Jump to content

Sign in to follow this  

Intermittent ATC communications

Recommended Posts


I have been fighting a intermittent problem with loss of communications.  For example, sometimes ATC calls to give me instructions, but I do not hear the audio.  Then the copilot may execute the command.  Sometimes I hear the ATC instructions, but the copilot does not respond.

I have trouble shot this problme for 3 weeks.  Here is some of the stuff I have tried.

1) Reinstalled RC three times- no fix

2) Tried different aircraft - same problem

3) As suggested in this forum I have set the audio, under communications to "Do Nothing" - no help

4) Defrag the hard drive - no help

5) Ran Norton clean disk - no help

Finally as a last resort, I had my Windows 7 computer check if there was a new driver available for the RealTek audio (mother board audio).  Windows found a updated driver and installed it.


I have posted this information so as to possible help some one else from spending as much time as I did trying to solve this issue.


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...