BMW969

P3D v4.5 FPS down

Recommended Posts

10 hours ago, BMW969 said:

I do not know how for you, but every additional FPS is dear to me.)  And minus 25-35% , this is critical!

Oh yeah its ruined and my local hubs EGKK and EGLL, I have been avoiding Heathrow since TE GB came out, as it was virtually unplayable.

 

I did do a clean install and removed all files from everywhere. Yesterday, I looked in the shaders folder and found to my amazement that i had some 3000+ files in there. I deleted them and so far the sim has only generated 450, but i saw no performance increase.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

With one monitor I have no problems, but with sourround and three Views the old problem ist back.

I use Prepare 3D Professional
The change from v4.4 to 4.5 works without problems.
The loading times are better, but I don't really care about them.

But the frames in 4.5 are unacceptable.
For comparison over 3 screens

All with addon airport and FTX GEN/GES

EDDP before 47 after 35
EDDB before 28 after 12!
LMML (my Development at this time) before 58 after 42

Back to 4.4, everything's fine.

And yes I know what I do, because I also develop.
Everything tested under unchanged same settings
My hardware

https://simmershome.de/pc-hardware-simmershome/

 

  • Like 1

Share this post


Link to post

I can report that I don't see any changes in performance (fps) at different locations including ORBX FTX regions.

Share this post


Link to post
15 hours ago, Chandler said:

yep, noticed a drop in FPS too, when ORBX stuff is installed, compared to 4.4.

Yes I too have installed the v4.5 updated and I'm disappointed. I'm getting lower frame rates than in 4.4, especially when doing a VFR flight with a chopper over London. I am running a triple monitor setup and with 4.4 it was still flyable over London. Now with 4.5 frame rates are dropping down to 10. 😪

Will do some more testing, but I'm seriously contemplating in switching back to 4.4.

Kind regards,

Share this post


Link to post
11 hours ago, Bert Pieke said:

If you are experiencing fps drop..

1. Did you delete your Shaders folder?

2. Are you using speedtrees?

In my case fps are unchanged and smoothness is better.

(Shaders deleted, and no Speedtrees in use).

Hi,

I deleted shadows folder and even the sceneryindexes_64 folder to no avail. Still a drop in FPS in comparison with v4.4? I've also completely deleted PrePaR3D.cfg file and that did not help either. Dynamic 3D Autogen Vegetation (speedtrees?) has always been off on my setup.

Kind regards,

 

Share this post


Link to post

Can't say I've noticed any difference in FPS either way, over both ORBX regions and photo scenery. Not flown with weather yet, I might do my stress test scenario in to Edinburgh in rubbish weather and see how it does

Share this post


Link to post
Posted (edited)

@davetfcCould it be the Windows 10 game mode? maybe others have this disabled for P3D, etc. while yours is active.

Can you try to disable the Game mode in your case and test again?

Also check if you have WPF hardware acceleration enabled or disabled, this is located inside the registry key: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics

Check if you have a key with the value DisableHWAcceleration = 1

Simbol

Edited by simbol

Share this post


Link to post

Is the FPS loss specific to VR and/or people utilizing triple monitors?  That seems to be a common theme? 

Share this post


Link to post
11 minutes ago, simbol said:

@davetfcCould it be the Windows 10 game mode? maybe others have this disabled for P3D, etc. while yours is active.

Can you try to disable the Game mode in your case and test again?

Also check if you have WPF hardware acceleration enabled or disabled, this is located inside the registry key: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics

Check if you have a key with the value DisableHWAcceleration = 1

Simbol

On the note of the hardware acceleration fix, do you know if that was sorted in 4.5, so we can use ReShade normally without disabling it?

Share this post


Link to post
Posted (edited)
2 minutes ago, Sethos1988 said:

On the note of the hardware acceleration fix, do you know if that was sorted in 4.5, so we can use ReShade normally without disabling it?

Beau said next version would have this sorted and I also use Reshade on my sim, but I haven't tested it yet to be honest, I have been putting other fires in the last 48 hours lol.

This weekend I might get a chance.

S.

Edited by simbol
  • Upvote 1

Share this post


Link to post

I'm using 5 monitors (3 for outside view and 2 for 2D panels) and have noticed a drop pf 10 fps going from 4.4 to 4.5.
I lock my frames at 24fps.

I deleted prepared.cfg, shaders dir contents and scenery index dir and rebooted prior to starting up 4.5.
I dont use speed trees nor any reshade tools.

Share this post


Link to post
1 minute ago, c912039 said:

I deleted prepared.cfg, shaders dir contents and scenery index dir and rebooted prior to starting up 4.5.
I dont use speed trees nor any reshade tools.

Despite of not using the reshade tools, can you check the registry entry I suggested? it is not related to Reshade it is related really to hardware acceleration for .NET WPF applications.

Also can you confirm your Nvidia drivers, game mode state, etc.?

We need to compile data to pass along to LM, saying it doesn;t work and just reverting back will not help anybody to get anything fixed or improved.

Regards,
Simbol

Share this post


Link to post
37 minutes ago, simbol said:

Beau said next version would have this sorted and I also use Reshade on my sim, but I haven't tested it yet to be honest, I have been putting other fires in the last 48 hours lol.

This weekend I might get a chance.

S.

Figured I'd quickly set it up and mess with ReShade. Now it behaves identical under 4.5 with hardware acceleration enabled, as it did with it disabled under 4.4, using Reshade 3.1.2. So it seems to have indeed been fixed.

  • Like 1

Share this post


Link to post
4 minutes ago, simbol said:

Despite of not using the reshade tools, can you check the registry entry I suggested? it is not related to Reshade it is related really to hardware acceleration for .NET WPF applications.

Also can you confirm your Nvidia drivers, game mode state, etc.?

We need to compile data to pass along to LM, saying it doesn;t work and just reverting back will not help anybody to get anything fixed or improved.

Regards,
Simbol

Game Mode State: States the PC supports Game mode, but there is no on/off toggle. All other related entries associated with the Gaming tabs in Settings are disabled where there is an option to do so.

Reg entry was not present, but I added the DWORD and rebooted and still experienced the same FPS drop.

Tests are done with weather set to clear skies
I have all traffic sliders at 0.
frames locked at 24 fps, no triple buffer, no Vsync, no FXAA, AA=4xMSAA

I notice the greatest drop at Aersoft EDDF and Aerosoft EGLL

8700k CPU overclocked at 5.2GHz, water cooled. (temps under P3D load are 48C deg)
3 x 3d monitors hooked up to GTX 1080Ti (water cooled), drivers 391.35
2 x 2d panel monitors hooked up to GTX 1050

 

Share this post


Link to post
8 minutes ago, c912039 said:

Game Mode State: States the PC supports Game mode, but there is no on/off toggle. All other related entries associated with the Gaming tabs in Settings are disabled where there is an option to do so.

Reg entry was not present, but I added the DWORD and rebooted and still experienced the same FPS drop.

Tests are done with weather set to clear skies
I have all traffic sliders at 0.
frames locked at 24 fps, no triple buffer, no Vsync, no FXAA, AA=4xMSAA

I notice the greatest drop at Aersoft EDDF and Aerosoft EGLL

8700k CPU overclocked at 5.2GHz, water cooled. (temps under P3D load are 48C deg)
3 x 3d monitors hooked up to GTX 1080Ti (water cooled), drivers 391.35
2 x 2d panel monitors hooked up to GTX 1050

 

Could it be the old drivers not taking advantage of 4.5 ?

Michael Moe

  • Upvote 1

Share this post


Link to post
2 minutes ago, Michael Moe said:

Could it be the old drivers not taking advantage of 4.5 ?

Michael Moe

+1

Also please remove the registry key about Hardware acceleration, not needed with 4.5, this does not requires a reboot.

Do you use also Nvidia Control Panel? 

Regards 

Simbol 

Share this post


Link to post
2 minutes ago, simbol said:

+1

Also please remove the registry key about Hardware acceleration, not needed with 4.5, this does not requires a reboot.

Do you use also Nvidia Control Panel? 

Regards 

Simbol 

Removed, no change

I do not use NVidia Control Panel

Share this post


Link to post
1 hour ago, kingm56 said:

Is the FPS loss specific to VR and/or people utilizing triple monitors?  That seems to be a common theme? 

I'm using a single monitor (2560x1600) and also have the FPS loss.

Share this post


Link to post
3 minutes ago, noisy said:

I'm using a single monitor (2560x1600) and also have the FPS loss.

Nvidia Drivers?

Share this post


Link to post
5 minutes ago, c912039 said:

Removed, no change

I do not use NVidia Control Panel

Rgr, did you update to the latest Nvidia drivers?

Share this post


Link to post
Posted (edited)

No frame loss here

  1. I uninstalled Client 4.4.
  2. I uninstalled content 4.4
  3. I installed client 4.5
  4. I installed content 4.5
  5. I removed some addons from the dll.xml and exe.xml, related to active sky, VRS and aerosoft recorder

SteamVR is OFF
NVIDIA Drivers 419.67

I did not delete any shareds nor change any settings, getting the same results as before. I do use processlasso otherwise my VR headset and frames are unstable.

In VR ~40fps no VR 100+fps

 

 

Edited by Hollywood

Share this post


Link to post
Posted (edited)

Can anybody having the FPS issues, test disabling the Nvidia high definitions sound devices? and retest please? be sure to be on the latest drivers as well.

Regards,
Simbol

Edited by simbol

Share this post


Link to post
14 minutes ago, simbol said:

Can anybody having the FPS issues, test disabling the Nvidia high definitions sound devices? and retest please? be sure to be on the latest drivers as well.

Regards,
Simbol

upgraded drivers to 419.67, disabled Nvidia hi-def sound drivers, deleted cache dir contents, rebooted and tested the same scenario, with no change in performance.

Share this post


Link to post
Posted (edited)
5 minutes ago, c912039 said:

rebooted and tested the same scenario,

How you disable the Nvidia hi-def devices? they always get re-enabled after reboot unless you uninstall the driver entirely.

Just check they remained disabled, but thanks for all your tests..

There is a topic in the LM forums about this: https://www.prepar3d.com/forum/viewtopic.php?f=6312&t=133165

It seems that if you have only 1 Monitor all is fine, multiple monitors this happens..

S.

Edited by simbol

Share this post


Link to post

Has anybody mentioned OS and OS version? - of late there has been a resistance of updating windows 10 and Nvidia drivers for various reasons.

I have the very latest build of Win 10 and I have not been able to detect any performance drop between 4.4 and 4.5   

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now