Jump to content

Sign in to follow this  
whamil77

Carenado Turbo Commander Mod v6.0

Recommended Posts

Hi Bill,

If I remember correctly, I initially used "Auto Start" for the beginning of my flight. At the end of the flight, I tried both left and right mouse click on the right engine control knob. It would not click to the off position--each time I tried to mouse click on the control knob it would move slightly but spring back to Ground position (engine running). In doing the same for the left engine shut down, clicked on the control knob and it went directly to the engine off position and the left engine shut down as it should. I will try another flight and this time go through the step by step procedure for start up.

Raymie

Share this post


Link to post
Share on other sites
8 minutes ago, toucanair said:

Hi Bill,

Thanks for the awesome mods,

I'm wondering if Raymie might be having some issues with the mod as he is using P3D V3.4 still. Could it be a platform conflict perhaps?

Also, I am using P3D version 4.5 now. 

Do you know if this mod is compatible, as I'm Getting CTD's on screen load it seems from a conflict with VFX (oldProp) immersion manager for some reason. I'm troubleshooting now to see where it may be coming from exactly.

Cheers T  

There were no changes that I know about in 4.5 that should affect the mod.  I experienced the CTD problems associated with the bad VR code when I tried to start 4.5, so I reverted back to 4.4.  I think LM has found the fix and I will load 4.5 sometime soon. 

Share this post


Link to post
Share on other sites
2 minutes ago, raymie said:

Hi Bill,

If I remember correctly, I initially used "Auto Start" for the beginning of my flight. At the end of the flight, I tried both left and right mouse click on the right engine control knob. It would not click to the off position--each time I tried to mouse click on the control knob it would move slightly but spring back to Ground position (engine running). In doing the same for the left engine shut down, clicked on the control knob and it went directly to the engine off position and the left engine shut down as it should. I will try another flight and this time go through the step by step procedure for start up.

Raymie

I used AutoStart and didn't have a problem.  If you interrupted AutoStart it could have stayed on the step that starts the right engine.  If that were the case, the switch would be "trapped".  I can insert a line that cancels AutoStart if it is interrupted and releases all the switches. 

Share this post


Link to post
Share on other sites

Hi Bill,

Just finished another test start, this time with the "cold and dark" set up that you have as a default setting after selecting the TC. Everything worked fine from engine start, taxi, to engine shut down. The right engine control knob worked fine in shut down. I used the scroll wheel on my mouse--control knob scrolled through each function from Ground to Engine Off. Left engine control knob worked fine as well.

Maybe there is something in the Auto Start function that is not correct, causing the initial situation that I experienced and previously described. I did select this time,  the aircraft with the more modern auto pilot panel (300). That should not make any difference I would suspect. Again, kudos for all your work in making this mod available for us. Makes the Carenado TC very enjoyable to fly.

Raymie

Share this post


Link to post
Share on other sites

My guess is that you somehow interrupted the auto start sequence at exactly the moment it put the switch in GND START RUN and it got trapped there.  You probably wouldn't ever see that again, but I will devise something that will keep it from happening. 

Share this post


Link to post
Share on other sites

Okay, here is what happened--just tried this again, here is the sequence of events.

--At the default "Cold & Dark" setting, I selected "Auto Start" When doing so, Both Auto Start and Step by Step Start "buttons" turned red in color. Don't know if that is correct or not.

--The right engine started first--and did so in a normal fashion, however and this is what I forgot initially--the left engine did not go through its start sequence and fire off. There's the interruption that you may be describing. This same thing happened to me initially on my first flight. 

--Without the left engine running as it never started (waited for it to do so for about a minute), I tried to shut down the right engine via the control knob--it was "trapped" as you described it. I tried mouse clicking on it and using the mouse scroll wheel. Just went ahead and shut down the sim just like I did initially.

If you are not having a problem with this and if no one else is reporting this as an issue, it may be my set up in P3D 3.4xx??

Raymie

 

Share this post


Link to post
Share on other sites

Hi Bill: I want to join the chorus thanking you for you great mods.  I clicked on the link to dropbox in the email you sent me, but a 404 message popped up saying that the file was not longer available.  Mike Gutierrez, North Hollywood, California


Michael Gutierrez. North Hollywood, California

Share this post


Link to post
Share on other sites

Hi Bill,

Just tried to open your email sent this week and the file is no longer there?

Thanks and regards,

expat

 

Share this post


Link to post
Share on other sites
Bill for the FSX SE lovers you can port some changes in the V6 to V5, 
For example, the changes in the FDE, the rpm, hp, FF adjust, the effect of the drag disk propeller when we cut the power on final (,this is really true, this behavior it's similar to the real, o the RL the 690, A,B need to land no less that with 150 200 HP. If not the plane when to the ground), the start locks reworked system, In the V5 if you put the prop on feather, there's no way to put back to normal if the plane is off, and the startup is done with the prop on feather (In the RL you know that you melt the turbine and the battery too) ....... The hydraulic system too if it's easy for you, I know that it's big thing, and work, but for the FSX Users still are a lot and we will happy if you do a 5.1 version..... 
 
That's changes for examples..... Can you take it of the V6 to the V5?
 
 I can live with the KFC 300 AP, and the lights mix panel cabin, and the press system bug,  without problem, 
 
Redgars
Robert Bernard

Share this post


Link to post
Share on other sites

Update Mod v6.1 on the street.  Includes the KFC-300 correction only.  Still assembling the remaining bug list for investigation.

Share this post


Link to post
Share on other sites
16 hours ago, whamil77 said:

Welp......Bad news.  This will simply not work with FSX.  All development and testing was done with P3Dv4.4.  The resulting models are beyond the scope of FSX.  I tried to re-compile them using the FSX SDK to no avail. I tried to convert the FSX version to include the details in the mod.  Still no luck.  I think there is some dividing line between the 64 bit and 32 bit versions that can't be crossed.  Anyway....very sorry.  

If you are an FSX user and discarded v5.0 please send me a PM and I will re-post v5.0 to Dropbox for you to download. 

Hi Bill,

I manged to make a full flight using FSX SE with mod v6.1, but falling back the interior model to v5.0 (A690_interior_GTN.mdl) and seems to be working fine. I'm using GTN LITE model options (except for the interior model) and GTN KFC300 panel options. However, I am not completely sure if all your enhancement in v6.1 are working properly for FSX SE. It seems so (I burned the engines exceeding POH procedures 😉). Would you recommend to keep this mod in FSX SE with the v5.0 interior model or just fall back to v5.0? I have v5.0 mod backed up.

Again thanks very much for your outstanding job!!

Best Regards,

Roberto

Share this post


Link to post
Share on other sites

Hi Bill:

All good with the v6.1 and the KFC-300 AP, now it's showing Ok.

Could you please check why the landing lights and extend/retract switches do not work?. I noticed this today.

Cheers, Ed


Ed Patino

P3Dv4.5 hf3 - Win 10 Home x64 // Rig: Corsair Graphite 760T Full Tower - ASUS MBoard Maximus XI Hero Z390 - CPU Intel i7-8086k 6-cores - 32GB RAM - MSI Nvidia GeForce GTX1080Ti 11GB - 3 x SSD x 1TB Crucial/Samsung + 1 x SSD 2TB Crucial + 1 HDD Seagate 2TB + 1 HDD External Seagate 2TB - Monitor LG 29UC97C UWHD Curved - PSU Corsair RM1000x - VR Oculus Rift // P3Dv4.5 hf3 - Win 10 Home x64 - Gaming Laptop CUK ASUS Strix - CPU Intel i7-8750H - 32GB RAM - Nvidia RTX 2070 - 2TB SSD - 2TB HDD // Thrustmaster FCS & MS XBOX Controllers

Share this post


Link to post
Share on other sites
1 hour ago, edpatino said:

Hi Bill:

All good with the v6.1 and the KFC-300 AP, now it's showing Ok.

Could you please check why the landing lights and extend/retract switches do not work?. I noticed this today.

Cheers, Ed

Bill's wired them to the default landing lights toggle.  Ctrl+L will now extend the lights and turn them on in one keystroke.  I find that quite helpful.

Share this post


Link to post
Share on other sites
2 hours ago, edpatino said:

Could you please check why the landing lights and extend/retract switches do not work?. I noticed this today.

Hi Bill,

I am having the same problem as quote above by edpatino. The mouse click spots do not work on all three switches--landing lights and the extend\retract switch. I get the switch "click" sound but no switch movement. I must use the keyboard functions to operate the landing lights and the extension\retraction operation.

Thanks again for all that you have done in your work, expertise and personal time to make these mods available for us to enjoy.

Raymie

Share this post


Link to post
Share on other sites

Every time I distribute this thing I forget to remove my own code for controlling the landing lights with FSUIPC. 

1.  Go to the main gauges folder and open the GAUGE_690B_mod folder.

2. Find the file "Gauge_UPDATE_DIG_2.xml" and open it with notepad or some other text editor.

3.  Scroll down until you see these lines:

--------------------------------------------------

<!-- For default VC landing light operation -->

<!-- (L:ASD_690B_SWITCH_LANDING_LIGHT_RIGHT,number) 0 ==
(L:ASD_690B_SWITCH_LANDING_LIGHT_LEFT,number)  0 == and if{
    (A:LIGHT LANDING,bool) 0 != if{ 1 (&gt;K:LANDING_LIGHTS_TOGGLE) } } els{
    (A:LIGHT LANDING,bool) 0 == if{ 1 (&gt;K:LANDING_LIGHTS_TOGGLE) } } -->

<!-- For assigning landing lights to FSUIPC landing lights switch -->    
        
(A:LIGHT LANDING,bool) 0 != if{ 1 (>L:ASD_690B_EXTEND) 1 (>L:ASD_690B_SWITCH_LANDING_LIGHT_RIGHT,number) 1 (>L:ASD_690B_SWITCH_LANDING_LIGHT_LEFT,number) (>K:LANDING_LIGHTS_ON) }
(A:LIGHT LANDING,bool) 0 == if{ 0 (>L:ASD_690B_EXTEND) 0 (>L:ASD_690B_SWITCH_LANDING_LIGHT_RIGHT,number) 0 (>L:ASD_690B_SWITCH_LANDING_LIGHT_LEFT,number) (>K:LANDING_LIGHTS_OFF) }

--------------------------------------------------------------------------------------------

To restore the normal clickable landing light switches change it to look like this (you can cut and paste from this page):

-----------------------------------------------------------------------------------------------

<!-- For default VC landing light operation -->

(L:ASD_690B_SWITCH_LANDING_LIGHT_RIGHT,number) 0 ==
(L:ASD_690B_SWITCH_LANDING_LIGHT_LEFT,number)  0 == and if{
    (A:LIGHT LANDING,bool) 0 != if{ 1 (&gt;K:LANDING_LIGHTS_TOGGLE) } } els{
    (A:LIGHT LANDING,bool) 0 == if{ 1 (&gt;K:LANDING_LIGHTS_TOGGLE) } }

<!-- For assigning landing lights to FSUIPC landing lights switch -->    
        
<!-- (A:LIGHT LANDING,bool) 0 != if{ 1 (>L:ASD_690B_EXTEND) 1 (>L:ASD_690B_SWITCH_LANDING_LIGHT_RIGHT,number) 1 (>L:ASD_690B_SWITCH_LANDING_LIGHT_LEFT,number) (>K:LANDING_LIGHTS_ON) }
(A:LIGHT LANDING,bool) 0 == if{ 0 (>L:ASD_690B_EXTEND) 0 (>L:ASD_690B_SWITCH_LANDING_LIGHT_RIGHT,number) 0 (>L:ASD_690B_SWITCH_LANDING_LIGHT_LEFT,number) (>K:LANDING_LIGHTS_OFF) } -->

------------------------------------------------------------------------

Save the file.  The clickable landing light switches will now work. 

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,170.00 of $25,000.00 Donate Now
×
×
  • Create New...