Problem with Pilot2ATC, GTN750 and the TBM900

Recommended Posts

Posted (edited)

Hi, My previous post got deleted because it was a duplicate of another post. Well it was because three developers are involved and I don't know which. Hopefully I won't get deleted again....

A few days ago I began to notice that Pilot2ATC was behaving strangely. On starting it, it wouldn't finish an ATIS report, stopping after a few words and then starting again. Finally, after getting clearance, the tower tried to hand me off to departure and after departure started to respond, tower came back and tried the handoff again. In short, the control would not pass to the next frequency. When the plane was stopped the frequency would swap back and forth between the COM1 and COM2 (which is why ATIS could never finish.) Then today, I had a flight in the Eclipse 550 where everything worked. Hmmm. Then I started a flight with the Socata and the problem was back. So I disabled all AI aircraft and turned off some other plugins that used the voice system. No cure. Then I changed to a plane that wasn't the Socata. Problem fixed. Back to the Socata, back to the problem. Pilot2ATC, Reality GTN 750 and the Socata TBM900 are fighting over the radio controls. 
Pilot2ATC is configured as always - I've used it for several years....
Reality GTN750 I use as a floating window in all my planes since I fly in VR and can control it easily with the controllers. When I saw this problem emerge, I updated to the latest version of the GTN. I even copied the RealityGTN.ini file to the Socata from the Epic 1000 where it works just fine.
The Socata is the variable that causes the problem. Any other plane works with the other 2 program settings identical.

Edited by Quijote

Share this post

Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!


There is nothing in the GTN which may cause this directly.

The GTN is in 'reading' and 'writing' the COM1/NAV1 or the COM2/NAV2 datarefs (whether how you'd configure the GTN) but it is never mixing both sets of datarefs (unless there is a bug but you'll see the problem with any aircraft).

Are you sure it is not swapping COM1(active)/COM1(standby) instead of COM1(active)/COM2(active)?




Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now