Chapstick

4.5 hot fix is out

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

Honestly, to me this is not a "hotfix", but a mere new version, as you basically have to go through all update steps again and again some addons might need an update to work properly. But still happy that it is finally out.

Share this post


Link to post
Just now, AnkH said:

Honestly, to me this is not a "hotfix", but a mere new version, as you basically have to go through all update steps again and again some addons might need an update to work properly. But still happy that it is finally out.

I don't think there will ever be a traditional hotfix without uninstalling and reinstalling.  

Share this post


Link to post

Just given it a try - still significantly lower FPS than 4.4

  • Like 2

Share this post


Link to post

4.4 seems like the place to stay then 

Share this post


Link to post

Im sorry but you cant base 5mins flying and then say its a poor update @srce

  • Like 5
  • Upvote 7

Share this post


Link to post
7 minutes ago, srce said:

Just given it a try - still significantly lower FPS than 4.4

Can it be that LM does not test before releasing a hotfix? Its hard to believe. I'll wait for more people to verify your finding..

  • Like 1

Share this post


Link to post
1 minute ago, BBoyJD10 said:

Im sorry but you cant base 5mins flying and then say its a poor update @srce

True enough, better off to install and draw you’re own conclusion 

Share this post


Link to post
5 minutes ago, BBoyJD10 said:

Im sorry but you cant base 5mins flying and then say its a poor update @srce

+1

Share this post


Link to post

Request. If you are going to install an update, take a screenshot or video of any scene (with FPS display)
After installing the update, download the same scene.
It will be clearly.

  • Like 1

Share this post


Link to post

......smug 4.4 user enters stage left with popcorn in hand :tongue:

  • Like 2

Share this post


Link to post
12 minutes ago, BBoyJD10 said:

Im sorry but you cant base 5mins flying and then say its a poor update @srce

GLOL. Will the FPS increase if I fly around for longer? 

6 minutes ago, Daedalus said:

Can it be that LM does not test before releasing a hotfix? Its hard to believe. I'll wait for more people to verify your finding..

Well, they didn't spot this problem in the initial 4.5 release!

Different people with different settings and setups may get different results. Some people didn't have a problem with the original 4.5 release. Try it and see for yourself. For me, it hasn't fixed the problem. FPS is still massively worse than 4.4.

Share this post


Link to post

What we need is a prepar3d vanilla mode. Like a windows safe mode.  Im willing to bet if p3d v4.5 is run vanilla default, it runs super great.  Addons and P3D have always been temperamental and any little switch, or misconfiguration somewhere, can make it all wacky. I run 4.5 with alot of the major addons and dont have any problems. FPS is roughly the same as it has always been relative to previous versions.  

Unfortunately there is no safe mode, so apart from disabling or uninstalling everything, theres no way to test that theory but I have a hard time believing that 4.5 is suddenly a massive fps killer. 

  • Like 1
  • Upvote 2

Share this post


Link to post
5 minutes ago, HighTowers said:

Unfortunately there is no safe mode, so apart from disabling or uninstalling everything, theres no way to test that theory but I have a hard time believing that 4.5 is suddenly a massive fps killer. 

Not even when they agree there is a problem and try to provide a fix for it? 😂

Share this post


Link to post
26 minutes ago, BBoyJD10 said:

Im sorry but you cant base 5mins flying and then say its a poor update @srce

I'll agree with you on that.  (from a sunlounger in 🇬🇩

Share this post


Link to post

Given that I wasn't having any performance issues with going from v4.4 to v4.5 i'm a little reluctant to install this so called "hotfix", I think i'm going to wait and see what the results are for people who weren't having issues with v4.5 after installing this fix.

One thing I did notice at the hotfix page is it says "The Prepar3D v4.5 update will require you to reactivate your product" which seems odd because I didn't have to re-activate after installing the first v4.5 client...

Share this post


Link to post

Think I might say with my 4.4....

Share this post


Link to post
13 minutes ago, srce said:

 

Different people with different settings and setups may get different results. Some people didn't have a problem with the original 4.5 release. Try it and see for yourself. For me, it hasn't fixed the problem. FPS is still massively worse than 4.4.

Both of myself and three friends had issues with 4.5 when using the fsl at Gatwick for example.  It was an absolute stutterfest for example. 

Also random freezes etc etc with autogen. 

Head over to the fsl forums you'll see people had issues. 

For me I'm thankful of the patch 

Share this post


Link to post
12 minutes ago, tooting said:

Both of myself and three friends had issues with 4.5 when using the fsl at Gatwick for example.  It was an absolute stutterfest for example. 

Also random freezes etc etc with autogen. 

Head over to the fsl forums you'll see people had issues. 

For me I'm thankful of the patch 

If it works? but let us know Pete when your back.

Share this post


Link to post

I'm presuming it's a full new installer? And therefore updates needed for chaseplane and and activesky etc etc

4 minutes ago, Nyxx said:

If it works? but let us know Pete when your back.

And on the initial 4.5 (before hotfix) there deffo was issues with certain systems

Share this post


Link to post

looks like some users need a HOTTER FIX to fix the HOT FIX😂

Share this post


Link to post
3 minutes ago, Arthur42417 said:

looks like some users need a HOTTER FIX to fix the HOT FIX😂

Since you apparently prefer FSX Steam, why does this even matter to you....😏

Share this post


Link to post
15 minutes ago, tooting said:

I'm presuming it's a full new installer? And therefore updates needed for chaseplane and and activesky etc etc

Pete, you can do the full installer, or just the client, which apparently addresses the quote, "performance issues seen on some systems and configurations" according to the hotfix page at LM. 

  • Upvote 1

Share this post


Link to post

It seems to me there is an addon that causes P3D to not launch after installing the hotfix. I haven't found it yet. When I launch P3D the splash screen appear and after a while it just disappears and I'm left with the desktop. 

Share this post


Link to post
2 minutes ago, Daedalus said:

It seems to me there is an addon that causes P3D to not launch after installing the hotfix. I haven't found it yet. When I launch P3D the splash screen appear and after a while it just disappears and I'm left with the desktop. 

If you have the Fsalbs, you should uninstall or deactivate it before starting P3D.

They are testing the build now and will release a new update soon.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now