Jump to content

GSalden

V4.5 : what has happened to Locked framerate ?

Recommended Posts

13 hours ago, Riah069 said:

OK thought i would share my findings and what i see.

Gsync on enabled both windowed and full screen

In game Vsync off and FPS capped on 33

And at this point i hate tweaking the CFG but i thought i would give Affinity MAsk a try and dialed in 62

This what i got with those settings, see pic.

I'm running a 8700k at 4.7. If some remember that i had REAL bad issues with running P3D at anything lower than 60 FPS when i was reading most people were getting (I hated these words) buttery smooth. But now after 4.5 hotfix with what i have done has given me that. Not going to use those words i still hate them 🙂 But again this is just me other users mileage may vary. No joysticks were broken during this test and post.

ns0oM2B.png

 

I can confirm good results with this AM. I had been using this with previous version of 4.0 and for some reason stopped, yesterday reinstating AM=62 for my non-HT 8700K @ 4.4Ghz. Glad I did...currently at FL350 over Central America. VSynch=on, TB checked, Unlimited, 4K at 30Hz. Flying an old 737-800 virtual cockpit in a TDS 787.     

Temps and usage:

Core 0=22%, 40C

Core 1=88%, 44C

Core 2=81%. 44C

Core 3=89%, 49C

Core 4=92%, 50C

Core 5=88%, 50C   

Smooth flight so far from KIAH...approach and landing yet to come into SEQM.

4.5HF1 client only.

Share this post


Link to post

Good to know mate. I'm not normally methodical tweaker. But thought i would give something different a try.

Share this post


Link to post
Posted (edited)

Sorry OP if i seem to hijack your thread in regards to your issue no offence intended.

Edited by Riah069
  • Like 1

Share this post


Link to post
8 hours ago, Chocorua said:

I can confirm good results with this AM. I had been using this with previous version of 4.0 and for some reason stopped, yesterday reinstating AM=62 for my non-HT 8700K @ 4.4Ghz. Glad I did...currently at FL350 over Central America. VSynch=on, TB checked, Unlimited, 4K at 30Hz. Flying an old 737-800 virtual cockpit in a TDS 787.     

Temps and usage:

Core 0=22%, 40C

Core 1=88%, 44C

Core 2=81%. 44C

Core 3=89%, 49C

Core 4=92%, 50C

Core 5=88%, 50C   

Smooth flight so far from KIAH...approach and landing yet to come into SEQM.

4.5HF1 client only.

I tried your AM setting, seems to work better, also I turned off Turboboost, something Jim Young recommended, and I feel I get smoother performance and a cooler running set of cores, I do not hear my fan stressing as much.  I used Throttlestop to turn off Turboboost since my BIOS is locked down, Throttlestop bypasses that.

John

  • Like 1

Share this post


Link to post
On 5/16/2019 at 3:32 PM, GSalden said:

Therefore I started to test with my 2 pc’s and found out that with Locked framerate , regardless of the settings , the main core shows a load of 100% which causes micro stutters ..

I just updated to 4.5 Client and Content with no AM in cfg and unlike previous versions I do not see any combination of Vsync On/Off and frame rate Unlimited/30, 31,32 (at 30Hz and sliders mostly right) that gives a permanent 100% core usage.

With all combinations core usage is very even across all cores with maybe core 4 and 6 (HT on) doing a bit more than the rest but usually no more than 60% max.

Pretty surprised at this considering how the previous versions behaved.

Only difference in practice with my V4.5 settings is that any setting without VSync ON causes stutters.

Not much conciliation to you I guess but I think it disproves the theory that the
main core of P3D is meant to run at 100% all the time.

gb.

Share this post


Link to post
3 hours ago, gboz said:

I just updated to 4.5 Client and Content with no AM in cfg and unlike previous versions I do not see any combination of Vsync On/Off and frame rate Unlimited/30, 31,32 (at 30Hz and sliders mostly right) that gives a permanent 100% core usage.

With all combinations core usage is very even across all cores with maybe core 4 and 6 (HT on) doing a bit more than the rest but usually no more than 60% max.

Pretty surprised at this considering how the previous versions behaved.

Only difference in practice with my V4.5 settings is that any setting without VSync ON causes stutters.

Not much conciliation to you I guess but I think it disproves the theory that the
main core of P3D is meant to run at 100% all the time.

gb.

Do you use a VC, as I saw posts from others who only experienced the 100% main core load with a Locked framerate in the VC, not in the 2D cockpit nor in spotplane

Share this post


Link to post

Installed the hotfix and no surprise, FPS did not change at all (where they were below my 30FPS limit without the hotfix) and the sim is still totally smooth. Did again not check the core0 load, but as long as everything is smooth, I could not care less about the actual load of my processor cores...

  • Upvote 1

Share this post


Link to post
1 hour ago, GSalden said:

Do you use a VC, as I saw posts from others who only experienced the 100% main core load with a Locked framerate in the VC, not in the 2D cockpit nor in spotplane

Yes I use the VC only.

gb.

Share this post


Link to post
1 hour ago, gboz said:

Yes I use the VC only.

gb.

Which aircraft do you use ?

All info will help. The Prosim flight model in VC , the PMDG VC and the FsLabs VC seem to put the main thread core at 100% 

Share this post


Link to post
Posted (edited)

FSLABS isn't compatible with 4.5 HF1 Gerard 😉 that's why I'm still at 4.4

Edited by awf

Share this post


Link to post
Posted (edited)

On my P3D 4.5 HF1.. the nVidia inspector locked fps at 30 does not work anymore also. Which is unfortunate, as with the fps locked in P3D menu it is not as smooth, it stutters more at panning. And CPU0 at full always also.

Edited by Vali

Share this post


Link to post
1 hour ago, Vali said:

On my P3D 4.5 HF1.. the nVidia inspector locked fps at 30 does not work anymore also. Which is unfortunate, as with the fps locked in P3D menu it is not as smooth, it stutters more at panning. And CPU0 at full always also.

Try RTSS instead of NVI as an external lock.

  • Upvote 1

Share this post


Link to post
2 minutes ago, Bert Pieke said:

Try RTSS instead of NVI as an external lock.

Unless you use 2D pop-ups then don't use them. Unless you want to loss 1/2 your FPS.

Share this post


Link to post
Posted (edited)
1 hour ago, Nyxx said:

Unless you use 2D pop-ups then don't use them. Unless you want to loss 1/2 your FPS.

Care to explain?

From your other posts, it would appear that you have two monitors and that is causing the issue.. :wink:

Edited by Bert Pieke
  • Like 1

Share this post


Link to post
Posted (edited)

My bad, stupid me.. I deleted the p3d cfg file so many times so that I forgot to change the line related to frame to average in it. So locked at 30fps it seems it keeps the fps at 31-32 fps (but still the average is fine). 

But when I changed for testing UIHardwareAcceleration=True to False, the in-game fps were up to 60 and not limited anymore, without any other change. And at 65 fps.. it stutters as at limited 30 fps. I do not understand it anymore...

One other point, as I am using 2 monitors, when I move the mouse to the other fps drops from those 60 at 30 fps in P3D (but that is probably due to multi monitor performance mode setting).

Edited by Vali

Share this post


Link to post
Posted (edited)
3 hours ago, Bert Pieke said:

Care to explain?

From your other posts, it would appear that you have two monitors and that is causing the issue.. :wink:

I’ve no need to as I did in the other topic.

Ok let’s nitpick if you have more than one screen RTSS cuts your  FPS in 1/2.

But ofc it’s the screen “issue “ not RTSS ^^

sweeping comments implying RTSS works for everyone, well it might If your only using one screen. But I lot of people use more than one these days.

As I found out opening pop ups destroy you FPS with RTSS.

But hey best not give the full picture! Since it’s two monitors that’s the “issue “ or is it that RTSS goes not work properly with two or more? 

 

Edited by Nyxx

Share this post


Link to post
1 hour ago, Nyxx said:

 

As I found out opening pop ups destroy you FPS with RTSS.

Actually, it would appear that placing your popups on your second monitor causes your fps drop.. call that nitpicking if you like :wink:

Share this post


Link to post
1 minute ago, Bert Pieke said:

Actually, it would appear that placing your popups on your second monitor causes your fps drop.. call that nitpicking if you like :wink:

Wrong

It happens the second I open one and that's on the same screen.

 

Share this post


Link to post
7 minutes ago, Nyxx said:

Wrong

It happens the second I open one and that's on the same screen.

 

OK.. that I do not see on my system..

Share this post


Link to post

nvm, all is working fine my end Just wanted to try RTSS out. Win some, lose some.

  • Like 1

Share this post


Link to post
Posted (edited)
3 hours ago, Nyxx said:

sweeping comments implying RTSS works for everyone, well it might If your only using one screen. But I lot of people use more than one these days.

I am using three screens (well, projectors, actually), and the RTSS frame limiter works fine for me. So it must be more than the number of screens.

Maybe it's also related to what's actually on them. Mine are just three scenery views, no cockpit, no gauges.

Also they are in nVidia Surround mode. Maybe that is the difference?

Pete

 

Edited by Pete Dowson

Share this post


Link to post
8 hours ago, Pete Dowson said:

I am using three screens (well, projectors, actually), and the RTSS frame limiter works fine for me. So it must be more than the number of screens.

Maybe it's also related to what's actually on them. Mine are just three scenery views, no cockpit, no gauges.

Also they are in nVidia Surround mode. Maybe that is the difference?

Pete

 

Is there a reason not to use Vsync + Unlimited Pete ?

I use it but see spiking ( 30-60 and back to 30 ) with 30 hertz + Unlimited

Share this post


Link to post

To me, those simmers still sticking to "unlimited" are those not yet ready to accept that it is not about FPS numbers but smooth visuals. It took me long to make the turn, but since I accepted that 22-24FPS on a heavy airport still somehow displayed smoothly is way more valuable than 30-35FPS on the same airport but stuttering like hell or dealing with other drawbacks like blurries, autogen popping etc.

  • Like 3

Share this post


Link to post
Posted (edited)
1 hour ago, AnkH said:

To me, those simmers still sticking to "unlimited" are those not yet ready to accept that it is not about FPS numbers but smooth visuals. It took me long to make the turn, but since I accepted that 22-24FPS on a heavy airport still somehow displayed smoothly is way more valuable than 30-35FPS on the same airport but stuttering like hell or dealing with other drawbacks like blurries, autogen popping etc.

Total agree with Chris, after making some changes for the good I am now down to 24 FPS, that's 20% less demand on FPS set to 30. Its shows, because you get no stutters and very smooth. Smoothness is key, not high FPS. But each to there own :) 

Edited by Nyxx

Share this post


Link to post
20 hours ago, GSalden said:

Which aircraft do you use ?

All info will help. The Prosim flight model in VC , the PMDG VC and the FsLabs VC seem to put the main thread core at 100% 

Just tried the PMDG VC and still an even spread across most cores.
Definitely none pegging out at 100%.

gb

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...