Jump to content

Sign in to follow this  
pietergoris

24 hours later....please please stop the suffering

Recommended Posts

I'm not uptodate with your install or any other posts...but I can assure you the gauge works great.

When I had a black screen issue it was related to ensuring I had the latest trainer installed..

Sometimes going right back to the start with a full reinstall fixes issues.

You can save your flightplans etc.

Bryan


Bryan Wallis aka "fltsimguy"

Maple Bay, British Columbia

Near CAM3

Share this post


Link to post
Share on other sites

OK, I recovered from backup. The previous (working) package is the one with C:\Program Files (x86)\Garmin\Trainers\Packages\GTN\bin\GTN Simulator.exe (6.50.10) which was installed with GarminTrainerSetup_2310.exe. This installer appears to be unavailable, and if you find one and run it. it shifts you over to _2400 anyway. If you have a system image backup, here's how to recover:

  1. Leave the latest Garmin Trainer (package 2.4.0.0) installed. You are going to replace the files with the earlier ones manually.
  2. In C:\Program Files (x86)\Garmin delete the Trainers folder and replace with the Trainers folder from your system backup. Verify that you  have reverted by looking at C:\Program Files (x86)\Garmin\Trainers\Packages\GTN\bin\GTN Simulator.exe for version 6.50.1.0 (hover with mouse or right click > Properties > Details tab).
  3. In C:\ProgramData\Garmin delete the Trainers folder and replace with the Trainers folder from your system backup. This folder is huge, it contains the Nav Data. I tried to run the old trainer with the new data, no go.
  4. Go to C:\Program Files (x86)\Garmin\Trainers\Packages\GTN\bin\ and right click GTN Simulator.exe, select Run as Administrator. Let it open, give it a few secs then close the GTN. It will not start.

After doing this, my  RXP GTN came up in all three aircraft in which I have it installed.

Edited by Bob Denny
  • Like 1

Share this post


Link to post
Share on other sites

I have the F1 setup.  Part of the issues seen are Trainer related specifically not the gauge.  Does the Trainer open and function by itself outside of the Sim? If it doesn't then the problem is definitely there.  I had this exact problem plague me for weeks, couldn't figure it out.  What it boiled down to was having software that allowed my iPad to be used as a secondary display. My intent was to use the 750 on my iPad.  Well turns out this completely screws up the trainers software.  The program to enable the secondary display didn't even need to be running to screw up the trainer, just it being on my computer was enough.  

So, do you have any such software on your desktop? Did the gauge work at some point and it stopped working after your installed something else?  Like I said, this is a really finicky piece of software.


Brian Thibodeaux

beta.gif   30557299837_a933ac6804.jpg 

My Liveries

B747-400/8 First Officer, C-130 Flight Engineer, ATP, CFI

Share this post


Link to post
Share on other sites

Did you guys install the trainer?

 

I had the issue where the trainer wouldn't download so I went out and got it from Garmin.

Share this post


Link to post
Share on other sites

Yeah I figured it out last night. You can't get trainer 2310 anymore which is what the install is trying to download. Ridiculous that they haven't fixed that.

So I actually downloaded 6211 and installed it. never uninstalled 2400. But it works fine now.

 

Share this post


Link to post
Share on other sites

You should be able to copy the content of the "Databases" folder from version 2400, into the "DB" folder from the 6.21. Then it should give you the 1809 navigation database in your GTN. Not sure if that leads to problems somewhere along the way. But if something goes wrong, you can always get back to your 6.50 version.

Share this post


Link to post
Share on other sites

Check the Trainer version. Garmin released 2.4.0.0 on June 19. The RXP hasn't been updated for it yet.

Edited by DavidP
  • Like 1

David Porrett

Share this post


Link to post
Share on other sites

Thank you everyone for the replies.  I have the trainer, v2.4 installed. 

However it is not on the same drive as X-Plane....does that matter?

Also, I have been able to open the trainer and use it no problem, outside of X-Plane...however when I open the 750 inside X-Plane the screen is black and it doesn't respond to anything.

Share this post


Link to post
Share on other sites
2 hours ago, EsqFlyer said:

I found the new trainer download: https://www8.garmin.com/support/download_details.jsp?id=12373  Install it and then re-install the GTN addon but select NOT to install the trainer (since you'll have it installed already) and that should work.

thanks for your post.  i just downloaded the trainer and run the installer.  the GTN750 is now available in plugins, but doesn't seem to turn on.  does the trainer download have to be in a particular directory or is it something else?  any help you could offer would be greatly appreciated.

Share this post


Link to post
Share on other sites

Ty to install an older version of the Garmin trainer, instead. I had the same problem after reinstalling my system yesterday, and downloading version 2400. So i went to the Garmin site and found version 6.21.1 ( https://www8.garmin.com/support/download_details.jsp?id=9256 ). Then I copied the content from the "Database" folder of version 2400 into the "DB" folder of version 6.21. Now my GTN works, showing a navigation database 1809. Afterwards I took a flight, and it seemed that everything was working. But naturally, this is only an experiment that could crash at any time. And i'm also unable to tell, if the database is really the one it shows on the screen.

Share this post


Link to post
Share on other sites

sspeter78 the 2.4 version won't work that we are sure of. It's not supported yet by Reality XP.
About the drive I'm unsure but download the following trainer and uninstall the 2.4 version to be sure:

https://www8.garmin.com/support/download_details.jsp?id=9256

It's an older database from 2016 but you can update that later and it does function properly.

Also make sure to go to the plugin settings in X-Plane 11 and set the GTN750 as your master and set the power as 'always on' or to your avionics bus. Otherwise it probably will keep giving a black screen.
Hope this helps for you.

Share this post


Link to post
Share on other sites

Hi,

please see this:

 


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    2%
    $740.00 of $25,000.00 Donate Now
×
×
  • Create New...