Jump to content
Sign in to follow this  
E69_Brisafresca

Is P3Dv4.5HF1 finally better performance than P3Dv4.4?

Recommended Posts

Hello

I have been with P3D uninstalled for a while and I will start installing it again with my add onds, with P3Dv4.4 I had a great performance, but I was wondering if finally P3Dv4.5 Hotfix 1 is better performance and if all the add onds are already compatible with 4.5hf1.

Thank you

Share this post


Link to post

In general yes and yes.

Go for it you won’t be sorry if you enjoyed P3D in the past.

Joe

  • Like 1

Joe (Southern California)

SystemI9-9900KS @5.1Ghz/ Corsair H115i / Gigabyte A-390 Master / EVGA RTX 2080 Ti FTW3 Hybrid w 11Gb / Trident 32Gb DDR4-3200 C14 / Evo 970 2Tb M.2 / Samsung 40inch TV 40ku6300 4K w/ Native 30 hz capability  / Corsair AX850 PS / VKB Gunfighter Pro / Virpil MongoosT-50 Throttle / MFG Crosswind Pedals /   LINDA, VoiceAttack, ChasePlane, AIG AI, MCE, FFTF, Pilot2ATC, HP Reverb G2

Share this post


Link to post

IMO yes. Still get an occasional pause for a few seconds when loading a large addon airport especially if it's FSDT.


Vic green

Share this post


Link to post

Am I right to assume the packages in the prepar3d website include the hotfix? 


Ahmet Can

Share this post


Link to post
2 hours ago, costamesa said:

Am I right to assume the packages in the prepar3d website include the hotfix? 

Correct.

The actual release is called V4.5.12


Bert

Share this post


Link to post
16 hours ago, Bert Pieke said:

Correct.

The actual release is called V4.5.12

Thanks


Ahmet Can

Share this post


Link to post

Quick question.  I am already on v4.5. To update hf1 do I need to install client only or do I need to also install other components? Do I need to update other addons as well?


Bilal Asif Khan

Share this post


Link to post

Thank you so much all for the comments

If I install p3dv4.5hf1, can I go back to install p3dv4.4 later without problems?

On the other hand, are most of the add ons compatible with p3d4.5hf1 already?

Is there an important add on not yet updated to p3dv4.5hf1?

Many add ons only indicate that they are compatible with p3dv4 or p3dv4.4 + :blink:

Thanks

Edited by E69_Brisafresca

Share this post


Link to post
1 hour ago, biloo said:

Quick question.  I am already on v4.5. To update hf1 do I need to install client only or do I need to also install other components? Do I need to update other addons as well?

Client only..


Bert

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...