Jump to content

Skyseek

Simconnect / Windows 10 Upgrade Breaks Network Sharing

Recommended Posts

It seems like EVERY TIME Microsoft upgrades Windows 10 it breaks the networking so products like Active Sky Next won't work via the network (FRUSTRATING!).  Does anybody know of a FSUIPC weather add-on that I can use that isn't reliant on Network shares and Simconnect like Active Sky Next?  I have already written to Damian of Active Sky to convert the AS line over to FSUIPC.

Anyone else having this issue with Simconnect / Windows 10 Networking??

Thanks!

Share this post


Link to post
Share on other sites
31 minutes ago, Skyseek said:

 

Anyone else having this issue with Simconnect / Windows 10 Networking??

 

I've never had any issues with Networking and Microsoft updates/upgrades with regards to Simconnect or Network shares. I've always have run Active Sky, ATC-X on a secondary PC.

Whenever I do have an issue, it's always a firewall setting. I don't use the built in firewall that comes with Windows 10. If you are, maybe it gets re-set when doing an Windows upgrade. Just a thought. 

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks for the reply.

It was working fine until Windows 10 performed an update.  Now AS Next can’t find the network shares at all!

 

i will check the firewall.

 

Thanks again. 

Edited by Skyseek
Content

Share this post


Link to post
Share on other sites

The most common change I’ve seen after updates is the network mode being changed to Public. Check this and make sure it’s set to private.

Cheers

David.

Share this post


Link to post
Share on other sites

The most common issue I have when Win 10 installs an update is that it turns off simple file sharing support. 

Go to Control Panel -> Programs and features -> Turn Windows Features on/off

Ensure that SMB 1.0/CIFS File Sharing Support is enabled.  Every Win 10 update since 1803 has turned it off on me and screwed up my network shares.

Regards

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks everyone!

 

Well after researching,

This article seemed to have the resolution.

https://support.microsoft.com/en-us/help/4092694/windows-10-file-sharing-over-a-network

Make sure the computers are on the same network. For example, if your computers connect to the internet through a wireless router, make sure they all connect through the same wireless router.

If you're on a Wi-Fi network, set it to Private. To find out how, read Make a Wi-Fi network public or private in Windows 10.

Turn on network discovery and file and printer sharing, and turn off password protected sharing.

Select the Start  button, then select Settings  > Network & Internet , and on the right side, select Sharing options.

Under Private, select Turn on Network discovery and Turn on file and printer sharing.

Under All Networks, select Turn off password protected sharing.

Make sharing services start automatically.

Press the Windows logo key  + R.

In the Run dialog box, type services.msc, and then select OK.

Right-click each of the following services, select Properties, if they're not running, select Start, and next to Startup type, select Automatic:

Function Discovery Provider Host

Function Discovery Resource Publication

SSDP Discovery

UPnP Device Host

Bookmark this page, very helpful!

Edited by Skyseek

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...