Skywolf

Autogen Draw Distance just drops fps - any solutions?

Recommended Posts

Hi,

So, I have a pretty beefy system (even though it is few years old) - i7-5820K OC 4.5Ghz with 2070-Super and with 16GB DDR4 Ram - running on 4K

Does Prepar3d 4.5HF1 do something strange with Autogen Draw Distance? if I just increase this slider from default medium to High - I lose around 10 fps approx right of the bat - this is even with Trees and Buildings set to Normal (default values).

 

Now if Leave Auto gen Draw Distance to default and load up (pretty much maximize it) the trees and building autogen, My FPS drop is hardly noticeable.

 

Could the issues be related that I am on 4K resolution?

 

This is with No addons - running bare p3d4.5hf1

 

I Hope LM can release HF2.  They released hotfix 1, hopefully hotfix 2 is close by lol 🤣  

Edited by Skywolf

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Autogen along with Airborne/Road traffic AI are the biggest FPS eaters. Turn off Traffic and see what happens with the auto-gen. You simply can`t have your cake and eat it too in P3D. I know this sounds pessimistic. As much as I love P3D, it`s very nature is bi-polar. It`s the nature of the beast we all relentlessly pursue hoping one day something better will come along.

Cheers. . .Lol.

Share this post


Link to post

I have zero traffic AI and zero road traffic right now.

 

Isn't there a manual tweak to increase autogen draw distance.  Trying to figure that one out too.

Edited by Skywolf

Share this post


Link to post
7 minutes ago, Skywolf said:

isn't there a manual tweak to increase autogen draw distance.  Trying to figure that one out too.

I think the bigger question is, why do you want to increase it?

Share this post


Link to post

What I mean is, are you getting popping and seeing the end of your autogen?

Share this post


Link to post

The recommendation is to leave this setting on Medium.

If you increase it, you will start to get popping autogen etc.. not worth it!

  • Like 1

Share this post


Link to post

Medium is looking like the best solution, as I have the most fps at this setting.  I hope LM can do new things for HF2 or whatever they release next.  Sigh

Share this post


Link to post
15 minutes ago, Bert Pieke said:

The recommendation is to leave this setting on Medium.

If you increase it, you will start to get popping autogen etc.. not worth it!

Bert is right. Myself, I always have the AG DD at Medium with both AG buildings and trees set to Very High.

No AG popping up 😎

Share this post


Link to post

I agree. Auto-gen best left on medium to never touch again. I have 1080ti, plus 32 MB Ram, 8700K and the auto still "pops" over medium. I have learned to live without it. I also force myself to turn off the FPS counter and just fly now. Full auto-gen is for "screen-shot" artists.

Edited by Ezra
  • Upvote 1

Share this post


Link to post

I have mine set to Medium, and I don't see the end of the autogen.  That would make a nice realistic screenshot.  Not this 50 nm low-level visibility I've seen people use in their sim.

Share this post


Link to post

I found auto-gen at medium best around some airports because if you have it set larger you are more apt to get those tree-guardians at both ends of runways at the lesser airports. I don't miss anything from the higher settings.  

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now