Jump to content
Sign in to follow this  
schepma

Confused - suddenly frequent CTD with Real Traffic

Recommended Posts

Hi Nico,

as the title suggests,I'm a little bit confused. I have been using your excellent program for a quite a while now and never had any problems with it. I'm running P3D 4.5 together with the FLAi package.

But a few days ago, I noticed a CTD shortly after takeoff. At that time I had no idea what caused it. So I restarted the flight and it happened again, this time it occured while still standing at the gate. So I started troubleshooting. In addition to PSXT I have Active Sky and Aivlasoft EFB v2 running in the background. The installation of EFB v2 was a change in setup, so next time I didn't use it. But again, the CTD occured after a couple of minutes running Active Sky and PSXT. Then I stopped using Active Sky. And voilà, I was able to complete the flight. So I thought that I nailed down the issue. But the joy didn't last very long - on the return flight the crash occured again.

So I decided to stop using PSXT and turned Active Sky back on. No CTDs on many consecutive flights. Then I also turned EFB back on and again, no problems.

But as soon as I start PSXT, it is only a matter of time until a CTD occurs. This is really making me confused - I don't think that your software can be blamed for this because it is an external process running outside P3D (and it never crashed when P3D crashed).

I can only think of 2 reasons:

1) there might be a faulty aircraft in the FlAi package causing P3D to crash 
2) a Simconnect problem (maybe the parallel use of Active Sky and PSXT is flooding the Simconnect pipe? - but it never happened before)

Do you have any further ideas? The CTDs occured with versions 15.10 and 15.14, FlAi was updated to build 18, if I recall correctly.  Is there a way to scan the FlAi library for faulty aircraft or liveries?

Best regards,
Dirk

 


Dirk Schepmann
Münster, Germany (EDDG)

Flight simulation enthusiast since 1993
Favorite Aircraft: PMDG 747-400 QoTS II, PMDG 777, FSLabs A320, Majestic Dash Q400 and Aerowinx PSX

Share this post


Link to post
Share on other sites

Hi Dirk,

Post your Log.txt please. I think a livery could not have been  created, but you can find that info in the Log.

Did you have had a look at it?

Nico

Share this post


Link to post
Share on other sites

Hallo Nico,

This is also happening to me.  II am using FLAi, ASN and P3DV4.5.  I did  a couple of flight from EDDF to EDDB and in midflight a CTD.  On another flight from EDDF to EDDB I turned on PSXT mid way and then the flight continued without a hitch. Later I parked the plane on EDDF and then after some 15 minutes a CTD.  It looks to me that one of the AI planes is causing trouble.  I will post a log next time it happens.

Best regards,

--pim

Edited by pvrijald

Pim van Vrijaldenhoven

Share this post


Link to post
Share on other sites

I checked the log files but there is no hint at all (I can post it if you want). There was only one livery which couldn’t be created (a CFG 767 with the reg. D-ABUK) and that occurred 10 minutes before the CTD. No other fault messages except that the connection to P3D was lost.

In the Windows 10 logs, a NTDLL error was recorded. 

I‘ll now update my NVIDIA drivers and reduce some settings first and then try it again. 

I still suspect a particular aircraft in the FLAi package, though. Perhaps it was created but incompatible? This would also explain Pim‘s observation as we were both flying in roughly the same region (the CTDs happened when I was flying from EDDK to EDDP and EDDG - EDDN). 

Best regards,

Dirk

Edited by schepma

Dirk Schepmann
Münster, Germany (EDDG)

Flight simulation enthusiast since 1993
Favorite Aircraft: PMDG 747-400 QoTS II, PMDG 777, FSLabs A320, Majestic Dash Q400 and Aerowinx PSX

Share this post


Link to post
Share on other sites

Remove the livery that could not be created from your Simulator, please.

Question for clarification: you are talking about a Simulator CTD, are not you?

Edited by kiek

Share this post


Link to post
Share on other sites

i have the same problem that P3D v4 is shutting down after 15 - 30 minutes on the ground.

how to remove the livery that can not be created ?

thanks,

Share this post


Link to post
Share on other sites
21 minutes ago, axel737 said:

how to remove the livery that can not be created ?

Delete the [fltsim.x] section with the livery title from the aircraft.cfg file for the aircraft type of the livery. 

Share this post


Link to post
Share on other sites

I have the same problem, and noticed on taxy out that one FLAi aircraft was black, but i didn't think to identify it. P3Dv4 crashed shotly after, second time of doing it.


Rob Jones.

Share this post


Link to post
Share on other sites
6 hours ago, axel737 said:

ok, is that in the traffic folder in psxseecon ?

No, in your FlightSimulator where the FLAi package is installed.....................

 and don't forget to renumber the [fltsim.x] sections so that they are consecutive (no holes). Their are tools for that to.

Edited by kiek

Share this post


Link to post
Share on other sites

Hi Nico,

regarding your question: yes, P3D is crashing, PSXT keeps running as if nothing happened. It is very stable, I think.

Maybe it's worth mentioning that the majority of aircraft which couldn't be created are 767-300. And most of them have a specific registration added to the AI_liveries.xml file, e,g,

    <livery airline="CFG" type="B763" folder="1" title="FLAi_B763_CFG-Condor NC D-ABUA" atc_id="D-ABUA" />
    <livery airline="CFG" type="B763" folder="1" title="FLAi_B763_CFG-Condor OC D-ABUK" atc_id="D-ABUK" />
    <livery airline="CFG" type="B763" folder="1" title="FLAi_B763_CFG-Condor Retro D-ABUM" atc_id="D-ABUM" />

Here's the relevant section of the log file:

Spoiler

*************************************** live traffic livery matching summary ***************************************

Tue Aug 20 21:21:34 2019 (utc)
165 liveries needed
67% (111) were completely matched, of which 1% (2) upon registration code (r), of which 100% (2) exact (R)!
16 liveries could not be created:
  CFG B763 "FLAi_B763_AJT-Amerijet N316CM"
  CFG B763 "FLAi_B763_CFG-Condor NC D-ABUA"
  CFG B763 "FLAi_B763_CFG-Condor OC D-ABUK"
  CFG B763 "FLAi_B763_CFG-Condor Retro D-ABUM"
  CFG B763 "FLAi_B763_DAL-Delta NC PW N198DN"
  CFG B763 "FLAi_B763_FDX-Fedex N68079"
  CFG B763 "FLAi_B763_UAL-United SA N653UA"
  CFG B763 "FLAi_B763_X N767S"
  CFG B763 "FLAi_B764_DAL-Delta ST N844MH"
  CFG B763 "FLAi_B764_UAL-United NC N77066"
  CFG B763 "FLAi_B764_UAL-United SA N76055"
  ELY B763 "FLAi_B763_ELY-El Al 4X-EAP"
  KLM E75L "FLAi_RAI_E75L_KLC-Cityhopper PH-EXG"
  KLM E75L "FLAi_RAI_E75L_RPA-Republic UAL N434YX"
  LOT E170 "FLAi_RAI_E75S_LOT LII SP-LII"
  MGL B763 "FLAi_B763_MGL-Miat JU-1021"
 =g= 17 generic liveries generated for unknown airlines
 =s= 10 liveries for airline and similar type generated
 =x= 18 random liveries for type
 =X= 9 random liveries for similar type

The missing liveries were for the following airlines and type codes:
  AAB CL35
  AFR E190
  AUA E195
  AZA E190
  BUC MD82
  CFG B763
  CND B738
  DLH A20N
  DLH CRJ9
  DLH E190
  EZY A20N
  IRA A332
  JAF B737
  KLM E190
  KLM E75L
  LGL CRJ7
  MGL B763
  MSR B789
  OHY A332
  PGT A20N
  SDR A320
  SWR E190
  SXS A320
  TFL A320
  TFL B738
  WUK A321
  WZZ A21N
********************************************************************************************************************

 

I don't know if this can crash P3D to crash, but perhaps it helps to further improve the model matching.

I'll now try to run PSXT with a different set of AI aircraft and see what happens. If there is no CTD in P3D, the fault must be somewhere in the FLAi package. As axel737 pointed out, I never had any problems until I installed the FlAi v18 package.

Best regards,
Dirk


Dirk Schepmann
Münster, Germany (EDDG)

Flight simulation enthusiast since 1993
Favorite Aircraft: PMDG 747-400 QoTS II, PMDG 777, FSLabs A320, Majestic Dash Q400 and Aerowinx PSX

Share this post


Link to post
Share on other sites

correct, also problems with the 767 liveries, as the post above.

but i also use the FlAi v18 since i started using psxseecontraffic and had never problems until now.

to Dirk : what other AI program do you also use ?

Share this post


Link to post
Share on other sites
11 hours ago, axel737 said:

Ok but it worked without problems before, earlier updates

That's no guarantee it will work with future updates. The FLAi package gets updates and the AI_liveries.xml in installed_liveries was updated recently too, so it will make use of more corners of the FLAi package.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...