ttbq1

Stutters revisited.......

Recommended Posts

On 9/7/2019 at 9:30 AM, Rob_Ainscough said:

Hi Bernd,

Sources for regular stutters are numerous.  I am a little puzzled when you indicated you didn't notice any difference going from 8XMSAA to 8XSSAA?  Even on my Titan RTX I notice a performance difference with 8XSSAA (at 4K res).

Regardless I would approach your problem but doing the following:

1.  Disable every add-on including checking you DLL.XML and EXE.XML files (there can be two of them in different folder locations).

2.  With all add-ons disabled check to see if you still have the same regular stutters using a default P3D aircraft (F22).

3.  If you still have regular stutters then disable any 3rd party entries in your scenery.cfg and test for stutters again.

4.  If you still have stutters then make sure you don't have any external processing running ... create Windows 10 defender folder exceptions and/or whatever anti-virus software you use be sure to add folder exceptions for that also ... any folders that contain your P3D files.

5.  Don't use Process Lasso, there is no need with P3D V4.x

6.  Disable HT (hyperthreading) via BIOS.

7.  If you have an ASUS motherboard or any motherboard that has RGB Lights ... disable the LightingServices or set it to static ... there is a know bug in LightingServices that can consume considerable CPU processing time.

8.  Run taskmgr while you run P3D and monitor applications running and see if you notice an correlation in CPU spikes to other applications/service running in TaskMgr.

9.  Delete your shaders folder, sometimes these get corrupted if you have BSOD or hard lockup.

10.  Disable your 9900K overclock, disable and GPU overclocking ... run Prime95 for 30-60 mins to make sure you aren't getting any errors.

11.  Make sure all your drivers are up to date and watch out for a Windows 10 bug that seems to have affect many with high CPU utilization (see article HERE).

Unfortunately there is no magic solution, but if you've disabled everything in P3D and still get stutters then it's likely some external influence.  OC can be a source of stutters ... if you ever see any DEVICE_HUNG errors those are usually GPU related to OC.  But the basic diagnostics process is to remove and many variables as possible and "hope" the stutters go away ... then (and only then) start to re-enable one by one testing P3D each time until you isolate the source of the stutters.

Can be a long and tedious process, but may ultimately be rewarding once you identify the issue.

Cheers, Rob.

EDIT: as noted by Rhett, 30 Hz monitor Refresh is a more reliable path to smooth consistent FPS.

Hi guys I really need your help.

After the summer break I came back home a when I start using my P3D V4.5 FSLabs A320X I started noticing my FPS were around 10-15 when they were usually at 30FPS. And the a 2 weeks nightmare began. I ended up uninstalling everything, even my windows 10 PRO.

After reinstalling latest BIOS, Windows, Drivers, P3D V4.5 Vanilla, I was getting no more than 40FPS in the default situation, I used to have around 200fps. 

I noticed my core 0 was at 100% and the rest of the cores between 0% and 5% (I currently have a 9700K not overclocked, GTX 1080Ti, 16RAM).

So, while sitting in the cockpit, I went to "set Affnity" in the task manager and disable the Core 0, and my FPS return to 180fps. Please check the following video:

Do you guys know what is going on here? and please help me find a fix to my problem, there should be a problem, I shouldn´t have to do this process everytime I want to fly. Also, I don´t want to run my sim with affinitymask=254 which will disable core 0. I didn´t need that before.

Thanks everyone for your help, I am really desperate here to be honest.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I guess it is related to this Windows 10 bug hammering core0. Guess you have to wait for the hotfix or use one of the workarounds you find in the net.

Share this post


Link to post

The last thing anyone needs when running a flight simulator is an OS bug. It's hard enough getting P3D to run smooth without unwelcome help from elsewhere :dry:

  • Like 3

Share this post


Link to post
3 minutes ago, Christopher Low said:

The last thing anyone needs when running a flight simulator is an OS bug. It's hard enough getting P3D to run smooth without unwelcome help from elsewhere :dry:

So very very true ...

It is the first time I hear from this bug. How can I proof that my system is affected or better NOT affected?

Share this post


Link to post
1 hour ago, ttbq1 said:

Hi guys I really need your help.

After the summer break I came back home a when I start using my P3D V4.5 FSLabs A320X I started noticing my FPS were around 10-15 when they were usually at 30FPS. And the a 2 weeks nightmare began. I ended up uninstalling everything, even my windows 10 PRO.

After reinstalling latest BIOS, Windows, Drivers, P3D V4.5 Vanilla, I was getting no more than 40FPS in the default situation, I used to have around 200fps. 

I noticed my core 0 was at 100% and the rest of the cores between 0% and 5% (I currently have a 9700K not overclocked, GTX 1080Ti, 16RAM).

So, while sitting in the cockpit, I went to "set Affnity" in the task manager and disable the Core 0, and my FPS return to 180fps. Please check the following video:

Do you guys know what is going on here? and please help me find a fix to my problem, there should be a problem, I shouldn´t have to do this process everytime I want to fly. Also, I don´t want to run my sim with affinitymask=254 which will disable core 0. I didn´t need that before.

Thanks everyone for your help, I am really desperate here to be honest.

I have run 4.5 / Win10 w/HT on, with core 0 disabled for quite some time. Given the time and effort already expended, you might consider running 254 whether you had to do that before or not.

Cheers,

Mark

Share this post


Link to post
7 minutes ago, Christopher Low said:

The last thing anyone needs when running a flight simulator is an OS bug. It's hard enough getting P3D to run smooth without unwelcome help from elsewhere :dry:

I have uninstalled and installed Win10 1903 and 1809 both twice, and run the latest windows updates (without jumping from 1809 to 1903) with no luck. Same behavior.

 

Share this post


Link to post
1 minute ago, newtie said:

I have run 4.5 / Win10 w/HT on, with core 0 disabled for quite some time. Given the time and effort already expended, you might consider running 254 whether you had to do that before or not.

Cheers,

Mark

my 9700k doesn’t have HT, so I only have 8 cores, affinity mask will disable core 0 leaving me with only 7 cores.

I have tested yesterday and the FPS are back to normal. but I would prefer to fix the problem and run my 8 cores the way I used to do it before my break.

 

 

Share this post


Link to post

Hi,

I bet no one has an explanation for my stutter experience; I know I don’t although, thankfully, I do have a simple solution:

Since v4.4 my Prepar3D installation can experience a regular brief single hitch/stutter, occurring at 3 second intervals, and observed while rolling down the runway and continuing throughout the duration of that flight session.

While barely noticeable the presence of this stutter is sufficient to ruin immersion and so the flight is quickly terminated.

Since this started I have developed the habit of switching to Slew mode immediately after the chosen Scenario is configured and loaded and, while the a/c remains static on the ground, start a slow 360 degree turn in either direction. If these regular stutters are noted I know it’s pointless to continue as there appears to be no way of ridding P3D of these hitches during that particular session, and so it is aborted.

These stutters may or may not be present at the start of an initial P3D session. When present, restarting P3D on its own does not eliminate these stutters. When absent, the initial and subsequent sessions, no matter how long, will remain impressively fluid and stutter-free. To date no 3rd Party product has been identified as being the cause nor does the choice of GPU driver have any influence on what appears to be a random occurrence.

The solution: What does work every time is either 1) A System Restart or 2) Logging OFF and then back ON. The latter is preferred as it’s quicker.

These regular stutters, when present, were first observed following a clean v4.4 install and now persist in v4.5. The solution is always the same.

Windows 7 Pro 64bit.

Regards,

Mike

Share this post


Link to post

I see that there are some Corsair processes running in the background. Are you using iCue software. iCue 3.19.120 has introduced an issue where core 0 is hammered with hardware interrupts. If that is you, then downgrade to 3.18 or just try out with iCue uninstalled. It looks exactly like that because your system interrupts process is also running high. 

Edited by Evros

Share this post


Link to post
7 hours ago, ttbq1 said:

Do you guys know what is going on here?

Do you run a lot of AI traffic or Road Traffic or Boat Traffic?  Also, from the screenshot you seem have your audio disabled?  Is that intentional?

In addition, did you install any Intel Turbo Boost Max software/drivers?  If so, disable it or get latest updated software for ITBM here

FYI, and very important to understand, you will NOT see much multi-core activity while sitting idle on the ground.  The Terrain and Autogen engine kicks in when you start to actually fly, this is when you should see more multi-core activity.

Cheers, Rob.

Share this post


Link to post

ttbq1,

when you open Task Manager,before disabling core 0, click on the Performance tab and then Open Resource Monitor (bottom of the window). Be sure to monitor CPU. Core 0 will be pegged. Now do your Set Affinity, disable core 0, click OK. Wait a few seconds and then re-enable core 0 and click OK. Core 0 will now have a much lower utilization - pretty much equal to the rest of the cores. Keep the Resource Monitor open and go fly. All the cores should be close to equal. It will be interesting to see what this does to your FPS.

 

I wish I could take credit for this tweak but I saw it on one of the forums quite awhile ago.I do this each and every time I use P3D. I do not remember which forum or the person that posted it. Someone a lot smarter than me!

 

Lyn

Share this post


Link to post

I tried this affinity setting:  no difference in fps, but i get a gain of 5 fps if i select the priority of P3D to the highest priority in stead of normal. Is it OK to set P3D priority to highest or not ?

Share this post


Link to post
20 hours ago, Evros said:

I see that there are some Corsair processes running in the background. Are you using iCue software. iCue 3.19.120 has introduced an issue where core 0 is hammered with hardware interrupts. If that is you, then downgrade to 3.18 or just try out with iCue uninstalled. It looks exactly like that because your system interrupts process is also running high. 

 

17 hours ago, Rob_Ainscough said:

Do you run a lot of AI traffic or Road Traffic or Boat Traffic?  Also, from the screenshot you seem have your audio disabled?  Is that intentional?

In addition, did you install any Intel Turbo Boost Max software/drivers?  If so, disable it or get latest updated software for ITBM here

FYI, and very important to understand, you will NOT see much multi-core activity while sitting idle on the ground.  The Terrain and Autogen engine kicks in when you start to actually fly, this is when you should see more multi-core activity.

Cheers, Rob.

 

16 hours ago, Mazo said:

ttbq1,

when you open Task Manager,before disabling core 0, click on the Performance tab and then Open Resource Monitor (bottom of the window). Be sure to monitor CPU. Core 0 will be pegged. Now do your Set Affinity, disable core 0, click OK. Wait a few seconds and then re-enable core 0 and click OK. Core 0 will now have a much lower utilization - pretty much equal to the rest of the cores. Keep the Resource Monitor open and go fly. All the cores should be close to equal. It will be interesting to see what this does to your FPS.

 

I wish I could take credit for this tweak but I saw it on one of the forums quite awhile ago.I do this each and every time I use P3D. I do not remember which forum or the person that posted it. Someone a lot smarter than me!

 

Lyn

You guys are amazing!! thanks for taking your time to help me.

@Evros thanks mate, you nailed it!! it was indeed the Icue latest software which broke my P3D, many customers firing at Corsair at their forum for this issue.

My P3D V4.5 without any add-ons nor traffic installed, is giving me 180fps in the default scenario.

Now, I will need some time to install everything back again.

Share this post


Link to post

I'll have to check into this in my rig too.  Quick question.  Do I just look at the processes and see if Core0 is spiking related to icue tasks?  Assume I can check this even when P3D isn't running?

Share this post


Link to post
50 minutes ago, ttbq1 said:

it was indeed the Icue latest software which broke my P3D, many customers firing at Corsair

Glad you found it, this type of problem identification and resolution could be very helpful for other's using Corsair, great work.

ASUS had similar high CPU usage with their RGB lighting services ... there are so many "possible" causes to stutters beyond the flight simulator itself.

Cheers, Rob.  

Share this post


Link to post

@ttbq1 Glad to see that it helped you. I faced a terrible performance loss across the whole system as well when I updated to latest version. Luckily, for me, that was the only variable that changed at the moment to it was easy to track it down.

@micstatic The current issue is related to Corsair's iCue software only. If you do use that software and are on version 3.19.120, then you could open a hardware resource monitor of your choosing and see if core 0 is heavily loaded while system is idle. All that work would then be attributed to a system process called 'System Interrupts' and would amount the load of a single core maxing out. System Interrupts are priority level kernel requests that jump the processing pipeline queue for immediate execution. In a standard, well operating environment, the effect of this process should not be noticeable to user and should remain at 0% CPU usage most of the time.

@Rob_Ainscough Very true regarding Asus Aura. Even running the basic rainbow effect will eat some 5% of processing power with 8c/16t 5Ghz processor. Sometimes LightingService.exe trainwrecks completely and will start hammering CPU with 20-30% load. Setting things to static light will solve both of those problems.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now