Jump to content

somiller

Invalid aircraft code

Recommended Posts

Nico,

I receive this error: CS300 in "C:\Users\Owner\Documents\Prepar3D v4 Add-ons\AIGAIM - OCI\SimObjects\AIGAIM_SBAI_A220-300\aircraft.cfg"

aircraft.cfg:

Spoiler

[fltsim.0]
title=AIGAIM_Swiss Bombardier CS300
sim=CSeries
model=
texture=SWR-Swiss
atc_airline=SWISS
atc_parking_types=Gate
atc_parking_codes=SWR
ui_type=Bombardier CS300

[fltsim.1]
title=AIGAIM_Swiss Bombardier CS300 - unnamed
sim=CSeries
model=
texture=SWR-Swiss_unnamed
atc_airline=SWISS
atc_parking_types=Gate
atc_parking_codes=SWR
ui_type=Bombardier CS300

[General]
atc_type=BOMBARDIER
atc_model=BCS3
editable=1
visual_damage=1
performance=Only experienced AI pilots should attempt to fly this aircraft.
Category=airplane

At the same time, this aircraft.cfg elicits no error:

Spoiler

[fltsim.1]
title=AIGAIM_Swiss Bombardier CS100 - fwd Titles (rhs)
sim=CSeries
model=
texture=SWR-Swiss_fwd Titles (rhs)
atc_airline=SWISS
atc_parking_types=Gate
atc_parking_codes=SWR
ui_type=Bombardier CS100

[fltsim.2]
title=AIGAIM_Swiss Bombardier CS100 - unnamed
sim=CSeries
model=
texture=SWR-Swiss_unnamed
atc_airline=SWISS
atc_parking_types=Gate
atc_parking_codes=SWR
ui_type=Bombardier CS100

[General]
atc_type=BOMBARDIER
atc_model=BCS1
editable=1
visual_damage=1
performance=Only experienced AI pilots should attempt to fly this aircraft.
Category=airplane

Is there something I can change in the CS300 - BCS3 aircraft.cfg to eliminate the error?

I have comfirmed that BCS3 is in fact the correct type code.

Kind Regards,

Share this post


Link to post
Share on other sites

I assume you are talking about AILG and you have found this error in the file InvalidAircraftCodes?

If so it has found a line atc_model=CS300.
CS300 has more then 4 characters so it must be an error.

Maybe there is another line atc_model in "C:\Users\Owner\Documents\Prepar3D v4 Add-ons\AIGAIM - OCI\SimObjects\AIGAIM_SBAI_A220-300\aircraft.cfg"

Edited by kiek

Share this post


Link to post
Share on other sites

Well I found the problem. At some recent point a new aircraft.cfg was written...I assume during an update to AIG OCI, and the offending atc_model=CS300 was present.

Kind Regards,

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...