Jump to content
Sign in to follow this  
Ed Kammerman

Still having stuttering issues with FSX in Windows 10

Recommended Posts

Hi, so recently my installation of FSX has been stuttering. What I get is an hourglass and then FSX stops very briefly and then starts again. If I pause it then I get a brief flash of my desktop and then the flight continues. Assistance would be appreciated .  I have tried everything that I have seen here  to no avail  I'm just at a total loss I don't want to have to do a complete reinstall of FSX  anybody got any out of the box ideas . Computer  Dell XPS 8900  Intel i7  quad core 3.4 gigahertz, 8GB ddr4 Ram, 3 terabyte Serial ATA Drive and the equivalent of an Nvidia 1050ti graphics with four gigabytes of DDR RAM, OS Windows 10 1903, thank you Ed

Edited by Ed Kammerman
Added additional info

Share this post


Link to post
Share on other sites

Sorry, no out of the box answers; the tried and true ones seem to help;  Check for the latest video drivers, download and go through the AVSIM FSX Config Guide.

You might also try running ProcessExplorer while flying to see if something is spiking your CPU or exhausting your GPU VRAM.

  • Like 1

Ernest Pergrem

Share this post


Link to post
Share on other sites
8 hours ago, Ed Kammerman said:

I don't want to have to do a complete reinstall of FSX  anybody got any out of the box ideas

More info first. What are the most recent modifications you made to FSX?  Do you keep a log?  Can you undo or remove the most recent mods, one at a time?

What flight is FSX loading when you first start it?  What airport is loaded by that flight?  Is it a default airport, or is it an add-on airport?  What aircraft is loaded with that flight? Same questions, default or add-on?  

Did you ever make backup copy of your FSX.cfg file when FSX was operation smoothly?  Have you reverted to the saved backup?  If not, or if unable (don't have a good backup), have you deleted your FSX.cfg file to force FSX to rebuild it? 

What sceneries do you have loaded, especially 3rd party large airports and photoreal sceneries?  Then where are you flying when experiencing the stutters? 

What aircraft are you flying when this happens?  What add-ons or modifications have been applied to the aircraft?  Gauges, panel.cfg mods, repaints, etc.


Frank Patton
MasterCase Pro H500M; Z490 WiFi MOB; i7 10700k 3.8 Ghz; H100i Pro; 32GB DDR4 3600; RTX 3070 TI 8GB; Gold RMX850X PSU; ASUS VG289 4K 27"
Honeycomb Alpha & Bravo, Crosswind 3's w/dampener.  
Former USAF meteorologist & ground weather school instructor. AOPA Member #07379126
                       
"I will never put my name on a product that does not have in it the best that is in me." - John Deere

Share this post


Link to post
Share on other sites
8 hours ago, Ed Kammerman said:

I have tried everything that I have seen here  to no avail

Sorry, but this tells anyone that wants to help absolutely nothing.  Without knowing more about the problem (is it random, happening periodically, only in certain places or phases of flight etc) and what you've already tried, we're left to guess.

 

  • Like 1

Bob Scott | AVSIM Forums Administrator | AVSIM Board of Directors
ATP Gulfstream II-III-IV-V

System: i9-10900K @ 5.2GHz on custom water loop, ASUS Maximus XII Hero, 32GB GSkill 3600MHz CAS15, EVGA RTX3090 XC3 Ultra
Samsung 55" JS8500 4K TV@30Hz,
3x NVME 2x SATA Samsung SSD, EVGA 1KW PSU, 1.2Gbps internet
SoundBlaster XFi Titanium, TOSLINK to Yamaha RX-V467 HT Rcvr, Polk/Klipsch 6" bookshelf spkrs, Polk 12" subwoofer, 12.9" iPad Pro
PFC yoke/throttle quad/pedals with custom Hall sensors, Coolermaster HAF932 case, Stream Deck XL button box

Share this post


Link to post
Share on other sites

Hi all,

  Thanks for your recommendations and suggestions.....however for me it's just too complicated and time consuming to go through all these processes, I am going through the FSX .config manual and rebuilding my FSX .config file.. However I'm not going to write a 25 page dissertation on what I've done (LOL). I've backed up and rebuilt the FSX .config file several times, played with frame rates (usually keeping to 30 fps). Scenery settings between ultra high and high, basic scenery addons are Free mesh, FSC2010 and FSX nav updates. A fair amount of airports (asstd. developers) and several 3rd party aircraft (primarily PMDG) weather AS2016. My PC specs are in the original post, which are quite sufficient in my opinion

P>S Steve's DX10 Scenery Fixer

 

Ed.

 

 

Edited by Ed Kammerman
Addition to post

Share this post


Link to post
Share on other sites

I remember stuttering in P3D and it turned out to be an outdated FSUIPC.  You should rename the dll.xml to dll.off and make sure it is not one of your utilities causing this issue.  Renaming the fsx.cfg usually fixes many things but see you have tried that.  I would also try renaming the scenery.cfg to scenery.off and let the scenery.cfg rebuild to the default and see if this fixes the problem.  If it does fix the problem, then you will have to find the offending scenery but I would look first at the scenery you installed recently.  If not, just remove the .off from the one you renamed and you'll be back.  Problems like this are usually caused by the fsx.cfg, the scenery.cfg, or a utility in the dll.xml.

 

  • Like 1

Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites

Hi Jim,

   So I did as you suggested, after rebuilding the scenery.onfig  file and reloading FSX today I noticed the issue was still occurring. I happened to look up at the title bar and realized the that whenever the sim paused especially for more than a second and the hourglass appeared on the title bar it said not responding. Do you know if there's any specific program that might cause this ? Like weather, live traffic GSX etc.

 

  Ed  

Share this post


Link to post
Share on other sites

It sounds like it is trying to load a scenery, an aircraft gauge or sound, weather, or something and cannot find it.  If you rebuilt the scenery.cfg and the error is still happening, did you rename the dll.xml to dll.off to make sure it is not one of the utilities that load at startup.  Maybe you uninstalled something like an aircraft and it did not uninstall everything so the aircraft is trying to load and cannot as some of the files were uninstalled.  Once, in FSX, I had an AI aircraft shutting down my simulator at the same spot every time.  It took me a couple of months to find out it was an AI aircraft.  It evidently had bad textures.  Did you run the diagnostics program in Steve's DX10 Fixer.  Maybe something there is not installed correctly.  Also, make sure you are starting FSX in Administrative Mode and that you have set your compatibility settings show compatibility with All Users and not just you.  When some software addon is installed, it may have a user that was not allowed to run in Admin Mode.  These could be system users too.

You can easily determine if weather or live traffic is the culprit by renaming the dll.xml.  Those programs will not load.  For FSDT, you need to only disable the FSDT scenery in the scenery.cfg.

Check your Event Viewer to make sure there are not errors pertaining to FSX are there.  See page 8 in the AVSIM CTD Guide.

Can you let us know the scenario you are running when this happens.  What is the departure airport, the aircraft, the weather program, etc?  Are they payware or the default?  Maybe I can try to replicate.


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites

FSUIPC auto-save will do this, especially on machines with old-timey spinning HDDs without write caching enabled.

 


Bob Scott | AVSIM Forums Administrator | AVSIM Board of Directors
ATP Gulfstream II-III-IV-V

System: i9-10900K @ 5.2GHz on custom water loop, ASUS Maximus XII Hero, 32GB GSkill 3600MHz CAS15, EVGA RTX3090 XC3 Ultra
Samsung 55" JS8500 4K TV@30Hz,
3x NVME 2x SATA Samsung SSD, EVGA 1KW PSU, 1.2Gbps internet
SoundBlaster XFi Titanium, TOSLINK to Yamaha RX-V467 HT Rcvr, Polk/Klipsch 6" bookshelf spkrs, Polk 12" subwoofer, 12.9" iPad Pro
PFC yoke/throttle quad/pedals with custom Hall sensors, Coolermaster HAF932 case, Stream Deck XL button box

Share this post


Link to post
Share on other sites

Hi Jim, so I tried what you suggested and things seem to be running a lot smoother the only problem is I lost all my things like GSX and the co-pilot program that provides me with time adjustments and things like that. It kept my ultimate live traffic so that doesn't seem to be the issue. I love to keep the smoothness but keep GSX and things of that nature. Flight is from KBOI to KLAX. Aircraft pmdg 737 800 weather is as2016. KBOI is updated with freeware add-on and KLAX is fsdt.

Share this post


Link to post
Share on other sites

Ed,

I suspect you renamed the dll.xml and your stuttering stopped but now your GSX entry is gone as you now are only loading the default dll.xml?  On page 13/14, AVSIM CTD Guide, it shows you via an image on how to manually disable only the modules you do not want loaded.  If you do not want to load the FSUIPC, then you would change a line from false to true and the FSUIPC will not load.

In regards to the FSUIPC, Bob Scott's suggestion about the FSUIPC auto-save function is probably the best solution in regards to stuttering.  As I recall now, this is how I fixed my stuttering in P3D using Washington X (I did not try with FSX as I rarely load heavy programs like DD's WashX.

Best regards,

Jim


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites

Jim, I had already cancelled auto save in FSUIPC prior to these recent posts from me.  The stuttering had continued.  What's odd after renaming dll.xml file and reloading  FSX I can't seem to locate the new dll.xml file, I know the location where it should be, but it's not there.

 

Ed

Edited by Ed Kammerman

Share this post


Link to post
Share on other sites

In P3D there are two dll.xml files (and two exe.xml files as well).  One is in C:\Users\...\AppData\Roaming\Lockheed Martin...... and the other in C:\ProgramData\Lockheed Martin...


Bob Scott | AVSIM Forums Administrator | AVSIM Board of Directors
ATP Gulfstream II-III-IV-V

System: i9-10900K @ 5.2GHz on custom water loop, ASUS Maximus XII Hero, 32GB GSkill 3600MHz CAS15, EVGA RTX3090 XC3 Ultra
Samsung 55" JS8500 4K TV@30Hz,
3x NVME 2x SATA Samsung SSD, EVGA 1KW PSU, 1.2Gbps internet
SoundBlaster XFi Titanium, TOSLINK to Yamaha RX-V467 HT Rcvr, Polk/Klipsch 6" bookshelf spkrs, Polk 12" subwoofer, 12.9" iPad Pro
PFC yoke/throttle quad/pedals with custom Hall sensors, Coolermaster HAF932 case, Stream Deck XL button box

Share this post


Link to post
Share on other sites

Thanks but remember I'm dealing with FSX not p 3D the file we're talking about is under my username, app data, roaming, Microsoft, FSX. The odd thing is since I've rebuilt the file I can't find it. Which to me is very odd

Edited by Ed Kammerman
I love using my phone for speech to text but I hate autocorrect lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...