Jump to content

Sign in to follow this  
amollen

VATSim data not loading

Recommended Posts

Hi Alexander,

 

Earlier this week, without me having changed any settings, VATSim data stopped loading into LittleNavMap. No airplanes on the map and the table to the right of the map is empty. I get no error messages, but the data simply isn't there.

Funny enough, a similar thing happened to VATSpy. But other VATSim-related software is fine (vPilot, vatstats). This makes me believe that it's not the software but VATSim changed something.

Here is a link to the post I put on VATSim about the problem: https://forums.vatsim.net/viewtopic.php?f=24&t=80283

Any ideas?

 

Alex

Share this post


Link to post
Share on other sites

Thanks for responding!

Well, temporary hickup is already going on for 4 days.... Maybe an internet port was closed or my internet provider changed something? Is there any setting I could doublecheck? Firewall settings?

Share this post


Link to post
Share on other sites

LNM does a simple HTTPS request (same as a web browser does to get a page) to get this file: https://status.vatsim.net/status.txt

From there it gets the actual data from one of the following files (randomly selected):

http://us.data.vatsim.net/vatsim-data.txt, http://eu.data.vatsim.net/vatsim-data.txt or http://apac.data.vatsim.net/vatsim-data.txt

This should work without problems if you can see the map or weather in LNM updated. It's the same mechanism.

There are a few test buttons in the options dialog on page "Weather" where you can check if LNM can access the web.

Alex

 

Share this post


Link to post
Share on other sites

Alex,

The test buttons in the weather dialog all test OK.

I've tried the following:

- Both VRC and vPilot give a message upon startup that they cannot access the remote server and are working with cached data, but otherwise work fine,

- ping www.vatsim.net and status.vatsim.net both is OK

- ping us.data.vatsim.net and eu.data.vatsim.net times out (I tried pinging from another laptop with the same result; it was however the same router and ISP). I think the root cause of my problems is that I am not connecting to these sites.

- Turning off Windows Defender Firewall doesn't make a difference. I don't see VATsim related sites in my Firewall rules.

- Turning off my Avast antivirus doesn't make a difference

- Turning my router off and back on doesn't make a difference

 

I'm starting to think that my ISP is somehow blocking these sites, getting a little desperate.

 

 

Share this post


Link to post
Share on other sites

I have experienced the same with Vatsim weather. Test runs fine, but unless I restart navmap, vatsim weather does not get updated. Above ping works perfectly to both sights. My Little Navmap runs 24/7 unless I need to do something else

 

I just tested via http vice ping and us.data gets a 404 error and the others return text.

Edited by BBQSteve

Share this post


Link to post
Share on other sites
22 hours ago, BBQSteve said:

I have experienced the same with Vatsim weather. Test runs fine, but unless I restart navmap, vatsim weather does not get updated. Above ping works perfectly to both sights. My Little Navmap runs 24/7 unless I need to do something else

If you use the betas: Update to the latest 2.6.4.beta. I fixed this recently and tested it thoroughly.

Alex

Edit: I see the problem. VATSIM stalls after the first download while IVAO continues every five minutes. Bizarre, since both use exactly the same code.😦

Edited by albar965
Confirmed

Share this post


Link to post
Share on other sites

I use the betas and am on 2.6.4 now, still have the problem. Funny how the test work fine, but still does not update the database.

Edited by BBQSteve

Share this post


Link to post
Share on other sites

@BBQSteve I just found the issue and fixed it. This was one of the "I must have been drunk while writing this" moments. Testing now and all is ok. Will be released with the next beta or release candidate.

Alex

Edit: I see outdated METARs on VATSIM (at 1616Z):

grafik.png

Edited by albar965

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    50%
    $12,670.00 of $25,000.00 Donate Now
×
×
  • Create New...