Jump to content

Sign in to follow this  
sho69607

Speech Recognition keeps picking up random words/phrases

Recommended Posts

I am having an issue with the speech recognition. When I actually speak, it gets picked up perfectly, however even when I am not saying anything I will see words such as, "hold" and other random phrases appearing in the green text bar. Do I need to keep my mic muted when I am not talking?


~Spencer Hoefer

MOBO: MSI MPG Z390 Gaming Pro Carbon | CPU: Intel i7-9700K(OC at 5.1GHz) | RAM: GSKILL RIPJAWS 16GB DDR4 3200 |GPU: Nvidia GTX 1070 8GBOS: Windows 10 

Share this post


Link to post
Share on other sites

Ultimately it really makes no difference.

Our system is designed so that even if odd words are picked up it shouldn't impact the simulation.  In other words, the FO won't do anything.

Regardless, you can try:

1. Lowering the sensitivity on your mic.

2. Keep your mic further away from your speakers.

3. If you don't need to make a voice command, engage "hard mute".

Cheers,

 

Share this post


Link to post
Share on other sites

I am having the same issue somewhat.

 

when doing the shutdown checklist

i say off , but the green text bar says both and fs2crew doesn't do anything. ... speech under admin rights.... nothing has control of the mic... and iv ran speech training 7 times now.... didnt happen in the update before last.....

 

so now im stuck saying checked and set the whole time and sensitivity is very low still says both instead of off ... any fix`

 

i tried adding and recording off in the dictionary still nothing...

 

Christopher adama

Share this post


Link to post
Share on other sites

This is why we have the backup phrase: "SET AND CHECKED" for cases like these, if, for whatever reason, the speech recognition system has trouble with a specific word.

You can try deleting your voice profile, creating a new one.... then re-training your voice.

 

Share this post


Link to post
Share on other sites
Posted (edited)

well i deleted the profile and re trained another few times... still the same ....

didnt have this issue with 1.4 anyway i can download 1.4

 

also a new issue came up when i say shurt down checklist the gree bar says after landing actions or when i finally get to when the fo ask transponder and i say at 1k and stand by it says set 1k and stand by or something random. this is getting very annoying, cant complete a full flight with fs2 crew working right.

and not to mention still have fs2 crew say both instead of off .

at points checked and set do not work.

everything is running as admin. 

christopher adama

 

i also restarted the sim several times and no joy expect for when i say off it says auto or up or on i didnt know off ment all those

Edited by vikelu22

Share this post


Link to post
Share on other sites

If you didn't have this issue with V1.4, it means something on your computer changed since the speech recognition code itself never changes between updates.  

Try it with a new microphone... maybe your microphone is not functioning 100 percent anymore.

If you get a new mic, be sure to retrain your voice again.

Cheers,

Share this post


Link to post
Share on other sites

I got this problem as well, especially when flying online and there is other traffic speaking with ATC. It happens even if I switch my loudspeakers off and have the sound only on my headset. During some phases of the flight it's just not practical to engage hard mute. 

Share this post


Link to post
Share on other sites
Posted (edited)

How is your mic detecting sound that's coming out your headset?  Your volume must be extremely high for it to hear that.

Again, as above, you can try lowing your mic sensitivity.

Cheers,

 

Edited by byork

Share this post


Link to post
Share on other sites

That's what I am asking myself as well 😉

The volume is not really high to be honest and also the setting in vpilot is not maxed out.

Share this post


Link to post
Share on other sites

I'm having 2 problems similar to this.  I've confirmed several times that my mic sensitivity is way down.

1) picks up random things when literally *nothing* is being picked up by the mic (according to the sound meter).

2) can't seem to figure out the word "set" on the altimeter setting change or the checklist (always wants to say it's "seven").

Both of these problems started about the same time and *only* affect the 747.  All my other FS2Crew programs work just fine.

Also, the soft mute on the 747 doesn't seem to be working either.  Whenever I transmit on VATSIM, it picks up what I'm saying even though the soft mute shows active and I get random command changes to things like speed when I release the transmit key on my joystick and the soft mute releases.


Chris Trott

Share this post


Link to post
Share on other sites

1. Maybe it's detecting breath?

But as mentioned even if it picks up random words, it makes no difference because the system probably won't act on those random words.

 

2. Delete your voice profile.  Re-train your voice.

Each FS2Crew uses the exact same speech recognition system.  Your results between each FS2Crew should be idential.

For soft mute, do you see the Mute icon on the Main Panel when you press it?

Make sure your slider for the key event is set to (full) repeat as per the manual.

Cheers,

Share this post


Link to post
Share on other sites

Yes, I see the mute icon when I am talking.  Just had it happen a few moments ago when I landed at Alliance Airport in Texas.  Was calling traffic and ended a transmission with "Alliance" and as soon as I un-keyed the mic and the yellow Mute cleared, the green bar said "Lights" which then turned off my taxi lights.

As for the retrain - I built this current computer 2 months ago from scratch.  That included a new training session for voice.  It did this before the new computer.  It does it now with the new computer.  It does it no matter what microphone I have installed.  The point I think we're trying to make Bryan is that maybe it's not Speech Recognition profile that is the problem.  Maybe it's something changed in how SR is working or how FS2Crew is interacting with it that changed and is causing the issue.

Edited by CAPFlyer

Chris Trott

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,080.00 of $25,000.00 Donate Now
×
×
  • Create New...