Jump to content
Sign in to follow this  

OldProp Site Can't Be Reached

Recommended Posts


I am trying to migrate all my OldProp products to ORBX, but if I try to access the oldprop site to start the process, I get a message that the site cant be reached. I tried in different browsers. Is the site down completely or am I missing something? Any help would be appreciated.


This site can’t be reached

oldprop.com took too long to respond.




Share this post

Link to post
Share on other sites

I just tried it. It worked for me.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Create New...