Jump to content

Sign in to follow this  
Jammin16

Help my P3D v4 Crash!!!

Recommended Posts

Hi every one,

 

I have a "big" problem with my P3D v4, It crashes and shuts down automatically!!!

My PC: Windows 10 Home, i5-7600k, M.2 SSD, GTX 1080 Aero & RAM 32GB.

I hope some can help me I have this pictures

S.png

P3D_v4_Crash.png

 

Best Regards

Jammin16

Share this post


Link to post

Round up the usual suspects. Dll.xml, scenery.cfg and Prepar3d.cfg. Make a Backup of the previous and delete one at a time and see if it loads. The Sim will rebuild all but the DLL.xml.Go from there.

Edited by Adrian123

Share this post


Link to post

Jammin16:

 

The most common culprit is "Prepar3D. config". It is located C:\Users\ ----\AppData\Roaming\Lockheed Martin\Prepar3D v4.

Simply remove that file (Use cut and paste it somewhere handy). Restart P3D , it will rebuild the file and all should be good.

If you have to edit this file, ensure you don't use a regular word editor. That will most often result in P3D not starting.

Use "notepad++" or something similar. 

 

                 - Roger

Share this post


Link to post
32 minutes ago, sevenflyer said:

Jammin16:

 

The most common culprit is "Prepar3D. config". It is located C:\Users\ ----\AppData\Roaming\Lockheed Martin\Prepar3D v4.

Simply remove that file (Use cut and paste it somewhere handy). Restart P3D , it will rebuild the file and all should be good.

If you have to edit this file, ensure you don't use a regular word editor. That will most often result in P3D not starting.

Use "notepad++" or something similar. 

 

                 - Roger

I have tried what you said, but P3D v4 didn't rebuild the file! I have remove the file to my disctop.

Share this post


Link to post
4 hours ago, Adrian123 said:

Round up the usual suspects. Dll.xml, scenery.cfg and Prepar3d.cfg. Make a Backup of the previous and delete one at a time and see if it loads. The Sim will rebuild all but the DLL.xml.Go from there.

I have maybe found the problem when I get to C:\Users\---\AppData\Roaming\Lockheed Martin\Prepar3D v4. I could not found the scenery.cfg file!

Edited by Jammin16

Share this post


Link to post
27 minutes ago, Jammin16 said:

I have maybe found the problem when I get to C:\Users\---\AppData\Roaming\Lockheed Martin\Prepar3D v4. I could not found the scenery.cfg file!

When launching P3D, if no scenery.cfg exists, P3D will create it with default settings.

Confirm that no scenery.cfg exists, launch P3D, try loading a flight to see if it works without crashing.


Steven_Miller.png?dl=1

i7-6700k Gigabyte GA-Z170X-UD5 CORSAIR Dominator Platinum 16GB DDR4 2400 ASUS ROG-STRIX GTX1070

Share this post


Link to post
11 hours ago, somiller said:

When launching P3D, if no scenery.cfg exists, P3D will create it with default settings.

Confirm that no scenery.cfg exists, launch P3D, try loading a flight to see if it works without crashing.

Somiller,

As I said it didn't help. P3Dv4 launching not a new scenery.cfg!

 

unknown.png?width=1202&height=677

Edited by Jammin16

Share this post


Link to post

Scenery.cfg is located in...

C:\ProgramData\Lockheed Martin\Prepar3D v4\

And I wouldn' recommend deleting, renaming will suffice.

And before even doing that I would say first to clear the scenery indexes, i.e. delete the files in \SceneryIndexes_x64 and then test, because they will rebuild completely where as deleting the Scenery.cfg will not include custom areas when recreated.

C:\ProgramData\Lockheed Martin\Prepar3D v4\SceneryIndexes_x64\

Would also recommend deleting the shader cache, again they will rebuild completely.

C:\Users\account_name\AppData\Local\Lockheed Martin\Prepar3D v4\Shaders\

Cheers


Ryzen 2700X clocked to 4.2 Ghz, 32 GB ram, Samsung 1 x 1 TB NVMe 970 and 2 x 1 TB SSD 850 Pro raided, Nvida 1070 Ti clocked to 2 Ghz

P3D 4.5.14, Orbx Global, Vector and more, lotsa planes too.

Catch my vids on Oz Sim Pilot, catch my screen pics @ Screenshots and Artwork

Share this post


Link to post
2 hours ago, Rogen said:

Scenery.cfg is located in...

C:\ProgramData\Lockheed Martin\Prepar3D v4\

And I wouldn' recommend deleting, renaming will suffice.

And before even doing that I would say first to clear the scenery indexes, i.e. delete the files in \SceneryIndexes_x64 and then test, because they will rebuild completely where as deleting the Scenery.cfg will not include custom areas when recreated.

C:\ProgramData\Lockheed Martin\Prepar3D v4\SceneryIndexes_x64\

Would also recommend deleting the shader cache, again they will rebuild completely.

C:\Users\account_name\AppData\Local\Lockheed Martin\Prepar3D v4\Shaders\

Cheers

Thank you very much, now it's not so bad but I have still the problem!

unknown.png

 

Edited by Jammin16

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,170.00 of $25,000.00 Donate Now
×
×
  • Create New...