Jump to content

Sign in to follow this  
Yak54

PSXseeconTraffic stops working after 10 – 15 minutes

Recommended Posts

3 minutes ago, Swinden said:

But it is interesting that it has only started happening with me in the last few months, which means you made a change in one of your newer versions.  I did do a flight over an hour w/ no problems...

I made several changes indeed (see the release notes) but none with respect to the use of SimConnect. It could also be caused by a change in your system...

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Nick,

Exact same problem, and it happens -frequently-.  The only thing that changed, is I upgraded to the latest version of PSXT.

If you can make older versions available, we can identify in which version / release the issue crept in.  This is most certainly, a PSXT issue.

Out of everything that I have using SimConnect, PSXT is also the only app experiencing these disconnects.  I find your "FSDT - it's not my app" attitude towards this also a bit concerning, to say the least.  If you're so adamant that it's not your app, make the older 17.4 / 17.3 available and let's see whether the issue persist for those of us that are experiencing the issues.

There's a multitude of issues in 17.5 that I am picking up, I've emailed you about it as well, but I guess my bug reports doesn't warrant a response as it is 'not your application'

Edited by cknipe

Share this post


Link to post
Share on other sites
Posted (edited)

Well, been running for the last 5 or 6 hours, not one single heartbeat missed issue yet for me on 17.0.

A lot of the other issues I've mentioned in my mail to you, has also disapeared . 

Edited by cknipe

Share this post


Link to post
Share on other sites
Posted (edited)
16 hours ago, cknipe said:

Well, been running for the last 5 or 6 hours, not one single heartbeat missed issue yet for me on 17.0.

Interesting. Did a file-compare of the file that interfaces with SimConnect but I do not see any differences. The only difference is the version of the Visual C++ compiler used. Have to dig deeper.

Edited by kiek

Share this post


Link to post
Share on other sites
9 hours ago, kiek said:

Interesting. Did a file-compare of the file that interfaces with SimConnect but I do not see any differences. The only difference is the version of the Visual C++ compiler used. Have to dig deeper.

(Don't pay attention to the timestamps, I'm cutting & pasting from multiple log files)

10:27:18 Flight Simulator was interrupted ...
10:27:19 Flight Simulator resumed

From the logs. I think it's related to that.  In 7.0, the connection is interrupted, and then it reconnects.  This happens due to Sim 'pauses', scenery loads, spawning at different locations, etc...  Normal in sim things that we can't really do anything about.  Even stutters sometimes.

In newer versions, I see this:

10:27:18 Flight Simulator was interrupted ...
10:27:19 Flight Simulator resumed
Error 14:21:19  SimConnect problem: no EVENT_1sec, no heartbeat
UPS=31
Exiting: USER CLOSED SIM

Your app seems to think that the SIM has been closed, when in fact it isn't.  It then never attempts to re-connect, and the only way to fix this is to restart PSXT.

I can clearly see the different behavior in the logs.  I unfortunately, don't know what in the code is causing it however.  If I have to guess, your "Exiting: USER CLOSED SIM" should really just be a re-open / re-connect SIM CONNECT.  

PS: 24+ hours for me on 7.0 now (actual sim running for 24+), not one heartbeat missed.  5 or 6 hours at VHHH, VHHH to KSDF (14.5 hours), and the rest of it at KSDF in the ground.

Share this post


Link to post
Share on other sites
Posted (edited)
16 hours ago, cknipe said:

Your app seems to think that the SIM has been closed, when in fact it isn't. 

I had already solved this problem in a not yet released version by testing for the interrupted state too. 

So my question is do you have no heart beat messages in 17.5 when you are not interrupting the Simulator? 

Edited by kiek

Share this post


Link to post
Share on other sites
2 minutes ago, kiek said:

So my question is do you have no heart beat messages in 17.5 when you are not interrupting the Simulator? 

Unfortunately, I do - as far as I can remember.  It is significantly less, but they are still there.

Will go back up to 17.5, test and confirm for you.

Share this post


Link to post
Share on other sites
Posted (edited)
16 hours ago, cknipe said:

  If I have to guess, your "Exiting: USER CLOSED SIM" should really just be a re-open / re-connect SIM CONNECT.  

No, an exception was raised and PSXT came up with the wrong cause. I have changed it now to "Exiting: SYSTEM ERROR".

Edited by kiek

Share this post


Link to post
Share on other sites
2 minutes ago, kiek said:

No, an exception was raised an PSXT came up with the wrong cause. I have changed it now to "Exiting: system error".

Can you not just give details in the logs as to WHAT exception occurred? Then at least we know what to look for.

In my experience -every- heartbeat missed error I got, presented itself with those lines in the logs... Why would it all of a sudden get exceptions on 17.5, but not get the same exceptions on 17.0?

 

Share this post


Link to post
Share on other sites
49 minutes ago, cknipe said:

Can you not just give details in the logs as to WHAT exception occurred? Then at least we know what to look for.

I already do, only the no heart beat exception got a misleading USER CLOSED SIM. Will be fixed.

Share this post


Link to post
Share on other sites
Posted (edited)
51 minutes ago, cknipe said:

In my experience -every- heartbeat missed error I got, presented itself with those lines in the logs... 

So it was always caused by Simulator being interrupted?!  Then we have found the problem...

Edited by kiek

Share this post


Link to post
Share on other sites

Well it took a few hours, but with 17.5... 

This is new now for me:

QNH=1011
20:58:11 Flight Simulator was interrupted ...
20:58:11 Flight Simulator resumed
QNH=1012
20:58:41 Flight Simulator was interrupted ...
20:58:42 Flight Simulator resumed
20:59:12 Flight Simulator was interrupted ...
20:59:12 Flight Simulator resumed
20:59:42 Flight Simulator was interrupted ...
checkIO
Error 21:00:22  SimConnect problem: no EVENT_1sec, no heartbeat

It does definitely seem to be related to when it looses / reconnect to the sim though.  Hope you can track it down, and if you want me to test anything for you, feel free to ask.

Share this post


Link to post
Share on other sites
Posted (edited)

"Flight Simulator was interrupted" does not mean PSXT has lost connection with the Sim. It is still connected but the flight is not "running", meaning you are probably browsing in the simulators menu and have selected an item. SimConnect reports this state change with the System Event Sim message.

If you are doing this too long (30 sec) you will (wrongly) get the no heart beat message. This will be fixed in the next version.

Note that if you pause the Sim, the flight keeps running, that is something different.

If the flight is not running PSXT stops processing RealTraffic data until the flight starts running again, that's all. 

So the question remains, why is your Sim interrupted? In particular the 1 second outages are strange ...

Edited by kiek

Share this post


Link to post
Share on other sites
9 hours ago, kiek said:

So the question remains, why is your Sim interrupted? In particular the 1 second outages are strange ...

I'm facing the same issue. Two hypotheses for the sim interruptions:
- Returning from accelerated sim rates (8x or 16x) to 1x
- Refreshing scenery before approach (or because it's too blurry)


Best regards,
Luis Hernández 20px-Flag_of_Colombia.svg.png20px-Flag_of_Argentina.svg.png

My rig: ASUS TUF FX504GD (Intel i5 8300H @ 2.8-4.0 GHz, 8 GB DDR4-2666 RAM, Nvidia GTX 1050, 256 GB M.2 SSD+256 GB 1 TB SATA III SSD as storage, Windows 10 Home)

Saitek X-52 as primary controller. Xbox 360 wired and eDimensional G-Pad Pro wired controllers as standby/travel.

Running FSX-SE as my primary sim, finally, 13 years after FSX's release. Also running FS9 and XP11 Vulkan. What do I do with 3 sims now?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    21%
    $5,465.00 of $25,000.00 Donate Now
×
×
  • Create New...