Jump to content

Sign in to follow this  
Raller

Flightnumber will be ignored by P3Dv4.5

Recommended Posts

When I set (together with the airline) a flightnumber within the aircraft.cfg, e.g
atc_airline = Lufthansa
atc_flight_number = 123

this will be ignored by P3Dv4.5. I load the ailplane and the airline is taken over, but the flightnumber is 0.

Is this a bug or a feature?


Win 10 Pro | P3Dv4.5 | X-Plane 11 | MSFS 2020 | I5-9600K @ 4.8GHz | RTX 2070 8GB | 32GB RAM | SSD | T.16000M

Share this post


Link to post

Neither, you're changing the wrong variable...

P3Dv4 loads the flight number from the state.cfg file that it keeps in %APPDATA%\Lockheed Martin\Prepar3d v4\SimObjects

Change (or add) atc_flight_number=123 under the required FltSim.x entry and Bob's your fathers brother...

Share this post


Link to post

too bad V5 won't give us the ability to have a check/uncheck box to completely deactivate any native ATC.  Every now and then on vatsim I'll have a looping p3d ATIS annoying me in the background.  


9700k | Maximus XI Hero| 32gb DDR4 3000 | 1080Ti 11GB | 1tb EVO Plus 970 and 500GB M2+3TB HDD | 43" Samsung X60R 4k and 2  22" monitors | Corsair RM1000x |  240MM AIO.| MFG Crosswind | T16000M Stick | Saitek Throttle Quad | Skalarki MCDU and FCU | Saitek Radio Panel

Share this post


Link to post

You should be able to do that in the aircraft.cfg file.  Can you take a screenshot from inside P3D at the aircraft selection screen with the one you want to fly selected?  Is this with all aircraft?


Dave

Current System (Running at 1440p): ASUS ROG Maximus XII Hero Z490, i9 10900k @ 5.1Ghz, RTX2080ti, 32GB DDR4 3600 RAM, EVGA CLC 280mm AIO Cooler

Share this post


Link to post

@iwebber  thx, i will try that.

I can remember that back in P3D it always worked with the "atc_flight_number=" variable. But for a long time now, the flight number has always been 0, no matter what aircraft.

The SDK says:
"The ATC system will use this number as part of the aircrafts callsign. ATC will treat this aircraft as an airliner when this is used in conjunction with atc_airline."

 


Win 10 Pro | P3Dv4.5 | X-Plane 11 | MSFS 2020 | I5-9600K @ 4.8GHz | RTX 2070 8GB | 32GB RAM | SSD | T.16000M

Share this post


Link to post

@iwebber  The flight number is stored in the state file indeed, but this is done by P3D. For example, if I manually assign the flight number when loading the aircraft, then this is stored in this file as part of the "aircraft state".

But changing the file by myself is the wrong way IMO, because it is "maintained" by P3D and is always adjusted by P3D and is nothing permanent.


Win 10 Pro | P3Dv4.5 | X-Plane 11 | MSFS 2020 | I5-9600K @ 4.8GHz | RTX 2070 8GB | 32GB RAM | SSD | T.16000M

Share this post


Link to post
1 hour ago, micstatic said:

too bad V5 won't give us the ability to have a check/uncheck box to completely deactivate any native ATC.  Every now and then on vatsim I'll have a looping p3d ATIS annoying me in the background.  

Just change the ATC volume to Zero and you are done.

S.

Share this post


Link to post
Posted (edited)

Okay, now I know what went wrong:
If you didn't have an assignment in the aircraft.cfg at the beginning, P3D sets a 0. When I load the airplane this way, the state-file will contain this 0.

Now I change the aircraft.cfg afterwards and set a flight number. But when I load the plane, P3D takes the state from the state-file, and there is 0 in it!

So the tip with the "state-file" brought the solution. When the state file is emptied, it also takes my changes from the aircraft.cfg. Makes sense...

Edited by Raller

Win 10 Pro | P3Dv4.5 | X-Plane 11 | MSFS 2020 | I5-9600K @ 4.8GHz | RTX 2070 8GB | 32GB RAM | SSD | T.16000M

Share this post


Link to post
1 hour ago, Raller said:

But changing the file by myself is the wrong way IMO, because it is "maintained" by P3D and is always adjusted by P3D and is nothing permanent.

Wrong way or not it's the only way that works if you want to change the flight number from outside P3D.

1 hour ago, Raller said:

So the tip with the "state-file" brought the solution.

It *IS* the solution 😄

Share this post


Link to post
3 hours ago, simbol said:

Just change the ATC volume to Zero and you are done.

S.

already do that.  But once every 50 flights or so there is an errant atis.  I believe at CYQB it happens also


9700k | Maximus XI Hero| 32gb DDR4 3000 | 1080Ti 11GB | 1tb EVO Plus 970 and 500GB M2+3TB HDD | 43" Samsung X60R 4k and 2  22" monitors | Corsair RM1000x |  240MM AIO.| MFG Crosswind | T16000M Stick | Saitek Throttle Quad | Skalarki MCDU and FCU | Saitek Radio Panel

Share this post


Link to post

have you tried to disable the GVP files?

 


AIGtechBanner_Kai_AVSIM.png

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,075.00 of $25,000.00 Donate Now
×
×
  • Create New...