Jump to content

David Roch

P3DV5: "DGXI error device hung" with an RTX 2080Ti (?)

Recommended Posts

On 5/12/2020 at 9:21 PM, Boeing or not going said:

I can be in cruise, and I will open PFPX, or switch to another Application running. Then the Error device hung appears on my screen.

And switching between application is a pretty load on your GPU because it has to shift, Again talking about "pushing the (tuned) hardware a tiny bit over its limits".

Or you go the "blame highway" and PFPX or the other app ist the culprit because the HUNG occures using that app at the moment.

  • Like 1

System: i9 9900k@4.9 - 32 GB RAM - Aorus 1080ti --- Sim/Addons: P3D v5 with tons of Addons and 3rd Party Airports
Signature3.png

Share this post


Link to post

With Nvidia cards run up GeForce Experience and run the driver check, use the express install. Some fixes in there with the most recent build: 445.87


Steve Waite: Engineer at codelegend.com

Share this post


Link to post

MSI Afterburner doing it for me.  Went back to EVGA Precision and all good.  Only downside I've not got RTSS OSD but maybe it's time to start flying than messing around with settings.  Stay safe, Allan.

  • Like 1

Allan Thomson

 

Share this post


Link to post

I know this is probably going to make me extremely unpopular, but I wanted to ask...

Do either of you, who's experiencing these issues with DXGI hung errors, have overclocked your systems? Now, please note, that I'm not asking of whether or not your system is stable (to your own accord) or if you've tested it for 36 hours with prime or similar tools... Are the GPU, CPU, RAM etc in any way overclocked? I can see from your signatures, that some of you, have CPU's which are overclocked... also, have you tried loading the defaults in your BIOS - or loaded the stock speeds in the BIOS - and then tried to see if the errors occured? 

I'm sorry to ask, but as a developers, programmer and supporter in daily life, I'm kinda intrigued by what you're describing... Also I'm also a little disconcerned with the (in my book) rather quick judgement, that this MUST BE A BUG (hence, there's-NOTHING-wrong-with-my-setup-attitude).

Anyway - sorry for breaking up the bashing... I was just genuinly interested of whether anyone had tested with stock core speeds, instead of the (potentially unstable) overclocked systems, you're advertising. 🙂

  • Like 4

Best regards,
--Anders Bermann--
____________________
Scandinavian VA

Pilot-ID: SAS2471

Share this post


Link to post
Posted (edited)

In my case my system is absolutely standard no overclocked anything, and on an absolutely stock install of P3D v5 with no prior directories. The hanging I had must have been a bad profile in Nvidia Control Panel because all I did was Restore/Apply.

However the problem can very well be overclock related but also can be due to physical problems in the GPU or system related.

Edited by SteveW
  • Like 1

Steve Waite: Engineer at codelegend.com

Share this post


Link to post
Posted (edited)
On 5/22/2020 at 8:15 AM, anden145 said:

I know this is probably going to make me extremely unpopular, but I wanted to ask...

Do either of you, who's experiencing these issues with DXGI hung errors, have overclocked your systems? Now, please note, that I'm not asking of whether or not your system is stable (to your own accord) or if you've tested it for 36 hours with prime or similar tools... Are the GPU, CPU, RAM etc in any way overclocked? I can see from your signatures, that some of you, have CPU's which are overclocked... also, have you tried loading the defaults in your BIOS - or loaded the stock speeds in the BIOS - and then tried to see if the errors occured? 

I'm sorry to ask, but as a developers, programmer and supporter in daily life, I'm kinda intrigued by what you're describing... Also I'm also a little disconcerned with the (in my book) rather quick judgement, that this MUST BE A BUG (hence, there's-NOTHING-wrong-with-my-setup-attitude).

Anyway - sorry for breaking up the bashing... I was just genuinly interested of whether anyone had tested with stock core speeds, instead of the (potentially unstable) overclocked systems, you're advertising. 🙂

Anders:

It isn't a poor or "trolling" question, because I think you are asking it without just making a snap judgement (to be fair, some people are making the opposite snap judgement... i.e. that the issues must absolutely be the user's setup or settings and not even accepting that there might be some common issues in the software that need to be addressed).  And it has definitely crossed my mind that the overclocking might be a source of problems (I am an engineer, that's how I think).

Yes, I do have my CPU overclocked and running the manufacturer's factory XMP profile for my memory, though no GPU overclock or anything else.  But like Steve I have also tested P3D v5 without any overclocks as well - just stock BIOS settings as you said to test performance under default conditions, and I have still seen crashes.  I haven't done near enough testing to pinpoint if it less frequent or the same, or if there are certain combinations of settings that trigger things, but that's part of the problem... my system really does work flawlessly for every other demanding application that I throw at it (the only other sim I have these types of issues is the latest beta for X-Plane - and that's a public beta where it is accepted that there are going to be bugs and instability), and I can't justify spending the time to go troubleshoot a specific combination of settings that are causing a problem on my rig when it is literally only P3D that is a problem for me (at least as far as non-beta releases go).

I guess that is part of the point - yes, there could absolutely be a combination of settings or interactions in my system that don't "play nice" with this version of P3D.  But I am a user of the software, not a tweaker or a tester, and I can't justify compromising system performance on everything else just to be able to run this version of P3D without crashing.

Edited by PurdueKev
  • Like 1

- Kevin

Windows 10 / i9-10900k (de-lidded) / MSI MEG Z490 ACE mobo / Corsair H150i RGB PRO XT liquid cooler / 32GB Corsair Vengeance LPX 3333MHz C16 DDR4 RAM / Nvidia Titan Xp 12GB / Dell Alienware AW3418DW WQHD 3440x1440 GSync / Samsung 970 EVO Plus M.2 2TB (OS) & 860 EVO 4TB / WD Caviar Black 4TB HDD  / EVGA Supernova 850 G5 PSU / Be Quiet Dark Base Pro 900 rev 2 case / ThrustMaster Warthog HOTAS stick & throttle / MFG Crosswind rudder pedals / C-Tek CT-203 collective / Virtual-Fly TQ6+ throttle quadrant / Saitek Trim Wheel / Saitek Radio and Switch Panels / Thrustmaster MFD Cougars (2) / TrackIR 5

Share this post


Link to post
Posted (edited)

You are definitely right Anders, it could be an OC issue, and I am open to all solutions.
So I reverted my BIOS settings to default, just for testing purpose. (Surprisingly, perfs were not that much degraded)
Unfortunately, same as Kevin, my first flight with the stock Maule finished with a GPU hang after 7 minutes using 4096x4096 textures.

As I said previously, with Win 10 1904, I can't use both EA + 4K textures together.
Let's hope that LM's upcoming patch + Win 10 2004 will bring more stability.

Edited by David Roch
  • Like 1

Best regards,
David Roch
Intel 9900K@5.1, Asus Maximus XI Formula, 32Gb G.Skill TridentZ 4133 CL17, EVGA RTX 2080 Ti XC ULTRA GAMING, 3x SSD Samsung 970 Pro M.2, Corsair 1600W PSU & 49" Samsung curved 4K TV monitor@30Hz.
MSFS Alpha tester

Share this post


Link to post

We should not have to change our main pc settings just to make V5 happy,,,it needs to be fixed at the source, not the end user. 


Paul Grubich 2017 - Professional texture artist painting virtual aircraft I love.
Be sure to check out my aged cockpits for the A2A B-377, B-17 and Connie at Flightsim.com and Avsim library

b0814f2d5cd6c708b2ec22681b36795f.jpg

Share this post


Link to post

I can't say that I am happy being a beta tester for a product I have purchased but I don't mind testing all kind of things. I want to understand where the issue comes from and try to find a solution.


Best regards,
David Roch
Intel 9900K@5.1, Asus Maximus XI Formula, 32Gb G.Skill TridentZ 4133 CL17, EVGA RTX 2080 Ti XC ULTRA GAMING, 3x SSD Samsung 970 Pro M.2, Corsair 1600W PSU & 49" Samsung curved 4K TV monitor@30Hz.
MSFS Alpha tester

Share this post


Link to post

 Let me start  out by saying i do not believe this is lm problem as i have the same error in dcs world.

 Now that being said i have and Aorus 1080 ti that is factory over clocked and i have solved my problem with the dx  hang by detuning  my video card from 1721 mhz down to 1698 mhz. If i forget to do this on a restart  it will hang.

 Fond this out with using my vr as it is susceptible to locking up and the same thing happens in  2d also.

I do not know if that will help as every body systems are different.

Regards Ted Kiser

  • Like 1
  • Upvote 1

Share this post


Link to post

Ted Kiser's post underscores an important point that is often overlooked about OCing and system errors. GPU manufacturers bin their products as to the product's ability to achieve specific clock speeds and remain stable under intense load. But then these GPUs are incorporated into a video card. The board manufacturer can choose a range of cooling solutions, power limitations and clock speeds that will again, achieve stability under load. But the board manufacturer cannot test every video game with every PC case configuration and image quality settings. And ambient temperature can also play a role.

There's no question that specific 3D apps are more prone to stressing the GPU than others. Just Google "DGXI error device hung" and you'll see specific games show up more frequently. But then you'll also see pages that mention how a subsequent game update eliminated the error. You'll also pages that say that a driver update cured the problem.

In any event, it's still good advice to troubleshoot by lowering IQ settings, monitoring hardware component temperatures and fan speeds, not using specific complex add-ons and even doing what Ted Kiser did.

  • Like 2

Share this post


Link to post

"Let me start  out by saying i do not believe this is lm problem as i have the same error in dcs world."

It is not in V4.5 so it does have something to do with the new version,,,,so their problem,,fix it. 


Paul Grubich 2017 - Professional texture artist painting virtual aircraft I love.
Be sure to check out my aged cockpits for the A2A B-377, B-17 and Connie at Flightsim.com and Avsim library

b0814f2d5cd6c708b2ec22681b36795f.jpg

Share this post


Link to post

Easy to fix: drop all the new stuff of V5 so it won't tax the system higher than V4.

Problem solved.


System: i9 9900k@4.9 - 32 GB RAM - Aorus 1080ti --- Sim/Addons: P3D v5 with tons of Addons and 3rd Party Airports
Signature3.png

Share this post


Link to post
10 minutes ago, warbirds said:

"Let me start  out by saying i do not believe this is lm problem as i have the same error in dcs world."

It is not in V4.5 so it does have something to do with the new version,,,,so their problem,,fix it. 

I simply don't know how to respond to such a close-minded and - quite frankly - obnoxious statement. 

You do realize, that Prepar3D 4.5 and Prepar3D 5 isn't utilizing the hardware/software the same, right? Now, I'm not saying, that this isn't something, with Prepar3D 5 in some way, but to simply discard the possibility, that the individual user setup is (partly) at fault, is simply just ludicrous, IMO. The very fact, that not every user experience this issue, and those who experience it, isn't reporting the same environment, tells us, that the individual user setting and hardware is playing a role in some regard. 

Unfortunately (and sadly, IMO) we're seeing more and more users, who flatly deny, that they have done something, which could influence the software or that their system could be at fault. Of course not! It's SO much simpler, to blame the developer. Why take responsibility for something, when you can blame someone else? Now, please (before you lynch me) I'm not saying, that this isn't a bug, that LM has to fix - but these kind of error, which is hardware related, can be caused by a myriad of underlying issues like hardware temperatures, bad drivers, Windows Updates, conflicting hardware, memory faults etc... 

Personally I would hold judgement, until more is known about the cause or causes.

  • Upvote 1

Best regards,
--Anders Bermann--
____________________
Scandinavian VA

Pilot-ID: SAS2471

Share this post


Link to post
1 hour ago, warbirds said:

"Let me start  out by saying i do not believe this is lm problem as i have the same error in dcs world."

It is not in V4.5 so it does have something to do with the new version,,,,so their problem,,fix it. 

Unsure what you mean because Device Hung crashes ARE in P3Dv4 and have been for many years.  I started getting them on my 1080ti from v4.2 I think a few years ago.

 

Chris


800driver.jpg

 

Chris Ibbotson

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,125.00 of $25,000.00 Donate Now
×
×
  • Create New...