Jump to content

Sign in to follow this  
David Roch

P3DV5: "DGXI error device hung" with an RTX 2080Ti (?)

Recommended Posts

3 hours ago, djbully said:

Thank you for this. I am also getting this device hung error, except I have an AMD system. Do you know if this fix is just for NVIDIA? Or should it work on any graphics driver? 

LM have acknowledged the AMD issue on their forums and apparently are working with AMD to resolve the issue. Hopefully they can get some results! 

BTW I'm running

3900x CPU

32GB DDR4@3600 

Radeon VII 16GB HBM2

Performance apart from all the crashes is very low.It Struggles keep a constant 20FPS with quite low settings. This is a completely vanilla install (no addons AT ALL!)

With p3d 4.5 I can run that 60 FPS no problem with no addons! It's only when you add Orbx etc to it that performance dips. 

Cheers,

Bully.

I don't know if it works only for NVIDIA. I would suggest to you that you just try it and see if it helps and stops these kind of errors

cheers

Dirk

  • Like 1

Share this post


Link to post

Maybe try the Nvidia Control Panel, Restore/Apply the P3D profile and the main profile.

Also can try setting let app decide:

NvidiaLetAppDecide.jpg


Steve Waite: Engineer at codelegend.com

Share this post


Link to post

Well, I can't get rid of those crashes. 😵

Now I get another message, same style:
5LPUbt.png

My poor 2080Ti is suffering...💔

On 4/26/2020 at 5:48 PM, SAS443 said:

Happens to me when I use Nvidia inspector (also  a 2080ti owner)

Thanks, uninstalled already.

On 4/26/2020 at 6:27 PM, rayharris108 said:

Not sure if this will help, but I found somewhere that DXGI_ERROR_DEVICE_HUNG crashes can be related to hardware and sound driver conflicts.

In my case I had mutliple sound drivers enabled, inc one for the NVidia graphics card and my display monitor sound driver, as well as my actual ones (in my case RME Fireface). I disabled the others in Device Manager and touch wood, no more DXGI errors so far.

Now, the only issue I am getting in P3D v5, is the brick wall smash up on short finals. I trust this will be fixed in the v5 HF next week.

Hope it helps.

Ray

Thanks, complete Nvidia uninstall using DDU, then graphic driver reinstalled WITHOUT sound driver.

On 4/26/2020 at 6:30 PM, rayharris108 said:

PS I am using Real Air Turbine Duke all the time. So I think it's unlikely to be your A2A. Anyway most of default planes are pretty unbearable for me :-(

Thanks, same thing using Carenado or default plane.

On 4/26/2020 at 7:46 PM, YoYo said:

Do not use ATC (AI traffic, you cant use ATC window, it could be frequencies of local ATC). Known issue.

No ATC.

 

On 5/6/2020 at 3:57 AM, Uteman said:

In my case I saw this problem early in V4 and several times in V5 until I remembered the v4 solution to turn of MSI afterburner (and RTSS) the problem goes away instantly for me. I run MSI full time to OC either a 1080TI or a 2080Ti and if I forget to turn it off v5 will crash with the error message almost every time a make a change at the v5 menu or make a scene change in the air. I was going to verify with some older cards but they are not DX12 compliant.

PCs and flight sims are an ongoing challenge - but that is part of the fascination (frustration?).

 

Thanks but MSI and RTSS uninstalled long ago.

On 5/6/2020 at 8:43 AM, redchiefnr1 said:

Hi,

 

I also had this error in prepar3dv4 and this solution from an older forum thread stopped the error occuring:

Found this solution on the internet, works for me 100% with P3Dv4.3 on Win10 64bit, Nvidia GTX1080ti and latest drivers. 

The problem: a thing called TDR checker monitors the computer’s hardware, particularly the GPU. When the GPU stops responding with the computer for 2 seconds TDR checker restarts the driver. The TDR checker was good on paper but did not work in the real world as a GPU can stop responding when it is working hard.

Here is the solution that worked for me, it requires an extra sub key entry into the Windows registry, so please only implement if you feel OK with editing your registry!

- Exit all Windows based programs,
- Click on the Windows Start button, type regedit in the Search box,double-click regedit.exe from the results above. 
If you are prompted for an administrator password or confirmation, type the password or provide confirmation,
- Browse to and then click the following registry subkey: 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers
- On the Edit menu, click New, and select the QWORD (64-bit) value from the drop-down menu,
- Type ‘TdrLevel’ as the Name and click Enter,
- Double-click TdrLevel and set the value as 0 (it is set to that by default, but double check) and click OK,
- Close the registry editor and restart your computer for the changes to take effect!

I saw this fix mentioned earlier in this thread, but make sure you create a Qword (64bit) key for Windows 64 bit OS and NOT a Bword (32 bit) key because that wil not give the right result.

If you encounter a DXGI hung/removed error again please make sure that this key still exists in your registry!
It happened to me once that the key vanished after a Windows Update, resulting in the dreadful DXGI hung error once again.

 

Cheers

Dirk

Thank you, Dirk, that didn't help.

On 5/6/2020 at 9:35 AM, fluffyflops said:

are you using asus gpu tweak II by any chance to over clock the card ?

 

Not according to Rob, I remember 3+ years ago I was belittled by Rob who was insistent the DXGI issue was my machine and couldn't ever ever possibly be a issue with LM coding ,but  and if you  chose a specific driver Version 397.64 (or before) this seems to remedy the issue.

But remember it's always your machine and never anything to do with LM ever, these coders always have that little back up line in their pockets

Howvever this blame the customer thoery seems to of changed now LM know they have released a product  full to the Brim of bugs and have been made to look a bit silly.

alas try these drivers and see if that solves it.

Version 397.64

 https://www.nvidia.com/download/driverResults.aspx/134070/en-us

Why not? 🙂
Will try and report, thanks!

  • Like 1

Best regards,
David Roch

AMD Ryzen 5950X //  Gigabyte X570 Aorus Xtreme //  32Gb Corsair Vengeance DDR4 4000 MHz CL17 //  EVGA GeForce RTX 3090 FTW3 ULTRA GAMING //  2x SSD 1Tb Corsair MP600 PCI-E4 NVM //  Corsair 1600W PSU & Samsung curved 49" TV monitor 4K.
Honeycomb Alpha Yoke & Beta Throttle + Thrustmaster Pendular Rudder.

 

Share this post


Link to post
13 minutes ago, David Roch said:

Well, I can't get rid of those crashes. 😵

It's not "crashing", its telling you that your settings are too high even for your 2080Ti and stops.

Rename your prepar3d.cfg and let a new one build, turn up your settings until your reaching the limit (stay under 9GB W10 1909 or 10GB @W10 2004

  • Like 1

System: i9 9900k@4.9 - 32 GB RAM - Aorus 1080ti --- Sim/Addons: P3D v5 + ProSim737
Signature3.png

Share this post


Link to post

Well it does crash actually, both with  the "DGXI error device hung" message and with the "Your dedicated graphics..." one.
No way to recover.
I haven't use any tool to OC my card, temperature stays acceptable in full load (72C), and VRAM never goes beyond 8.2.

And yes, p3d.cfg is new.

Edited by David Roch

Best regards,
David Roch

AMD Ryzen 5950X //  Gigabyte X570 Aorus Xtreme //  32Gb Corsair Vengeance DDR4 4000 MHz CL17 //  EVGA GeForce RTX 3090 FTW3 ULTRA GAMING //  2x SSD 1Tb Corsair MP600 PCI-E4 NVM //  Corsair 1600W PSU & Samsung curved 49" TV monitor 4K.
Honeycomb Alpha Yoke & Beta Throttle + Thrustmaster Pendular Rudder.

 

Share this post


Link to post

8.2 on VRAM I am on max settings and I am not going that high with TruSky enabled, something else is running with P3D to cause that check the background load with task manager. 


i9 10900K\ASUS 490 APEX \ MSI RTX 2080Ti GAMINGX TRIO \ 2 X M.2  Samsung 970 EVO Plus  \ 2 X 1TB Samsung 850 EVO \ 2TB BarraCuba SATA\ 32GB G.SKILL Z 3600MHZ \ Windows 10 Home\ ASUS 28" 4K monitor\ 4TB Portable Drive\P3DV5.1

Raymond Fry.

PMDG_Banner_747_Enthusiast.jpg

Share this post


Link to post

Ray, is your Texture resolution @High (2048) or Ultra (4096)?


Best regards,
David Roch

AMD Ryzen 5950X //  Gigabyte X570 Aorus Xtreme //  32Gb Corsair Vengeance DDR4 4000 MHz CL17 //  EVGA GeForce RTX 3090 FTW3 ULTRA GAMING //  2x SSD 1Tb Corsair MP600 PCI-E4 NVM //  Corsair 1600W PSU & Samsung curved 49" TV monitor 4K.
Honeycomb Alpha Yoke & Beta Throttle + Thrustmaster Pendular Rudder.

 

Share this post


Link to post

My settings are on the post I did Wednesday on this thread 2048, I will try it but running in 4K you need them some scenery is best at 2048.


i9 10900K\ASUS 490 APEX \ MSI RTX 2080Ti GAMINGX TRIO \ 2 X M.2  Samsung 970 EVO Plus  \ 2 X 1TB Samsung 850 EVO \ 2TB BarraCuba SATA\ 32GB G.SKILL Z 3600MHZ \ Windows 10 Home\ ASUS 28" 4K monitor\ 4TB Portable Drive\P3DV5.1

Raymond Fry.

PMDG_Banner_747_Enthusiast.jpg

Share this post


Link to post

The absolute only way to get rid of these "device hung" error messages is by doing a complete OS install and reinstalling everything from scratch. I do this once a year in February and (knock on wood) have not had this error since I began doing it (P3D v3.something.)

PITA, yea, you bet. Takes about 2 days but then this thread is already 2 weeks old without an end in sight. You're already staying home, staying safe, so why not. Install everything fresh, not updating an update that was previously updated. Clear out those useless gotta have utility(s), scenery(s), etc

I also give the computer case the once over. Reseating memory, cards, cables, etc.


-Jay

9700K | RTX 2080Ti @ 4K | 48GB DDR4 | 2 x 1TB SSDs | RC Cola

Share this post


Link to post

Getting the same error with a 1080ti 😞


Twitch | Facebook

i9-9900K O/C 5.0 GHz | ASUS ROG Strix NVIDIA GeForce RTX 3080 OC Edition | 32GB DDR 4 - 3200MHz | Asus Rog Strix Z390-E Gaming | Sabrent 512GB M.2 & Sabrent 1TB M.2 | Kaken X62 Cpu Cooler | NZXT H510 Elite Case

Share this post


Link to post

My guess is your settings are too high. I have only had V5 give me that error once. And that's when I had every single option turned on AND 4096 textures. Drop your textures down to 2048 or 1024 I bet the problem goes away. 


Flight Simulator - P3D V4.5/V5.1/MSFS2020 | Operating System - WIN 10 | Main Board - GIGABYTE Z390 AORUS PRO | CPU - INTEL 9700k (5.0Ghz) | RAM - VIPER 32Gig DDR4 4000Mhz | Video Card - EVGA RTX3090 FTW3 ULTRA Monitor - DELL 38" ULTRAWIDE | Case - CORSAIR 750D FULL TOWER | CPU Cooling - CORSAIR H150i Elite Push/Pull | Power Supply - EVGA 1000 G+ 

Share this post


Link to post

Just run 4096 textures over ORBX SOCAL, LAX no problem highest GPU 5.9-6.0.

  • Like 1

i9 10900K\ASUS 490 APEX \ MSI RTX 2080Ti GAMINGX TRIO \ 2 X M.2  Samsung 970 EVO Plus  \ 2 X 1TB Samsung 850 EVO \ 2TB BarraCuba SATA\ 32GB G.SKILL Z 3600MHZ \ Windows 10 Home\ ASUS 28" 4K monitor\ 4TB Portable Drive\P3DV5.1

Raymond Fry.

PMDG_Banner_747_Enthusiast.jpg

Share this post


Link to post

Yep settings are too high. Try 1K textures, AA et al off .. start from the left with sliders and go a notch to the right and find that balance. I have 1080ti, 32GB, 8700k , no crazy OC settings on those either. But need to run 1K textures , AA off (!), medium scenery and autogen .. especially if want to use enhanced atmospherics with medium cloud resolution. I also run AI traffic. Maybe if not using AI or EA clouds I could use 2k textures? It took a week for me to get the settings where I could reduce the DXGI errors to almost zero (it does happen once in a while even still). LM have will optimize / balancing things out in the near future. The sim runs 30fps and smooth as silk. Looks still much better than 4.5, I just enjoy flying this sim so much now. Good luck!

Share this post


Link to post

I have this issue as well, but for me it seems to be location specific. I have a 2080ti, and at EGLL with TE, if i spin the camera too quick i get that error. However ive noticed a significant vram decrease switching from default AI to AIG AI manager. Have to test EGLL to see if i see the same vram saving there. I firmly believe this is a vram issue.

-Tony@PVD

 

Edit to add: I use Aerosoft EGLL

Edited by breakinghbts

Tony Moore

Share this post


Link to post

I went back to Nvidia 442.50 and it's better for me. Not sure just what affects this issue.

 


PC=9700K@5Ghz+RTX2070  VR=HP Reverb|   Software = Windows 10 | Flight SIms = P3D, CAP2, DCS World, IL-2,  Aerofly FS2

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    45%
    $11,465.00 of $25,000.00 Donate Now
×
×
  • Create New...