Jump to content

Sign in to follow this  
David Roch

P3DV5: "DGXI error device hung" with an RTX 2080Ti (?)

Recommended Posts

I get this error but also can fly for hrs and not get it. I have tried all different scenarios and settings and still cant find what causes it. Settings in most cases wont fix it. I think it is some bad code in P3D that needs to be looked at and 3rd party sceneries like ORBX with issues even with there V5 compatible sceneries  . I will just have to live with the crashes for now as v4.5 don't cut it for me anymore. I still have V4.5 installed just in case it gets really bad.

  • Upvote 1

Share this post


Link to post

Since I installed Nvidias latest "Studio Driver" this error did not happen again and I did many flights with the sim the last days. Even I increased all my graphic settings again, used GSX2 a lot and touch wood, the sim behaved.

Seems that this error is caused by the latest Nvidia drivers - at least for me.

 


Jürgen Martens

Share this post


Link to post

For now the only fix for me is to revert to 2048x2048 texture.
But I am not satisfied with it.
I will try older and "Studio" drivers 😉 .


Best regards,
David Roch

AMD Ryzen 5950X //  Gigabyte X570 Aorus Xtreme //  32Gb Corsair Vengeance DDR4 4000 MHz CL17 //  EVGA GeForce RTX 3090 FTW3 ULTRA GAMING //  2x SSD 1Tb Corsair MP600 PCI-E4 NVM //  Corsair 1600W PSU & Samsung curved 49" TV monitor 4K.
Honeycomb Alpha Yoke & Beta Throttle + Thrustmaster Pendular Rudder.

 

Share this post


Link to post

Out of blue I've got my first while changing  some settings back and fort.....FYI vRam was at 2.5Gb, whatever that has anything to do...or not. But because of  to many "complaints"  here I abused V5 to the max...and I haven't reproduced any (doesn't mean won't happen either). Only ( and now big difference) with ASP, disabling TS vRam drops significantly...and for me that wasn't the case before. What will happen with real AC remains to be tested.....  And now since I can see real weather and clouds looks more realistic. I guess it's taste. TS gives endless haze...nice but overkill...


Virtual Air Canada - Alex Luzajic

Share this post


Link to post
3 hours ago, Yogipriester said:

Since I installed Nvidias latest "Studio Driver" this error did not happen again and I did many flights with the sim the last days. Even I increased all my graphic settings again, used GSX2 a lot and touch wood, the sim behaved.

Seems that this error is caused by the latest Nvidia drivers - at least for me.

 

I switched to the Studio drivers, but still getting the crash. And my card has 12GB of VRAM, so...

I haven't found the issue - no real pattern to the crashes. It isn't just the Dynamic Texture Streaming setting, because I can get them with and without that checked.

Unfortunately, when you post over at Prepar3D forum, some "helpful" regulars (not L-M staff) there always chime in with the same recycled troubleshooting steps (as if most of us using this are newbies and haven't been through multiple versions of P3D).  It's as if all they have to do is sit on the forum there and wait to post the same useless advice over and over.  I am only really interested in engaging there when L-M staff are involved, so I know the info is getting to their team.


- Kevin

Windows 10 / i9-10900k (de-lidded) / MSI MEG Z490 ACE mobo / Corsair H150i RGB PRO XT liquid cooler / 32GB Corsair Vengeance LPX 3333MHz C16 DDR4 RAM / Nvidia Titan Xp 12GB / Dell Alienware AW3418DW WQHD 3440x1440 GSync / Samsung 970 EVO Plus M.2 2TB (OS) & 860 EVO 4TB / WD Caviar Black 4TB HDD  / EVGA Supernova 850 G5 PSU / Be Quiet Dark Base Pro 900 rev 2 case / ThrustMaster Warthog HOTAS stick & throttle / MFG Crosswind rudder pedals / C-Tek CT-203 collective / Virtual-Fly TQ6+ throttle quadrant / Saitek Trim Wheel / Saitek Radio and Switch Panels / Thrustmaster MFD Cougars (2) / TrackIR 5

Share this post


Link to post
8 hours ago, JoeFackel said:

It's not "crashing", its telling you that your settings are too high even for your 2080Ti and stops.

Rename your prepar3d.cfg and let a new one build, turn up your settings until your reaching the limit (stay under 9GB W10 1909 or 10GB @W10 2004

 

4 hours ago, TurboKen said:

My guess is your settings are too high. I have only had V5 give me that error once. And that's when I had every single option turned on AND 4096 textures. Drop your textures down to 2048 or 1024 I bet the problem goes away. 

Sorry, but no.  My system specs are listed below.  Almost none of my sliders are past mid-way - don't have anywhere close to max. This isn't some "turn your sliders down" issue - and available user-adjustable sliders should not crash a program when you have the hardware many of us have.  I could accept this if we saw stuttering and low fps (that would suggest we have overdone the settings), but not a driver error. The coding should be more robust than that.

Edited by PurdueKev

- Kevin

Windows 10 / i9-10900k (de-lidded) / MSI MEG Z490 ACE mobo / Corsair H150i RGB PRO XT liquid cooler / 32GB Corsair Vengeance LPX 3333MHz C16 DDR4 RAM / Nvidia Titan Xp 12GB / Dell Alienware AW3418DW WQHD 3440x1440 GSync / Samsung 970 EVO Plus M.2 2TB (OS) & 860 EVO 4TB / WD Caviar Black 4TB HDD  / EVGA Supernova 850 G5 PSU / Be Quiet Dark Base Pro 900 rev 2 case / ThrustMaster Warthog HOTAS stick & throttle / MFG Crosswind rudder pedals / C-Tek CT-203 collective / Virtual-Fly TQ6+ throttle quadrant / Saitek Trim Wheel / Saitek Radio and Switch Panels / Thrustmaster MFD Cougars (2) / TrackIR 5

Share this post


Link to post

P3D can create a report you should do this and go to the LM support site and let them have a look, if they see something that's causing a problem they will spot it strait away. 


i9 10900K\ASUS 490 APEX \ MSI RTX 2080Ti GAMINGX TRIO \ 2 X M.2  Samsung 970 EVO Plus  \ 2 X 1TB Samsung 850 EVO \ 2TB BarraCuba SATA\ 32GB G.SKILL Z 3600MHZ \ Windows 10 Home\ ASUS 28" 4K monitor\ 4TB Portable Drive\P3DV5.1

Raymond Fry.

PMDG_Banner_747_Enthusiast.jpg

Share this post


Link to post
7 minutes ago, PurdueKev said:

 

Sorry, but no.  My system specs are listed below.  Almost none of my sliders are past mid-way - don't have anywhere close to max. This isn't some "turn your sliders down" issue - and available user-adjustable sliders should not crash a program when you have the hardware many of us have.  I could accept this if we saw stuttering and low fps (that would suggest we have overdone the settings), but not a driver error. The coding should be more robust than that.

I would upgrade your video card then, you only have a titan. LOL just kidding man.. I don't know I'm sorry I cant help. Maybe the next hotfix will do something for the crashes people are reporting. I'm just not getting them.


Flight Simulator - P3D V4.5/V5.1/MSFS2020 | Operating System - WIN 10 | Main Board - GIGABYTE Z390 AORUS PRO | CPU - INTEL 9700k (5.0Ghz) | RAM - VIPER 32Gig DDR4 4000Mhz | Video Card - EVGA RTX3090 FTW3 ULTRA Monitor - DELL 38" ULTRAWIDE | Case - CORSAIR 750D FULL TOWER | CPU Cooling - CORSAIR H150i Elite Push/Pull | Power Supply - EVGA 1000 G+ 

Share this post


Link to post
14 minutes ago, TurboKen said:

I would upgrade your video card then, you only have a titan. LOL just kidding man.. I don't know I'm sorry I cant help. Maybe the next hotfix will do something for the crashes people are reporting. I'm just not getting them.

LOL - if VRAM is my problem then everyone is screwed.  😃  Yeah, this one is weird because not everyone is getting them, and it is not totally clear what the common thread is.  I know I seem to be able to fly around to my heart's content with the F-22 after the hotfix (before the hotfix, just the ATC window open would cause the crash - but that is gone), but use anything that has popup windows or what-not and I start seeing issues.  But for others it is with default aircraft.  A lot of us have already backed way off on the sliders and still see issues.

It is a shame because the sim is really impressive when it doesn't crash.  I was having a blast last night buzzing FSDreamteam KIAH in the F-22 at low level over-and-over and marveling how smooth everything was.  I am hoping the fix does not walk back these performance improvements.

Also frustrated because in order to troubleshoot this, it take users collecting log files and submitting them running with different settings, add-ons turned on and off, etc...  It may sound bad, but I don't have the time to test and troubleshoot - I expect the software to be reasonably stable out-of-the-box.  The other sim-that-shall-remain-nameless (no not that one - the other one, LOL) does have more built-in mechanisms for users to report bugs quickly during beta (let's be honest - this IS an open beta), that I wish P3D had.

I am still spending most of my time on v4.5 until this all gets sorted - which is sort of like going from a Ferrari back to a Honda Civic.

Edited by PurdueKev

- Kevin

Windows 10 / i9-10900k (de-lidded) / MSI MEG Z490 ACE mobo / Corsair H150i RGB PRO XT liquid cooler / 32GB Corsair Vengeance LPX 3333MHz C16 DDR4 RAM / Nvidia Titan Xp 12GB / Dell Alienware AW3418DW WQHD 3440x1440 GSync / Samsung 970 EVO Plus M.2 2TB (OS) & 860 EVO 4TB / WD Caviar Black 4TB HDD  / EVGA Supernova 850 G5 PSU / Be Quiet Dark Base Pro 900 rev 2 case / ThrustMaster Warthog HOTAS stick & throttle / MFG Crosswind rudder pedals / C-Tek CT-203 collective / Virtual-Fly TQ6+ throttle quadrant / Saitek Trim Wheel / Saitek Radio and Switch Panels / Thrustmaster MFD Cougars (2) / TrackIR 5

Share this post


Link to post
18 minutes ago, G-RFRY said:

P3D can create a report you should do this and go to the LM support site and let them have a look, if they see something that's causing a problem they will spot it strait away. 

Is there somewhere in the L-M documentation on how to do that?  I am happy to create a log file and submit it, but the standard reporting from the Windows Event Manager seems not all that helpful.

Edited by PurdueKev

- Kevin

Windows 10 / i9-10900k (de-lidded) / MSI MEG Z490 ACE mobo / Corsair H150i RGB PRO XT liquid cooler / 32GB Corsair Vengeance LPX 3333MHz C16 DDR4 RAM / Nvidia Titan Xp 12GB / Dell Alienware AW3418DW WQHD 3440x1440 GSync / Samsung 970 EVO Plus M.2 2TB (OS) & 860 EVO 4TB / WD Caviar Black 4TB HDD  / EVGA Supernova 850 G5 PSU / Be Quiet Dark Base Pro 900 rev 2 case / ThrustMaster Warthog HOTAS stick & throttle / MFG Crosswind rudder pedals / C-Tek CT-203 collective / Virtual-Fly TQ6+ throttle quadrant / Saitek Trim Wheel / Saitek Radio and Switch Panels / Thrustmaster MFD Cougars (2) / TrackIR 5

Share this post


Link to post
54 minutes ago, PurdueKev said:

This isn't some "turn your sliders down" issue - and available user-adjustable sliders should not crash a program when you have the hardware many of us have.

Its not the sliders. Its enough when you run 4K with high AA setting and high texture size your VRAM is full after a blink of your eye. 

  • Like 1

System: i9 9900k@4.9 - 32 GB RAM - Aorus 1080ti --- Sim/Addons: P3D v5 + ProSim737
Signature3.png

Share this post


Link to post
4 minutes ago, JoeFackel said:

Its not the sliders. Its enough when you run 4K with high AA setting and high texture size your VRAM is full after a blink of your eye. 

Not running 4K. No SSAA. Medium texture size.


- Kevin

Windows 10 / i9-10900k (de-lidded) / MSI MEG Z490 ACE mobo / Corsair H150i RGB PRO XT liquid cooler / 32GB Corsair Vengeance LPX 3333MHz C16 DDR4 RAM / Nvidia Titan Xp 12GB / Dell Alienware AW3418DW WQHD 3440x1440 GSync / Samsung 970 EVO Plus M.2 2TB (OS) & 860 EVO 4TB / WD Caviar Black 4TB HDD  / EVGA Supernova 850 G5 PSU / Be Quiet Dark Base Pro 900 rev 2 case / ThrustMaster Warthog HOTAS stick & throttle / MFG Crosswind rudder pedals / C-Tek CT-203 collective / Virtual-Fly TQ6+ throttle quadrant / Saitek Trim Wheel / Saitek Radio and Switch Panels / Thrustmaster MFD Cougars (2) / TrackIR 5

Share this post


Link to post

Sure? Show your "DISPLAY" setting window when possible.

Guess you have at least WQHD to fit your monitor.


 


System: i9 9900k@4.9 - 32 GB RAM - Aorus 1080ti --- Sim/Addons: P3D v5 + ProSim737
Signature3.png

Share this post


Link to post

i just got a dxgi error from simply rightclicking on the screen and then left clicking too quickly.  sitting in the pmdg 747 at the default start airport. 

Its a bug.  dont be fooled by people itching to be LM contractors with their graphs and charts.  Its a bug where is badly coded.

We had a similar thing years back in fs2004 called uiautomationcore.dll.  

OOMS due to graphics card VRAM limitations are one thing, but this dxgi error is a bug.  In v4 they got away with telling you it was "your system" because v4 had hardly any bugs if any.  Now with v5 being full of them they cant really use that "its your system" get of jail card anymore.

my 10 cents.  

  • Upvote 1

 
 
 
 
v63vq9-5.png

Share this post


Link to post

Yes, its going to take some time for LM to fix the issues. So most people have found that reducing the settings, after trying every other workaround mentioned, gives them a few hours of dxgi-free flying. Its frustrating but people are just trying to make the best of it they can.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    45%
    $11,465.00 of $25,000.00 Donate Now
×
×
  • Create New...