Jump to content

netshadoe

Heads up on new AI separation utilities for P3Dv4

Recommended Posts

3 hours ago, captain420 said:

I'm still showing issues where the AI seems like they're running into each other at FB's KSFO. Also still seeing planes go around when landing, although not as often. Does anyone have a good base setting for AI Ground, AI Flow for those of us who are using AIG-OCI?

I also have witnessed 2 planes parked on top of one another at the gates. Will need to do more testing. I am currently using the default settings for AI Ground, AI Flow and AI Cull.

I run the HF7 versions with default settings and AIG and have not seen what you report. Can you confirm the start-up of the programs and monitor their procession?


i7 7700K @4.6, GTX 1060 6 Gig, Windows 10

Share this post


Link to post
2 hours ago, jimcarrel said:

I run the HF7 versions with default settings and AIG and have not seen what you report. Can you confirm the start-up of the programs and monitor their procession?

I think he has other underlying AI issues rather than with Roland's AI utilities:

https://www.avsim.com/forums/topic/577535-how-to-prevent-unrealistic-ai-behaviors-at-busy-airports/?tab=comments#comment-4261778

  

5 hours ago, captain420 said:

I'm still showing issues where the AI seems like they're running into each other at FB's KSFO. Also still seeing planes go around when landing, although not as often. Does anyone have a good base setting for AI Ground, AI Flow for those of us who are using AIG-OCI?

I also have witnessed 2 planes parked on top of one another at the gates. Will need to do more testing. I am currently using the default settings for AI Ground, AI Flow and AI Cull.

Aaron, I think you need to check if you have more than one ADE file active for KSFO.

I have only ever seen AI park on top of each other at gates where there is a second ADE file for the airport and it is active, or the AI models' wingspan is set so low that the anti-crash 'bubble' surrounding the AI model is ineffective, or the static AI that comes with a scenery is forgetten to be turned off.

No AI that I have used replicates what you are seeing at KSFO in your other thread.
 

 


Ryzen 3700X 4.4GHz(PBO) / Gigabyte AB350 Gaming 3 / ASUS GTX 1070 O8G / 32GB Corsair Vengeance 3200 MHz / triple monitor

P3Dv5 HF1 + FS Global Ultimate NG + ORBX + ASP3D (beta) + ChasePlane + WIN 10 Pro
QW 757 787 / AS A32x A330 / MJC Dash 8 / A2A PA-28 / JF C152 / PA A380 / PMDG 737NGX  777 / FT E-Jets v2

Share this post


Link to post
44 minutes ago, F737NG said:

I think he has other underlying AI issues rather than with Roland's AI utilities:

https://www.avsim.com/forums/topic/577535-how-to-prevent-unrealistic-ai-behaviors-at-busy-airports/?tab=comments#comment-4261778

  

Aaron, I think you need to check if you have more than one ADE file active for KSFO.

I have only ever seen AI park on top of each other at gates where there is a second ADE file for the airport and it is active, or the AI models' wingspan is set so low that the anti-crash 'bubble' surrounding the AI model is ineffective, or the static AI that comes with a scenery is forgetten to be turned off.

No AI that I have used replicates what you are seeing at KSFO in your other thread.
 

 

Is there a way to easily check for duplicate ADE file? I am currently using FB's KSFO.


Aaron Vinci

----------------

Intel i7 3770k @ 4.5Ghz / Windows 10 Professional 64 bit / 32GB DDR3 1600MHz RAM / EVGA NVIDIA GTX 1080 FTW 8GB RAM / 128MB SSD (OS Drive) / 2x2TB HDD / 750watt PSU

Share this post


Link to post
26 minutes ago, captain420 said:

Is there a way to easily check for duplicate ADE file? I am currently using FB's KSFO.

All I can suggest is to use Lorby's P5AO. On the 'Backup/Restore' tab, click 'Export library for external tool' then run ScruffyDuck's Simple Airport Scanner tool.
 


Ryzen 3700X 4.4GHz(PBO) / Gigabyte AB350 Gaming 3 / ASUS GTX 1070 O8G / 32GB Corsair Vengeance 3200 MHz / triple monitor

P3Dv5 HF1 + FS Global Ultimate NG + ORBX + ASP3D (beta) + ChasePlane + WIN 10 Pro
QW 757 787 / AS A32x A330 / MJC Dash 8 / A2A PA-28 / JF C152 / PA A380 / PMDG 737NGX  777 / FT E-Jets v2

Share this post


Link to post

@Clipper Ocean Spray, I've tried to change:

MODE_A3_X=50
MODE_A4_X=75
MODE_A5_X=125

But the menu items will not change in P3D. I think I got more planes via A5=125, but I would like to confirm that it is only printout issue in the menu and that the parameters actually work


Vincent Rouleau

Intel Core i7 8700K @ 5.1GHz / 16.0GB G.SKILL TridentZ DDR4 3000 / Gigabyte  GeForce® RTX 2080 / / Samsung C49RG9 49' /ASUS  PB287QQ ‑ 27" UHD / Samsung 970 PRO 1TB /  PNY SSD 1TB / Windows 10 Pro 64-bit / Gigabyte Z370 AORUS Gaming 5 Motherboard

Share this post


Link to post
1 hour ago, vincentrouleau said:

@Clipper Ocean Spray, I've tried to change:

MODE_A3_X=50
MODE_A4_X=75
MODE_A5_X=125

But the menu items will not change in P3D. I think I got more planes via A5=125, but I would like to confirm that it is only printout issue in the menu and that the parameters actually work

Yes, that is a bug.  Thanks for reporting it.  Fix incoming soon!  Regards, Roland.

Share this post


Link to post
Posted (edited)

Some updates:

AIFlow v1.1 OfficialAvsim Lib Download ID 218506

AIGround v1.1 OfficialAvsim Lib Download ID 218507

The AIFlow and AIGround officials are the most recent HF7, so no need to download if you already have those.

AICull HF4:  Mediafire AICull_v101HF4.zip

Fixed: AICull.ini changes not being read.  If anyone notices other issues, please let me know quickly because I need to upload this fix into the avsim lib soon.

Thanks, Roland.

 

Edited by Clipper Ocean Spray
  • Like 7
  • Upvote 1

Share this post


Link to post
Posted (edited)
7 hours ago, Clipper Ocean Spray said:

Some updates:

AIFlow v1.1 OfficialAvsim Lib Download ID 218506

AIGround v1.1 OfficialAvsim Lib Download ID 218507

The AIFlow and AIGround officials are the most recent HF7, so no need to download if you already have those.

AICull HF4:  Mediafire AICull_v101HF4.zip

Fixed: AICull.ini changes not being read.  If anyone notices other issues, please let me know quickly because I need to upload this fix into the avsim lib soon.

Thanks, Roland.

 

Thanks Roland for those great tools really appreciated 😎

Edited by awf

 

André
 

Share this post


Link to post

Yes, thank you very much for these very handy tools 😎


AMD Ryzen 3900X - Asus Crosshair VI Hero - G.Skill 32GB (2x16GB) 3000 C14 DDR4 @ 3600 C16

AMD Radeon VII 16GB HBM2 @ 1950/1150 1135mv  - 3 x Iiyama G-Master GB2888UHSU 4k @ 7680x1440

Saitek X-55 Rhino - Track IR5 - Obutto Sim Cockpit + Triple Monitor Stand - Fancy some Techno? https://www.mixcloud.com/dj_bully/

Share this post


Link to post

Thanks so much too. Very useful.

Cheers, Ed


Ed Patino

P3Dv4.5 hf2 - Win 10 Home x64 // Rig: Corsair Graphite 780T Full Tower - ASUS MBoard Maximus XI Hero Z390 - CPU Intel i7-8086k 6-cores - 32GB RAM - MSI Nvidia GeForce GTX1080Ti 11GB - 3 x SSD x 1TB Crucial/Samsung + 1 x SSD 2TB Crucial + 1 HDD Seagate 2TB + 1 HDD External Seagate 2TB - Monitor LG 29UC97C UWHD Curved - PSU Corsair RM1000x - VR Oculus Rift // P3Dv4.5 hf2 & Aerofly FS 2 - Win 10 Home x64 - Gaming Laptop CUK ASUS Strix - CPU Intel i7-8750H - 32GB RAM - Nvidia RTX 2070 - 2TB SSD - 2TB HDD // Thrustmaster FCS & MS XBOX Controllers

Share this post


Link to post

FYI AiCull HF4 worked for me. Thanks for the fix


Vincent Rouleau

Intel Core i7 8700K @ 5.1GHz / 16.0GB G.SKILL TridentZ DDR4 3000 / Gigabyte  GeForce® RTX 2080 / / Samsung C49RG9 49' /ASUS  PB287QQ ‑ 27" UHD / Samsung 970 PRO 1TB /  PNY SSD 1TB / Windows 10 Pro 64-bit / Gigabyte Z370 AORUS Gaming 5 Motherboard

Share this post


Link to post

Thanks for these great tools, I wouldn't fly without them anymore. 

Share this post


Link to post
29 minutes ago, vincentrouleau said:

FYI AiCull HF4 worked for me. Thanks for the fix

Worked for me here too. The three values (A3, A4, A5) are being read by the AICull.ini.

Thanks for the fix.

Cheers, Ed


Ed Patino

P3Dv4.5 hf2 - Win 10 Home x64 // Rig: Corsair Graphite 780T Full Tower - ASUS MBoard Maximus XI Hero Z390 - CPU Intel i7-8086k 6-cores - 32GB RAM - MSI Nvidia GeForce GTX1080Ti 11GB - 3 x SSD x 1TB Crucial/Samsung + 1 x SSD 2TB Crucial + 1 HDD Seagate 2TB + 1 HDD External Seagate 2TB - Monitor LG 29UC97C UWHD Curved - PSU Corsair RM1000x - VR Oculus Rift // P3Dv4.5 hf2 & Aerofly FS 2 - Win 10 Home x64 - Gaming Laptop CUK ASUS Strix - CPU Intel i7-8750H - 32GB RAM - Nvidia RTX 2070 - 2TB SSD - 2TB HDD // Thrustmaster FCS & MS XBOX Controllers

Share this post


Link to post

One last thing though, I still run AiCull manually, as using the addon.xml method still does not work for me. I must set the "run as administrator" in the exe properties and run manually, otherwise the deletion does not do anything. Ed, do you have the same behavior?


Vincent Rouleau

Intel Core i7 8700K @ 5.1GHz / 16.0GB G.SKILL TridentZ DDR4 3000 / Gigabyte  GeForce® RTX 2080 / / Samsung C49RG9 49' /ASUS  PB287QQ ‑ 27" UHD / Samsung 970 PRO 1TB /  PNY SSD 1TB / Windows 10 Pro 64-bit / Gigabyte Z370 AORUS Gaming 5 Motherboard

Share this post


Link to post
Posted (edited)
14 minutes ago, vincentrouleau said:

One last thing though, I still run AiCull manually, as using the addon.xml method still does not work for me. I must set the "run as administrator" in the exe properties and run manually, otherwise the deletion does not do anything. Ed, do you have the same behavior?

I've added all of them (AI Cull and AI Ground, AI Flow) using the addon-xml method and all they start-up together with P3D (haven't selected "run as administrator" in the files properties). I haven't noticed any anomalies in their functioning so far. Why do you say it's not working for you?. Have you activated AI Cull during the P3D start-up process?.

I also suggest adding the AICull folder, as it comes from the download, directly into your P3D addons folder typically located in %Documents%.

Cheers, Ed

Edited by edpatino

Ed Patino

P3Dv4.5 hf2 - Win 10 Home x64 // Rig: Corsair Graphite 780T Full Tower - ASUS MBoard Maximus XI Hero Z390 - CPU Intel i7-8086k 6-cores - 32GB RAM - MSI Nvidia GeForce GTX1080Ti 11GB - 3 x SSD x 1TB Crucial/Samsung + 1 x SSD 2TB Crucial + 1 HDD Seagate 2TB + 1 HDD External Seagate 2TB - Monitor LG 29UC97C UWHD Curved - PSU Corsair RM1000x - VR Oculus Rift // P3Dv4.5 hf2 & Aerofly FS 2 - Win 10 Home x64 - Gaming Laptop CUK ASUS Strix - CPU Intel i7-8750H - 32GB RAM - Nvidia RTX 2070 - 2TB SSD - 2TB HDD // Thrustmaster FCS & MS XBOX Controllers

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    21%
    $5,415.00 of $25,000.00 Donate Now
×
×
  • Create New...