Jump to content

Sign in to follow this  
naknaksdad

CH Products Pro Yoke and Pro Pedals with WIN10

Recommended Posts

My win7 became unstable and I recently upgraded to win10. FSX SE not recognizing the Yoke and Pedals in the calibration settings. Controllers worked fin in win7. I did a complete reinstall of FSX and used the controller manager for the yoke and pedals. win10 does recognize the hardware and states they are working properly. Is there a solution to this?


Scott T Woods

Share this post


Link to post
Share on other sites

I used CH Control Manager for years but it is a bear to understand and program. Also, the manufacturer provides no support or repair for the items they sell.

First, make sure Windows is up to date. Find the search function. Go to the control panel and find windows update. Click on it and make sure windows is up to date. If offered a different version of windows you can ignore that (mine wants me to upgrade to 1909 but just make sure whatever version you have is up to date. When finished there, again in the control panel select device manager and activate it. Now, at the very bottom you'll see listed "Universal Serial Bus Controllers. Click there and you'll see USB Generic Hubs listed and USB Root Hubs. On each, right click and open Properties and then the Power Management tab. If any items there are checked remove the check marks. Now try again.  Lastly, again go to the search tool and type USB troubleshooter and you'll get more instructions via the internet. I had trouble with the GoFlight modules being recognized and solved them with the power management settings. Lastly, again, just open the browser and type USB hardware not recognized in Windows 10. Lots of articles and suggestions there. Best wishes.

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/12/2020 at 12:57 AM, loop_n_roll said:

Lastly, again, just open the browser and type USB hardware not recognized in Windows 10.

He said Windows 10 recognises his hardware, so your suggestions don't apply. It's just FSX that doesn't recognise it.

@naknaksdad- are you using FSX:SE (Steam Edition)? If so, check the Steam controller settings. Close FSX. Open Steam and in the menu go to Steam-->Settings-->Controller. Select General Controller Settings. Uncheck everything there and try FSX again.

Edited by vortex681

 i7-6700k | Asus Maximus VIII Hero | 16GB RAM | MSI GTX 1080 Gaming X Plus | Samsung Evo 500GB & 1TB | WD Blue 2 x 1TB | EVGA Supernova G2 850W | AOC 2560x1440 monitor | Win 10 Pro 64-bit

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    22%
    $5,550.00 of $25,000.00 Donate Now
×
×
  • Create New...