Jump to content

Sign in to follow this  
MarkW

Frame rate drops over time (P3d v5)

Recommended Posts

Any other reports of framerates that drop significantly over time.  I am getting great framerates at the start of the flight (QW 787, PMDG 747)  but over time the framerates drop to single digits.  The is kind of a stutter drop ever 4 or 5 seconds.  so the frames will be 30, 35, 40, 50 and the down to 6, 7 and then back up again.  Really annoying and I cannot figure out what is causing this problem.  My settings are middle of the road in my opinion, no higher than in v4.  I have ES Beta on but does not seem to matter if I turn it off.  So far no CTD or running out of VM (1080Ti).


Mark W   CYYZ      

My Simhttps://goo.gl/photos/oic45LSoaHKEgU8E9

My Concorde Tutorial Videos available here:  https://www.youtube.com/user/UPS1000
 

 

Share this post


Link to post

I noticed similar behavior, but most severely when running multiple sessions of P3D per boot cycle of my PC.  In other words, P3D fps is noticeably worst on the 2nd or 3rd session compared to the first, until I reboot the PC and I'm back to "normal" fps.


Mark Javornik

Share this post


Link to post

I've seen this as well. Noticed with the majestic dash 8 that frames were solid 30 at runtime, then gradually deteriorated to around 10 over about 20 mins.  CPU monitoring showed core 0 load go from 60% to 100% (GPU was under 50% throughout).  No change in scenery, AI or user aircraft apart from view changes.


Kevin Firth - i7-8700K @5.0; Asus Maximus X Hero; 32Gb Cas14 3200 DDR4; RTX2080Ti

Beta tester for: UK2000; JustFlight; VoxATC; FSReborn; //42

Share this post


Link to post
9 hours ago, MarkW said:

Any other reports of framerates that drop significantly over time.  I am getting great framerates at the start of the flight (QW 787, PMDG 747)  but over time the framerates drop to single digits.  The is kind of a stutter drop ever 4 or 5 seconds.  so the frames will be 30, 35, 40, 50 and the down to 6, 7 and then back up again.  Really annoying and I cannot figure out what is causing this problem.  My settings are middle of the road in my opinion, no higher than in v4.  I have ES Beta on but does not seem to matter if I turn it off.  So far no CTD or running out of VM (1080Ti).

Are you flying online?  I notice Vpilot sometimes uses up to 17% of my CPU load and that makes my fps drop significantly. 

Did a 1,5 hours flight and on approach the fps was cut in half. Restart Vpilot 0,5-2% cpu load and FPS went back. 

Michael Moe 


Michael Moe

 

fs2crew_747_banner1.png

Banner_FS2Crew_Emergency.png

Share this post


Link to post

Having this too. I think it is related to the P3DV5 EA mode set to on.

 

My work around:

  • Start a flight with EA on, normally set in my P3D CFG menu to on.
  • When in flight just open menu. Uncheck EA mode (set to off)
  • Go back to flight with EA mode set to off
  • Then open menu again and Check EA mode (to on)
  • Fly again

Issues gone. No degrading of FPS on my system anymore.

My feeling says that there is something wrong with the EA related shading. Refreshing the shaders while in flight does not work either for me.

Try it and report back if it solves/not solves your issue. 

Note: You don´t have to wait to perform this work around till fps got drop/degrarded. Just do it instantly on "begin" of your flight. This works also.

Regards

Marcus

Share this post


Link to post

You dont even have to accept the changes in my case: simply go to the menue, change whatever setting and click on "cancal" usually restores FPS... funny though I do not see the FPS loss on every flight...


Greetings, Chris

Intel i7-8700K@5.0GHz, 2x16GB 3200MHz CL14 RAM, Gigabyte AORUS 1080Ti, Windows 10 Home 64bit, Prepar3D 4.5

Share this post


Link to post

Make sure autosave is off in FSUIPC aswell, as this will cause a temp drop in FPS as described as it saves.

Share this post


Link to post

Good.  I thought it was just me.  Absolutely, frame rates drop over time.  Many times the 1st leg of my flight is great for a few hundred miles.  However, after I land, refuel and take off again from that 1st airport, using the same plane, I can assure you that halfway through that flight to my 2nd destination, that the frames will drop into the cellar several times.  It can get so bad that I hear that inevitable lapse in sound which signals a CTD about to happen.

I've taken to just doing flights from airport A to airport B.  Then I'll quit and start a new P3d session.  I'm assuming Hotfix 2 will fix this.

BTW, I do not use EA so that has nothing to do with it, in my opinion.

Stan

Share this post


Link to post

I noticed if I do a short flight in the NGX of under 2 hours then no problem. I have tried CYYZ to EGLL 787 and EGLL to KBOS I. The 744 and both time’s landed with single digit frame rates.  Not really usable like this. I actually started turning down all sliders to basically nothing on approach and did not help at all 


Mark W   CYYZ      

My Simhttps://goo.gl/photos/oic45LSoaHKEgU8E9

My Concorde Tutorial Videos available here:  https://www.youtube.com/user/UPS1000
 

 

Share this post


Link to post

There are similar contents on Aerosoft forum as well as ActiveSky Forum.

stuttering-strong-fps-fluctuations-after-3-4-hours-in-flight

fps-being-taxed-every-ca-30-secs-from-high-80-to-low-20-and-then-up-again

Both threads pointed the problem to ActiveSkyP3D, which is still in beta.

Me personally also had this problem serveral days ago, what I did is to re-install ASP3D

Have done a 1-hour flight, and all seems ok, no performance loss, normally I will get constant shutters and thus fps drop to 20-ish fps after 40 minutes or so.

My spec: R7 3700X\RTX2070, Windows10 Home 2004 , P3Dv5 HF1,ActiveSky B7459

All of these tests are done with Aerosoft A330.

Share this post


Link to post

I'm not sure if it's the same issue but in the past couple days I had severe stuttering with vsync  on frames unlimited at 30hz.  My frames would bounce between 10 and 60.  After hours of troubleshooting I found I had turned off game mode in windows 10.   I turned it back on and it smooth at 30 with no fluctuations.

Like I said this may not be the same issue but just something to check.


Sean Green

Share this post


Link to post
Posted (edited)
On 6/15/2020 at 12:15 AM, 21grams said:

There are similar contents on Aerosoft forum as well as ActiveSky Forum.

stuttering-strong-fps-fluctuations-after-3-4-hours-in-flight

fps-being-taxed-every-ca-30-secs-from-high-80-to-low-20-and-then-up-again

Both threads pointed the problem to ActiveSkyP3D, which is still in beta.

Me personally also had this problem serveral days ago, what I did is to re-install ASP3D

Have done a 1-hour flight, and all seems ok, no performance loss, normally I will get constant shutters and thus fps drop to 20-ish fps after 40 minutes or so.

My spec: R7 3700X\RTX2070, Windows10 Home 2004 , P3Dv5 HF1,ActiveSky B7459

All of these tests are done with Aerosoft A330.

Good info.  I might try not running Activesky and see if that fixes it.  Obviously I don't want to do without Activesky but at least that will isolate the problem.

Edited by MarkW

Mark W   CYYZ      

My Simhttps://goo.gl/photos/oic45LSoaHKEgU8E9

My Concorde Tutorial Videos available here:  https://www.youtube.com/user/UPS1000
 

 

Share this post


Link to post

Just done a 3 hour flight with the A330. After re-installing ASP3D, framerates are still good after hours of flight, but I get constant shutters, and my chrome, navigraph and vatspy (almost anything that requires hardware acceleration)are still very laggy when P3D was running.

Share this post


Link to post
Posted (edited)

FWIW, I also have experienced this and have found that by essentially forcing weather to reload clears it. I do it by turning EA off and back on again, but I suspect it isn't EA related, but rather ASP3D related based on the other posts here, so possibly restarting ASP3D would do it also, but for me the disable/re-enable EA is quick and easy because there's no loading screen associated with turning it off and on again.  I typically need to do this once per flight, usually as part of my 'approach checklist'. Using this method I've flown as many as six or seven segments in a 10-12 hour period without restarting the sim. Purely anecdotal.

Edited by cwburnett
  • Upvote 1

i5 9600K @ 5Ghz | MSI RTX 2070 | 32GB DDR4 3200 MHz | 2 x M.2 Gen 3x4 1TB SSDs + 1 x SATA 1TB SSD
Honeycomb Alpha Yoke | Saitek Throttle Quadrant | Saitek Rudder Pedals | Thrustmaster Warthog HOTAS

P3Dv5 HF2 | ASP3D | PSXseeconTraffic | AIG-OCI | Lorby AOM | Navigraph Charts | RXP GTN750 | FS2Crew UGCX
Leonardo Maddog X | Majestic Dash 8 | Aerosoft A318-A321+A330 (Beta Tester) | TFDi 717 (Beta Tester) | FSW Lear 35A+Falcon 50+MU-2B | Aerosoft DC-8 | Coolsky DC-9

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    22%
    $5,540.00 of $25,000.00 Donate Now
×
×
  • Create New...