Jump to content

Sign in to follow this  
micstatic

HF2 CTD issues (perfect in HF1)

Recommended Posts

29 minutes ago, Karelpatch said:

So, I just tested installing Envtex and everything was working perfectly. I decided to try adding Envshade. I also installed Traffic Global at the same time. When starting any scenario I would get a device hung error.
I thought this was related to VRAM, even though I have 16gb and my GPU monitor showed almost no usage. I tried lowering and lowering settings, with no effect. Then I uninstalled Envshade and Envtex because I thought this error was caused by Envshade. But same error. Tried uninstalling and reinstalling the client. Same issue.

Then I uninstalled Traffic Global but the problem was still there. In the end I found out it was still present in the Addons, so I unchecked it. And voila, P3D scenario started. 
I then pushed all settings back to high and everything working fine. Still have to try reinstalling Envtex and Envshade to see how it goes. 

interesting.  I have those two but will hold off installing


9700k | Maximus XI Hero| 32gb DDR4 3000 | 1080Ti 11GB | 1tb EVO Plus 970 and 500GB M2+3TB HDD | 43" Samsung X60R 4k and 2  22" monitors | Corsair RM1000x |  240MM AIO.| MFG Crosswind | T16000M Stick | Saitek Throttle Quad | Skalarki MCDU and FCU | Saitek Radio Panel

Share this post


Link to post
29 minutes ago, Karelpatch said:

So, I just tested installing Envtex and everything was working perfectly. I decided to try adding Envshade. I also installed Traffic Global at the same time. When starting any scenario I would get a device hung error.
I thought this was related to VRAM, even though I have 16gb and my GPU monitor showed almost no usage. I tried lowering and lowering settings, with no effect. Then I uninstalled Envshade and Envtex because I thought this error was caused by Envshade. But same error. Tried uninstalling and reinstalling the client. Same issue.

Then I uninstalled Traffic Global but the problem was still there. In the end I found out it was still present in the Addons, so I unchecked it. And voila, P3D scenario started. 
I then pushed all settings back to high and everything working fine. Still have to try reinstalling Envtex and Envshade to see how it goes. 

Very odd, why TG would do that to P3D? I don't get it..

S.

Share this post


Link to post
10 minutes ago, Dreamflight767 said:

So P3D is a success now!?

Yes, very much so for me. I can't get enough of EA, haven't seen a single ctd flying in HF1 and now in HF2 so far.

  • Like 1
  • Upvote 1

Share this post


Link to post
2 hours ago, simbol said:

Very odd, why TG would do that to P3D? I don't get it..

S.

I have no idea but I am 99% certain disabling it fixed the issues. 
Before the hotfix I also had an odd issue where Envtex was making P3D crash (DGXUI error) on the scenario screen. Even after uninstalling Envtex, I had to untick the plugin box to get P3D to load.

Must be related to my AMD Radeon VII GPU, but it looks like bugs. 

 

Share this post


Link to post

Traffic global has always made my sim crash.

Not something I would choose to install in P3D v5 HF2, though it sounds like it is better now than in the past when I last tried it.

On a broader note, this thread hammers home the point that the most likely cause of CTDs is addons. If you’ve got a problem with stability, you really do need to disable everything as your first step, then take things from there.

Anything that changes the sim’s files should be near the top of your list of possible culprits.

  • Upvote 1

Rob

Sim rig: Intel Core i9 9900K @ 5GHz, Asus ROG Maximus XI Code, MSI 2080 Ti, GSkill DDR4 32 GB, NZXT Kraken. 

Current sims: P3D v5, MSFS, X-plane 11, Aerofly FS2 and DCS. 

 xdQCeNi.jpg   puHyX98.jpg

"There are three simple rules for making a smooth landing. Unfortunately, no one knows what they are."

Share this post


Link to post
1 hour ago, OzWhitey said:

Traffic global has always made my sim crash.

Not something I would choose to install in P3D v5 HF2, though it sounds like it is better now than in the past when I last tried it.

On a broader note, this thread hammers home the point that the most likely cause of CTDs is addons. If you’ve got a problem with stability, you really do need to disable everything as your first step, then take things from there.

Anything that changes the sim’s files should be near the top of your list of possible culprits.

With this in mind...before I install HF2, should I move my add-ons.cfg to some temporary location, then uninstall P3Dv5HF1, install P3Dv5HF2, verify good running, and only then put my add-ons.cfg back?

Would that guarantee that on first run, my P3Dv5HF2 would be totally vanilla?  (that is my goal)


Rhett

i7-8700k @ 5.0 ghz, 32 GB G.Skill TridentZ, 1080Ti, 32" BenQ, 4K res

Share this post


Link to post
10 hours ago, Mace said:

With this in mind...before I install HF2, should I move my add-ons.cfg to some temporary location, then uninstall P3Dv5HF1, install P3Dv5HF2, verify good running, and only then put my add-ons.cfg back?

Would that guarantee that on first run, my P3Dv5HF2 would be totally vanilla?  (that is my goal)

This may be unnecessary but it can't do anything bad. Always better to start vanilla, see if it works, before adding stuff. Especially in V5.

Share this post


Link to post

So i want to say the asinine ctd's I was experiencing have been significantly reduced/eliminated. 

The only changes I made :

Safe mode DDU driver clean and then installation of latest Nvidia 451.48 drivers.

Update F1 GTN for H2 compatibility.

Checked 12v rail with HWMonitor and voltages stable at idle and max load in P3D. 

I will still ctd with an "unknown" module error if I load a scenario and then try to load at any other airport three times or more, however I only tested this with Orbx airports. It will load to 100%, then ctd with device hung, or no error at all. I will just stop doing that and move on. Crashes occurring when changing simobject slider settings seems to have stopped. Crossing fingers. 

Performance has been good locked at 30 with even slightly higher settings that I had before. Maybe new driver with hardware accel GPU scheduling? Maybe she's in a good mood today, maybe tomorrow she will have a fit? Who knows...

 

  • Like 1

MUUV7Ax.png?1

 

Share this post


Link to post
Posted (edited)

Personally I found that using RTSS (to limit the frame rate to 30Hz) caused a CTD 100% of the time. Took me a good while to figure that out as it’s not an issue in V4.5. 

Now I need to find a new way to limit my frame rate, ideally without changing the monitor refresh rate as i can’t live with the annoying mouse lag in other applications. Curious if there are any other tools I could use? NCP didn’t seem to work btw. 

Edited by alepro21
.
  • Like 1

Formally screen name was Alex_YSSY until the forum software ate my account  ^_^

Share this post


Link to post
13 hours ago, alepro21 said:

Personally I found that using RTSS (to limit the frame rate to 30Hz) caused a CTD 100% of the time. Took me a good while to figure that out as it’s not an issue in V4.5. 
 

I will pass this information to LM.

Thanks

S.

  • Like 1
  • Upvote 1

Share this post


Link to post

I got these on approach (downwind) into ATL in the CS 767 last night.  

https://imgur.com/a/mXZ3sKV


9700k | Maximus XI Hero| 32gb DDR4 3000 | 1080Ti 11GB | 1tb EVO Plus 970 and 500GB M2+3TB HDD | 43" Samsung X60R 4k and 2  22" monitors | Corsair RM1000x |  240MM AIO.| MFG Crosswind | T16000M Stick | Saitek Throttle Quad | Skalarki MCDU and FCU | Saitek Radio Panel

Share this post


Link to post
13 minutes ago, micstatic said:

I got these on approach (downwind) into ATL in the CS 767 last night.  

https://imgur.com/a/mXZ3sKV

q2d.dll is related to Scenery and Terrain..

Suggestions:

* If you haven't installed the HF2 scenery do so.
* Delete the Senery.cfg and let it rebuild.

If you use ORBX, open ORBX central. Update everything / use the "verify files".

S.

Share this post


Link to post
Posted (edited)

Thanks will try. I have the hf2 scenery. But will do the others 

1.  Did a DDU in safe mode and removed/reinstalled 451.48

1a. Delete prepar3d.cfg and delete shader folder

2. Deleted scenery.cfg and let it rebuild. 

3. Verified Orbx files. 

We will see how it plays out.  Hopefully a one time CTD> 

Edited by micstatic

9700k | Maximus XI Hero| 32gb DDR4 3000 | 1080Ti 11GB | 1tb EVO Plus 970 and 500GB M2+3TB HDD | 43" Samsung X60R 4k and 2  22" monitors | Corsair RM1000x |  240MM AIO.| MFG Crosswind | T16000M Stick | Saitek Throttle Quad | Skalarki MCDU and FCU | Saitek Radio Panel

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,170.00 of $25,000.00 Donate Now
×
×
  • Create New...