Jump to content

Sign in to follow this  
georgiosgiannoukos

P3D4.5 HF3 Problem

Recommended Posts

I updated EZDok v3.0 for compatibility with the latest ASP3D beta.

Nothing else. Start the sim and .......... happened 

My shader folder is in place .

Yesterday while updated Nvidia new drivers, as always do, I use to delete shaders and p3d config so I get new generated folders. Everything was as normal.

BUT today with no reason it happened

Share this post


Link to post
11 minutes ago, G-YMML1 said:

What sort of update you did?

My nvidia driver 

Share this post


Link to post

The directory ShaderHLSL supposed to be in P3D root directory. Someone send me his directory and i paste it in my P3D root directory.

The sim started normally but without preview of the vehicles. I closed the sim and restarted and i get the same warning. The recently directory i placed in P3D root is disappeared

What the F... is going on here?.

 

Share this post


Link to post
Posted (edited)

Yes ShaderHLSL should be located in the root of the P3D install directory.

The are the source shader files the sim compiles for shader cache use.

Normally such folders are not removed (although hasn't a few Windows bugs resulted in folder/files being removed?)

I've seen a lot of so called missing folders accidently dragged into other folders nearby, hence missing but can be found with a search.

The recycle bin is another first point of call.

Could also be something really weird like it has become a hidden folder, or lost ACL permissions, or a disk corruption issue is developing, or AV has picked it up and deleted/quarrentined, or some unknown bug in an update has taken a fancy to the folder and its tasty files inside and swallowed the lot 🙂

Otherwise a repair of the P3D client should bring them back.

Would be interesting to hear the outcome.

Cheers

Edited by Rogen

Ryzen 2700X clocked to 4.2 Ghz, 32 GB ram, Samsung 1 x 1 TB NVMe 970 and 2 x 1 TB SSD 850 Pro raided, Nvida 1070 Ti clocked to 2 Ghz

P3D 4.5.13, Orbx Global, Vector and more, lotsa planes too.

Catch my vids on Oz Sim Pilot, catch my screen pics @ Screenshots and Artwork

Share this post


Link to post

someone else reported that updating client does not help.

I paste the shadersHLSL directory i get from someone but while the sim is normally loaded the vehicles are missing. also loading the default flight and plane only the engines sound and black screen. 

Share this post


Link to post

Here is what happening and this is very very weird.

1. Uninstalled old client.

2. Installed new client and Shaders HSHL Folder within P3D Directory was recovered.

3. Run P3D.exe and I got black menu for plane's selection menu.

4. Try to load any scenario and get black screen

5. Exit P3D and Shaders HSHL Folder disappeared again

 

Total freaking mystery!

Share this post


Link to post

....Update

 

1. Repair the Client and Shaders HSHL folder was recovered (as expected)

2. HOWEVER. once I run P3D exe, the Shaders folder disappears from P3D root directory literally as I write!  

 

Share this post


Link to post

Quick question for those who experience that issue. Do you have both ORBX/Parallel 42 Immersion Manager and  AI Lights Reborn Professional Installed?

Share this post


Link to post

Experience exactly the same issue as you, ORBX/parallel 42 immersion Manager was updated this morning, yes I have but not Al lights.

i paste a friends ShadersHLSL directory to my P3d root folder AND no vehicle images in p3d also black screen while a flight was loaded.

Exiting the P3d ShadersHLSL gone

Share this post


Link to post

Having the same issue here, Updated nvidia yesterday but when i ran P3D after nvidia didnt really notice any issues nor did installing ASP3D Beta 6.

I followed a guide on removing all P3D V4 folders and now its taking forever to start P3d to check if it has fixed. http://www.prepar3d.com/forum/viewtopic.php?t=120763

Only thing i noticed today was an update to Immersion manager. Not sure if this affected things by any chance but this issue started just after this update completed an i ran P3D


Aaqib Afzal

 

Boeing777_Banner_Pilot.jpg

 

pilotbanner.jpg

Share this post


Link to post
Posted (edited)

Ok. here is the conclusion.

Looks like Parallel 42 rolled out silent update for their Immersion Manager yesterday. When you start P3D, the IM starts simultaneously and wipes out the entire Shaders HSHL folder within P3D Root Folder. I disabled the IM from the list of active Add-ones, repaired the Client, ran P3D....and thing were back to normal. The Shaders folder is intact now

We have to ask Simbio to contact the guys ASAP.

Edited by G-YMML1

Share this post


Link to post
5 minutes ago, georgiosgiannoukos said:

 

i paste a friends ShadersHLSL directory to my P3d root folder AND no vehicle images in p3d also black screen while a flight was loaded.

 

Never copy and paste Shaders manually. It's Bad, very bad idea. The client should recreate them automatically.  

Share this post


Link to post
14 minutes ago, G-YMML1 said:

You'd need to open a ticket with //42 - ALL of you! - that forum is user-to-user support, as noted in the title of the forum.


Cheers, Søren Dissing

CPU: Intel i7-7700K @4.8 Ghz | Noctua NH-D15 | GeForce GTX1080 8Gb | MoBo: ASUS Maximus IX Hero | RAM: 32Gb DDR4 2666 | SSDs: 500Gb Samsung M.2 EVO960 (Win drive), 240 Gb Kingston HyperX 3K (P3D drive) | Monitor: 28" ASUS PB287Q 4K | Win 10 Pro 64-Bit | Prepar3d v5.0 Professional | FTX Global, OpenLC EU, NA | ASP3D (Beta) & ASCA | Chaseplane

 

 

Share this post


Link to post

Hello, As soon as I uninstalled Immersion Manager from Orbx Central and paste the directory ShadersHLSL to my P3D root folder EVERYTHING IS Perfect.

The Immersion Manager had an update if I’m not wrong this morning, that’s when all problems started.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,035.00 of $25,000.00 Donate Now
×
×
  • Create New...