Jump to content
Sign in to follow this  

Synthetic Vision - P3D V4

Recommended Posts


I'm really confused about the Carenado SVS system and I’ve read in loads of places that its tricky to get working. We here’s what I’ve tried so if anyone could suggest something else that would be great, if not I’m not sure what my chances are for a refund from Just Flight.

My test aircraft is the Cirrus SR22 v2.1 in P3D V.4 which I believe is SVS compatible. I know to push to softkey to get it working


1. Installed the SVS.exe straight away – failed to show in PFD

2. Uninstalled SVS and SR22 - failed

3. Installed SVS then SR22

4. Tried SVS.exe in SR22 directory and that just reinstalled SVS - failed

5. Opened TCP port 4444 in windows defender even though 4 SVS entries exist – failed

6. Used the alternative WebSimSVS.dll from Carenado

7. Used MakeRwys.exe and imported r5.bin

8. Checked WebServer is in NVI to ensure it has priorities

9. Checked the panel.cfg and XML files to make sure SVS entries are there – not changed anything.


The Carenado SVS icon appears in the system tray but all I get in the display of the SR22 is “TERR ERR” which I get if the SVS is on or not. Not sure how to clear this problem.

I also don’t believe I have and GPU problem as I have 1070GTX with latest Nvidia drivers loaded.

I’ve tried my TBM850 too and this doesn’t work either.

I have read AVSIM for solutions and tried what I’ve found on there. Some people just seem to get it to work and others are still struggling. The instructions that come with the product seem to be out of date and have limited relevance to the install.

Not turned to Carenado yet as I believe these forums have more knowledge than them

Ollie G

System: 8700K O/C@ 5.0Ghz, Asus ROG Strix Z370F MoBo, H100i v2, Gigabyte 1070 XTreme Gaming Edition, 500Gb NuMe (OS), 500 Gb (XP) & 1Tb Samsung 850 SSD (P3D), 4Tb WD HDD as library, Rift S & Touch, Honeycomb Yoke, Saitek throttles and TM TPR rudder pedals

Flight Sims: Xplane & P3D v4.5 HF2 - Orbx Global, Vector, Europe LC & Others, REX TD & SC Enhanced, AS, ASCA, Chaseplane, UK2000 Scenery, FSFX stuff and lots, lots more!

Share this post

Link to post
Share on other sites

I have the same problem, in P3d v5 using the Phenom 300.  

Carl Thompson

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Create New...