Jump to content

Sign in to follow this  
Rob_Ainscough

50% FPS drop with P3D V5 HF2 and undocking window

Recommended Posts

I've posted this issue on LM's Beta forum also, but thought I'd try here also in case you folks have a solution:

I updated the GNS V2:

uc?id=1G0MXyQOU993I_LVbVGcwTZQlsSEnZ6eC

Here is a video showing the issue when the window undocks and the FPS drops to 15.

With P3D V4.5 I solved this problem by setting the prepar3d.exe compatibility property to check "Disable fullscreen optimizations":

uc?id=1PP2ekWP53es2VIhnsPIEBG56IwCM1wHQ

FPS returned to normal with undocked window.  HOWEVER, this sadly does NOT work for P3D V5 HF2.

Thoughts?

Cheers, Rob.

Share this post


Link to post
Share on other sites

I have a similar problem. Iam using Nvidia control panel to limit p3d to 30 hz. (Max frame rate) Any window in p3d that I undock the frame rate goes to 15hz.

 

 

Richard


Richard Seim

Share this post


Link to post
Share on other sites
Posted (edited)

I was able to pin point the problem, it appears to be Vsync related. If I turn OFF Vsync and set TFR to 30 my FPS stays at 30 when I undock a window.  As soon as I enable Vsync it goes back to 15 FPS.

So it looks like some issue with Vsync and undocked windows (I have reported to LM).

Here is video of my "work around"

Obviously this is NOT a desirable situation, but I can work around it for now and use my RealSimGear with RXP 530/750.

14 minutes ago, Richardseim said:

Any window in p3d that I undock the frame rate goes to 15hz.

Glad you chimed in ... I was thinking I was alone with this problem.  Disable Vsync and set TFR = 30.

Cheers, Rob.

Edited by Rob_Ainscough

Share this post


Link to post
Share on other sites

It works with vsync off and tfr =30 AND No frame limit in Nvidia control panel. But my Cpu 0 goes to 100%.

if I set the max frame rate = 30 in Nvidia control panel and even with p3d vsync off I still get 15hz when the first window is undocked, strange!

 

Richard


Richard Seim

Share this post


Link to post
Share on other sites

As far as I know it's a "bug" ... but will wait to see what LM think about it. 

Vsync = Off and TFR=30 is just a work around ... if that causes your CPU to cap out at 100% then you have two options:

1.  Reduce graphic settings

2.  Lower FIBER_FRAME_TIME_FRACTION=0.33 to something lower like 0.10 ... BUT be warned that doing so could make Terrain blurry and Autogen fall behind in rendering.

Cheers, Rob.

Share this post


Link to post
Share on other sites

Do you have GSX installed? If so try going to the FSDT Addon Manager and click "disable RTT" - Render to Texture. This fixed a very similar  problem I had where FPS tanked upon undocking a window. 


Ian S

38.jpg

Share this post


Link to post
Share on other sites
34 minutes ago, Ian S said:

Do you have GSX installed? If so try going to the FSDT Addon Manager and click "disable RTT" - Render to Texture. This fixed a very similar  problem I had where FPS tanked upon undocking a window. 

Not an issue in P3D V5, since there's no RTT code there, and the disable RTT option is always considered disabled, regardless of the setting.

Share this post


Link to post
Share on other sites
47 minutes ago, virtuali said:

Not an issue in P3D V5, since there's no RTT code there, and the disable RTT option is always considered disabled, regardless of the setting.

Fair enough, just a thought...cheers Virtuali


Ian S

38.jpg

Share this post


Link to post
Share on other sites
7 hours ago, Ian S said:

Do you have GSX installed? If so try going to the FSDT Addon Manager and click "disable RTT" - Render to Texture. This fixed a very similar  problem I had where FPS tanked upon undocking a window. 

I currently don’t have GSX installed (but plan to this week) ... this is a P3D V5 HF2 bug that was present in V4.5 also ... only difference was in V4.5 I could resolve by disabling full screen optimization.

Cheers, Rob.

Share this post


Link to post
Share on other sites

Don`t have this problem FPS set to 30 in the sim settings using FFTF in 4K, but don`t use Vsync.


i9 10900K\ASUS APEX MB \ MSI RTX 2080Ti GAMINGX TRIO \ M.2  Samsung 970 EVO Plus 1TB C Drive \ 2+1TB Samsung 850 EVO \ 2TB BarraCuba \ 32GB G.SKILL Z DDR4 3600MHZ \ Windows 10 Home\ ASUS 28" 4K monitor\ 4TB Portable Drive\P3DV5

Raymond Fry.

PMDG_Banner_747_Enthusiast.jpg

Share this post


Link to post
Share on other sites

This looks like a bug in P3D5 indeed, not related to the way the GNS or the GTN are rendering.

You're safe with VSync OFF because as long as the simulator is rendering less than your monitor refresh rate, you shouldn't have any tearing at all right in the middle of a frame.

Have you tried other NVidia options, such as "Low Latency Mode: On" or "Vertical Sync: Fast" ?


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

NVidia options, such as "Low Latency Mode: On" or "Vertical Sync: Fast"  had no effect on my system. 

Lets hope LM can fix the problem with vsync in the next update.

Iam using low enough settings so that is probably not the issue. When using vsync and having an undocked window my cpu and gpu load goes down,fps = 15.

if I start by having my monitor at 60hz it goes down to 30 fps.
 

 


Richard Seim

Share this post


Link to post
Share on other sites

Welcome to the party Rob lol I have been struggling with this issue for a long time when un-docking the CDU on the PMDG. It was because I had to change settings in nvidia control panel because I was running 1080ti in SLI. I now notice this same issue with version 5. LM has told me for a few years now that it was my problem only and they couldn't help me.


I7-8086K Delid OC Synced all cores 5.2  Corsair Hydro Series, H115i PRO ASUS ROG Maximus X Hero (Wi-Fi AC)  EVGA GeForce GTX 1080 Ti FTW3 SLI CORSAIR HXi Series HX1200i 1200W G.SKILL TridentZ Series 64GB DDR4 3200 Windows 10 Pro 64

PMDG 737NGX

Share this post


Link to post
Share on other sites

I just resolved a similar issue in p3dv5 after running on hotfix #2 for a few weeks no with problems with undocking an overhead and two mcdu's (pmdg 737ngxu/ aerosoft  A330) losing only a couple of fps. Then two days ago a sudden loss of 10-15 fps on each panel undocked ! So I tried these and lots of other forum suggestions, including reinstall client, changing many p3d and nvidia CP setting including vsync etc, and all failed to remedy the huge drop in fps..... except after doing the following (even when i had already updated to latest nvidia driver via windows update!). So try this;

1. Download the program DDU and boot into safemode, then run it. (used v18.0.2.8)

2. Run latest version of NVcleanstall.exe (used 1.7.0) to...

3. Re-Install latest Nvidia driver (currently 452.06-desktop-win10-64bit-international-dch-whql.exe)

 

Hope this helps anyone else with a similar problem.

 

Regards,

Shane Burrows

Win10 ver 2004

i7-4790k/16GB/Geforce GTX 1070

  • Like 1

Share this post


Link to post
Share on other sites

Thank you for sharing. I'm hoping LM will find a way to code their windows so that no 'fix' is necessary.

  • Upvote 1

Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,100.00 of $25,000.00 Donate Now
×
×
  • Create New...