Jump to content

Sign in to follow this  
gpaviation

Problem getting Reality XP G530 to run on XPlane 11

Recommended Posts

I have purchased a RealSimGear G530 and also Reality XP software for my XPlane 11. I have paid for and downloaded the Reality XP software and also the Garmin GNS Trainer Lite. All the files appear to have been downloaded OK. But when I go to Plugins on XPlane the G530 is not showing. 

Any advice would be appreciated. The Reality XP User guide is useless.

Share this post


Link to post
Share on other sites

Does the standalone GNS trainer work for you?  I mean can you open the exe and use it?

Do you run an anti virus software that quarantined the RXP files during install?


|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post
Share on other sites

Yes, the RealSimGear 530 works fine with the basic XPlane software in the XPlane BE58. Could be the Windows security blocking something. If so how do I check this?

Share this post


Link to post
Share on other sites
14 hours ago, gpaviation said:

But when I go to Plugins on XPlane the G530 is not showing. 

Any advice would be appreciated. The Reality XP User guide is useless.

Hi,

The Reality XP User Guide might not help you, nonetheless, it is not useless.

First, you might want to post your question to the official Reality XP Support Forum. It is not far away, it is hosted at avsim too!

Second, while posting your support request on our forum, you might want to describe and detail what do you mean with "is not showing" (i.e. what you were expecting to see, what is showing up instead).

Last but not least, please don't forget to post the content of the RXP log files (see User's Manual for file/path - at least it will be useful for this).


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

Thanks for your reply and comments, which, to be honest, I found somewhat condescending.  If I were an IT technical sophisticate I would not be seeking help on this or any other forum.

Share this post


Link to post
Share on other sites
Posted (edited)

I have checked all the Windows security settings as per the user guide. Still not working.

There are no RXP log files showing under My documents.

Edited by gpaviation

Share this post


Link to post
Share on other sites
On 7/21/2020 at 10:10 PM, gpaviation said:

Yes, the RealSimGear 530 works fine with the basic XPlane software in the XPlane BE58. Could be the Windows security blocking something. If so how do I check this?

Just to be clear, the actual Garmin GNS trainer is working for you outside of xp11?  I'm not very familiar with realsimgear.


|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post
Share on other sites

Thanks for your reply but I think I need someone from Reality XP to remotely access my computer to check all the installed files.

I will go to the Reality XP support forum to see if I can get someone from their firm to help.

Share this post


Link to post
Share on other sites

when you look in your X-Plane 11 folder, do you have a folder called "rxpGNS" in your "X-Plane 11\Resources\plugins\" folder (so it should look like this "C:\X-Plane 11\Resources\plugins\rxpGNS" ? If so, do you have 2 folders and a file, "32, 64, apt.cache", and each of those folders should have two files.

If not, RXP is not installed correctly.

Also, for each plane you want to use the RXP 530/430 in, you have to add a "RealityXP.GNS.ini" into the aircraft's main folder (which you can find some pre-made files in the RXP forums). Even without this "ini" file installed, if RXP is installed into the sim correctly, "RealityXP GNS" should still show up in your plugins menu.

OR, maybe RealityXP GNS is disabled in your "Show Plugin Admin" menu option.

Just a few items to look at. I have both GNS430 and 530 installed, and it took a lot of research to get them working with RealSimGear, but once I got it all worked out, it has been an amazing experience using them. I'll be glad to help you out as much as I can.6.jpg4.jpg

  • Like 1

Share this post


Link to post
Share on other sites

@monica6211 Hi,

Tthank you for further helping out! Please note:

13 hours ago, monica6211 said:

apt.cache

This is not a standard RXP file.

13 hours ago, monica6211 said:

you have to add a "RealityXP.GNS.ini" into the aircraft's main folder (which you can find some pre-made files in the RXP forums). Even without this "ini" file installed, if RXP is installed into the sim correctly, "RealityXP GNS" should still show up in your plugins menu.

It is created by default the first time you open a device in the aircraft too.

 

@ryanbatcund Hi Ryan, please note:

14 hours ago, ryanbatcund said:

the actual Garmin GNS trainer is working for you outside of xp11

It won't turn on standalone and this is expected. It only turns on with our plugin in-sim.

 

@gpaviation

On 7/22/2020 at 7:55 PM, gpaviation said:

Thanks for your reply and comments, which, to be honest, I found somewhat condescending.  If I were an IT technical sophisticate I would not be seeking help on this or any other forum.

You might have misinterpreted my writing as much as I might have misinterpreted "The Reality XP User guide is useless.".

Nevertheless, my answer above is nothing more than the 1st step in problem resolution.

Do you want us to further help you?

If so then, like I've written above: First, you might want to post your question to the official Reality XP Support Forum.

 

[note to moderators: can you move the entire discussion to the RXP > XPlane > GNS forum please?]

 


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
15 hours ago, RXP said:

@monica6211 Hi,

Tthank you for further helping out! Please note:

This is not a standard RXP file.

It is created by default the first time you open a device in the aircraft too.

 

 

Hmm, good to know. I wonder where it comes from. I opened it with wordpad and the first line references "sam". I do have SAM installed. Wonder if it interacts with RXP.

Share this post


Link to post
Share on other sites

@monica6211 Yes it is weird I've found one such file on our systems too. It is an XML file with a list of airports and other info about them of no use but for SAM. This makes me wondering why SAM is creating this file in the RXP plugin folder. I believe it is a bug of some sort with SAM with the latest(s) XP11 beta(s).


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
Posted (edited)

Hi all,

Thanks for your input but still no luck.

I have tried downloading the software several times without success.

I can fly an actual Lear Jet at over 0.8 Mach but I can't run a simple flight sim setup. I think I was borne into the wrong era!

 

Edited by gpaviation

Share this post


Link to post
Share on other sites
1 hour ago, gpaviation said:

Thanks for your input but still no luck.

Ok, but can you please cross-check the suggestions and answer so that it gives us clues about what could possibly be the problem on your system?

See below:

On 7/23/2020 at 9:17 PM, monica6211 said:

when you look in your X-Plane 11 folder, do you have a folder called "rxpGNS" in your "X-Plane 11\Resources\plugins\" folder (so it should look like this "C:\X-Plane 11\Resources\plugins\rxpGNS" ? If so, do you have 2 foldera "32, 64" and each of those folders should have two files.

If not, RXP is not installed correctly.


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
33 minutes ago, RXP said:

Ok, but can you please cross-check the suggestions and answer so that it gives us clues about what could possibly be the problem on your system?

See below:

Yep, done all that. I do have the rxpGNS in the Plugins folder and there are the two 32 & 64 folders which each have 2 files in them: PFCHidReports32.dll & win.xpl & PFCHidReports64.dll & win.xpl

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,170.00 of $25,000.00 Donate Now
×
×
  • Create New...