Jump to content

Sign in to follow this  
ryan78

Saitek Yoke - Driver Issue or Broken Yoke?

Recommended Posts

Hello Everyone. Before I get into it I just want to clarify that I have been fiddling with this yoke for the last 3 hours and nothing that I have read so far has worked. I'm posting here as a last ditch effort to try to get this to work. I am trying to determine if this is a driver issue or the actual yoke is broken. Yesterday I bought a Saitek Yoke +throttle and pedals off kijiji, nice guy, everything looked in working order etc. Pedals work fine but my yoke or throttle won't turn on when I plug it in. I've installed the newest drivers from saitek and when I get to the part to plug it in the next button is greyed out and I can't do anything.

So I went into the drivers. Everything I've read so far basically tells me to do this:

"Use <Device Manager> and right click on Saitek Pro Yoke if there under <Human Interface Devices>, or <Unknown Device> if not. Right click on it and left click on <Update Drivers>.
Next left click on "Browse my computer for ............... "
In the next window, left click on "Let me pick from a list ............ "
You will now have a choice of <Pro Flight Yoke> OR <USB Device>
Left click on <USB Device>
Correct! Do NOT click on <Pro Flight Yoke> - it's NOT a Yoke, it's a USB device!"

None of this seems to work for me. I've dug through device manager and the only thing related to Saitek is the HID device by going into properties/details and changing the drop-down to hardware IDs, I can see Saitek hotkeys but not yoke... 

https://imgur.com/xhkSBQa

So after following the above I get to this, there is no option to select a USB device. https://imgur.com/zO5JLiN

If I uncheck the box that says show compatible and go to system operations and click on the USB, I get this message. I install and it says the installation was unsuccessful and the driver is not working. https://imgur.com/lASVjnn

I have tried everything from installing it as a yoke, manually running the driver update. I had it as a saitek yoke USB and it had the little yellow shield, then tried running the saitek drivers and my button is still greyed out. I've tried every USB port on my pc and laptop, I even opened up the yoke to see if anything was loose or damaged inside and nothing. I hope this is an actual yoke issue because these drivers are driving me insane!

Any help will be greatly appreciated!

Ryan

 

 

 

Share this post


Link to post
Share on other sites

Hi Ryan78,

When you mentioned "but my yoke or throttle won't turn on when I plug it in", I suspected the yoke is not in working condition.

Since you have pursued all the driver installing and testing processes,

may I suggest the following trouble shooting methods (only if you have basic electronic skill and do this on your own risk):

If you still have the yoke bottom case opened, use a multimeter to test the +5v or 4. something voltage readings are existed in the roll and pitch axes potentiometers.

Placing the multimeter +v probe to 1st tab and -ve probe to 3rd tab of each potentiometer. Ignore the middle tab which is the signal output.

It does not hurt which side is the 1st tab, your reading result is either +5v or -5v on your multimeter.

Just be cautious not shorting any parts in the controller circuit.

If you do not see the +5v showing up, then the yoke is not power up correctly.

If you do see the +5v, then the problem might be the controller failed to communicate to the PC via USB port .

One more test is the USB cable. Make sure the USB cable is not broken. You can google how to test the USB cable.

This will create the no power or lack of communication issues if the USB cable is broken.

If the USB cable is OK, then the controller broad inside the yoke might be defective.

Hope the above methods work for you.

 

 

Share this post


Link to post
Share on other sites

Hi, thanks for the reply! I managed to borrow a neighbors multimeter and I am in fact getting zero power to the yoke. At least I'm not pulling my hair out trying to figure out the driver issues. Kijiji guy hasn't returned my texts or calls so he probably knew it was broken... Shame, I've ordered one off Amazon and I'm just gonna swap the new one out for the old one and return it as defective. 😛 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    39%
    $9,970.00 of $25,000.00 Donate Now
×
×
  • Create New...