Jump to content

Sign in to follow this  
thedon

No Controllers recognised

Recommended Posts

6 minutes ago, JIMBOJET90 said:

Also having issues with a Thrustmaster T-flight Hotas X Throttle

In game, my Thrustmaster isn't recognized either, so I had to assign buttons manually. The problem is that Joystick Z-axis functions the same for the joystick as well as for the throttle. In other words, MSFS doesn't recognize the throttle as a slider, as it supposed to. So now I had to assign both Rudders and increase/decrease Throttle to my desktop throttle...

Appart from this, the two buttons on the back of Thrustmaster Throttle (the ones meant for the Rudders in FSX) aren't even recognized by MSFS.

Good to know thats my thrustmaster idea out the window. I'm also looking at the logitech 3d pro. Apparently it's supported. Having said that so is thrustmaster. At least the logitech is a cheap option and easy to sell on. Worth a try. 

Share this post


Link to post
Share on other sites
43 minutes ago, JIMBOJET90 said:

Also having issues with a Thrustmaster T-flight Hotas X Throttle

In game, my Thrustmaster isn't recognized either, so I had to assign buttons manually. The problem is that Joystick Z-axis functions the same for the joystick as well as for the throttle. In other words, MSFS doesn't recognize the throttle as a slider, as it supposed to. So now I had to assign both Rudders and increase/decrease Throttle to my desktop throttle...

Appart from this, the two buttons on the back of Thrustmaster Throttle (the ones meant for the Rudders in FSX) aren't even recognized by MSFS.

Problem solved!! :-) Thrustmaster was still set on PS3 instead of PC (switch at the backside of the stick)

Share this post


Link to post
Share on other sites
3 hours ago, JIMBOJET90 said:

Problem solved!! 🙂 Thrustmaster was still set on PS3 instead of PC (switch at the backside of the stick)

Great news. Hope everything hunky dory now. 

Share this post


Link to post
Share on other sites

This section was useful...but really, I know it is a sim and I am simming since 2006 in FS9, FSX, P3D...  but it took some time to be able to configure the joystick and pedals, I did it easier in the DCS then in the FS 2020 😄


Valentin Rusu

i9-7900X @4.5GHz (core 0 @4.8GHz), EVGA GTX 1080 TI FTW3, DDR4 32GB @3200MHz, Samsung 840 PRO Raid for Win 10 Pro, Samsung 960 PR0 512GB NVMe SSD for P3D v4.5

Share this post


Link to post
Share on other sites

Gladiator vkb mk2  problem solved. 

I have just updated my firmware and unplugged my gamepad controller. I think it was mapped also on same axis. At last, 2 days fiddling. 

Cessna 172 innsbruck to Zurich was awsome

😁

Share this post


Link to post
Share on other sites

Seems like there is a resolution for controllers (manually setting them up) but what about panels? I have saitek multi panel / radio panel / switch panel no life from any of them by default.

I installed spad.next trial which seems to get them working but would prefer a free solution.

Share this post


Link to post
Share on other sites

All my Peripherals are working fine - except for the most important one - my keyboard (ROG Claymore) - as you can see it works here but not in FS2020 - any clues please

Share this post


Link to post
Share on other sites
Posted (edited)

My X52 Pro (listed as officially supported my MFS2020) is not detected at all in the sim. The OS sees it, and so do other simulators like IL-2 CLOD Blitz or DCS World, so there must be something else specific to MFS2020 that I haven't found how to solve yet.

I have tried unplugging/replugging the USB cable multiple times, while in game (tried different menus) or before running the game, selecting a profile from the system tray icon or not, rebooting, no dice so far. Occasionally, when plugging the HOTAS while in the controller options in the sim, MFS2020 will crash. This does not seem to occur while in other menus, although it'd need to be tested more rigorously. In any case, this suggests that something is indeed happening when I plug it and MFS2020 somehow is impacted, but still no HOTAS showing before the crash.

An Xbox pad is correctly recognized and immediately listed when plugged in. I have tried disconnecting it too before my attempts with the X52 Pro, but no effect.

The sim is installed from the (atrocious) MS Xbox client, which also came with its own issues for downloading and installing MFS2020 (but at least, now that part is done!).

If anyone encounters the same issue or has any idea, please let me know.

Edited by Kabouik

Share this post


Link to post
Share on other sites

I found what was my problem with the X52 Pro not showing up at all in FS 2020 (despite working in other sims and showing up in W10's Devices and printers). I noticed that right clicking on the X52 icon in Devices and printers and then trying to open "Game controller settings" wouldn't do anything. Same when trying to execute joy.cpl directly.

Turns out my joy.cpl was corrupted, I'm assuming because of a driver but can't confirm. Therefore, I moved it to a backup folder (in case this wouldn't be the problem) from C:\Windows\System32, and then copied the original C:\Windows\SysWOW64\joy.cpl and pasted it in C:\Windows\System32 to start fresh. Rebooted, connected the X52 Pro, right clicked and opened the game controller settings successfully.

At this point, the first time I launched FS 2020, my HOTAS was detected. Hope this helps others. I think I was the only one not to have my X52 Pro detected at all, but never know.

Share this post


Link to post
Share on other sites

Anyone know what this message solution is?  Message:  You are trying to assign an action to a device that is not selected I can't assign roll axis on Saitek/Logitech yoke.   It shows, but it doesn't work.  I managed to get the pitch working on the BU controller.   I have to use the poor mans autopilot and steed with the rudder.  Not elegant!


Share this post


Link to post
Share on other sites
Posted (edited)
12 hours ago, Kabouik said:

I found what was my problem with the X52 Pro not showing up at all in FS 2020 (despite working in other sims and showing up in W10's Devices and printers). I noticed that right clicking on the X52 icon in Devices and printers and then trying to open "Game controller settings" wouldn't do anything. Same when trying to execute joy.cpl directly.

Turns out my joy.cpl was corrupted, I'm assuming because of a driver but can't confirm. Therefore, I moved it to a backup folder (in case this wouldn't be the problem) from C:\Windows\System32, and then copied the original C:\Windows\SysWOW64\joy.cpl and pasted it in C:\Windows\System32 to start fresh. Rebooted, connected the X52 Pro, right clicked and opened the game controller settings successfully.

At this point, the first time I launched FS 2020, my HOTAS was detected. Hope this helps others. I think I was the only one not to have my X52 Pro detected at all, but never know.

The problem appeared again, and just replacing joy.cpl was not enough. What worked is:

 

1. Devices and Printers

2. Right click on X52 Pro

3. Properties, Hardware tab, click the Properties button while the HID line is selected

4. Change settings

5. Driver, Update driver

6. Browse my computer, Let me pick from a list, and pick the only X52 HID occurrence

7. And replaced joy.cpl as described above, not sure if that was mandatory or not

 

This was after installing X52_Professional_HOTAS_x64_8_0_213_0.exe but I guess this is not necessarily a good idea, as now my hardware driver in the properties tab has "Driver date: 2017-04-20" and "Driver version: 8.0.121.0", so maybe the later updates (X52_Professional_HOTAS_x64_8_0_213_0.exe was released in September 2018) break things. We'll see how long it holds.

I wonder if there is a way to freeze things in that state and prevent updates.

 

 

 

Edited by Kabouik

Share this post


Link to post
Share on other sites

Sorry, newbee and I have not figure how to edit my own post.   Also, can't figure how to add pic from hard drive. Anyway, I had done Modification to Logitech/Saitek yoke with BU0836 controller to eliminate dead zone.

When I started sim I had no roll or pitch from Saitek.   I believed only pitch was going through the BU0836 so I assigned it there.   Pitch worked but no Roll. I went to Saitek and tried to verify roll axis assignment

by moving control and receive  the message You are trying to assign an action to a device that is not selected.  

   After a bit of head scratching I figured it was trying to tell me I had the wrong device.  I removed roll from the Saitek and assigned it to the BU0836.  Too long since I wired it and forgot both axis were wired through it.

Now all is well.  Hope this helps for those with the modification.

Share this post


Link to post
Share on other sites
On 8/19/2020 at 12:57 AM, fhcraig said:

There are several different issues running around in this thread. Some - namely controllers not getting recognized at all by the sim are harder to solve. I can say we didn't see a lot of those in testing so I wonder if it's related to a Steam install?

One has already been addressed. For all "linear" inputs you have to use the MSFS Axis commands, not the "simple" commands. This applies to all control surfaces, trims, engine controls, etc. If you turn the Control filter to "All" and do a search for Axis you'll see these commands. If you try to just use the "binary" commands, your control inputs will be all on or off.

If your controller is "recognized" by the sim but there are not control assignments, or if you don't like the default assignments, then you need to go into the Control bindings and assign them. I had to do this for my CH Flight Sim Yoke. Once you do it once it saves and you don't have to do it again. For those looking for a starting place I posted a thread over on the MSFS forum.

Finally there has been a lot of concern that the Cockpit Views don't smooth pan with the hat switch. Again if you look at the Bindings for the hat (POV) in Control, you can change it from Cockpit Camera Quickview to Cockpit Camera Look.

Hope this helps! Rick 

Hi there

Cannot find that thread on the MSFS forum. Could you pls post a link?

Thanks,

Roland

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    31%
    $7,750.00 of $25,000.00 Donate Now
×
×
  • Create New...