Jump to content

RobJC

Finally fixed game stutters

Recommended Posts

Hey guys, just wanted to share how I fixed the stutters I was seeing in this sim. For background, I have a 4770K CPU (overclocked to 4.3 GHz) paired with a GTX 1070 and 32 GB RAM running 1440p with all SSDs.  I have most of my settings on Ultra or High, and the visuals are excellent. But I was getting occasional stutters although the game was super fluid and I was getting around 27 FPS. I started investigating the cause of the stutters, initially thinking that my GPU could not keep up. I put a small overclock on the GPU but the stutters remained. I have tweaked the NVIDIA settings, and in-game settings until my eyes started to bleed, at which point I ran across a thread on process lasso. I did the recommended tweaks (set priority, disable windows dynamic thread priority) and saw considerable improvement in the stutters, but they were still there. So here is how I resolved my sim stutters.

While the sim was running (flying from Denver to Telluride) I loaded up process lasso and watched the graph while simultaneously having the sim dev FPS overlay up. At first I noticed that the GPU was red the entire time, and the Main Thread was yellow, but with frequent red spikes. When the red spikes clustered, the stutters occurred. I then sorted my CPU % column in process lasso to see what was happening during the spike. First, the CPU (all cores) were maxed out. A process linked to Malwarebytes was running for just a split second. I stopped that program and did a retest. It then ran fine until a process related to WebEx ran. I turned that off. Now the sim runs stutter free and the Main Thread is constantly yellow with occasional green (rarely a red bar). The GPU graph shows red with lots of yellow spikes. Smooth as butter.

In conclusion if you are getting occasional stutters but the sim is smooth otherwise, it is most likely not your GPU but rather a process that is running periodically that your CPU is consumed by. You need to track down those processes. 

BTW, I tried the CPU priority changes but that did not solve the problem. For some reason when certain processes run the CPU just cannot balance the load well enough. All cores max out during the spikes, so my original thought of dedicating only specific cores to the sim would not have helped. 

In any case, 27 FPS is amazingly smooth with my old CPU and GPU, so if you have anything more modern than mine you should be solid once you track down the offending processes. 

Rob 

 

 

Edited by RobJC
  • Like 5

i7 4770K@4.3GHz | 32GB RAM | GTX 1070 | ASUS Z97-Pro | 1TB SSD | LG 27GL850 G-Sync | Win10 Home

Share this post


Link to post
Share on other sites

What version of lasso are you running? freeware or pro? I would like to know more about that and what to disable.

Thanks,

Edited by alexcolka

Alexander Colka

Share this post


Link to post
Share on other sites
3 minutes ago, alexcolka said:

What version of lasso are you running? freeware or pro? I would like to know more about that and what to disable.

Thanks,

Free version.

PROCESS LASSO:

For flightsimulator.exe (start sim first) I set:

- Priority class > Always > High {SELECTED]
- Priority class > Always > Windows dynamic thread priority boosts enabled [NOT SELECTED]

NVIDIA Control Panel:

- Power management mode: Prefer maximum performance
- Texture filtering quality: High performance
- Threaded Optimization: Off
- Triple Buffering: Off

 

  • Like 1

i7 4770K@4.3GHz | 32GB RAM | GTX 1070 | ASUS Z97-Pro | 1TB SSD | LG 27GL850 G-Sync | Win10 Home

Share this post


Link to post
Share on other sites
1 minute ago, RobJC said:

Free version.

PROCESS LASSO:

For flightsimulator.exe (start sim first) I set:

- Priority class > Always > High {SELECTED]
- Priority class > Always > Windows dynamic thread priority boosts enabled [NOT SELECTED]

NVIDIA Control Panel:

- Power management mode: Prefer maximum performance
- Texture filtering quality: High performance
- Threaded Optimization: Off
- Triple Buffering: Off

 

Thank you Rob will try those.


Alexander Colka

Share this post


Link to post
Share on other sites

I would highly recommend shutting down all non-essential background services and applications prior to running this.  In recent years my little bit of playing with FSX:SE didn't really matter as I could never push the boundaries of my system (I didn't use any add-ons, really, tinkered only), but with 2020 being such a resource hog (for good reason)...

I build a system from the ground up specifically for this, and the first thing I did after installing Windows was remove everything unneeded, the check all my startup services, etc.  So, the OS is squeaky clean (or as squeaky clean as Win10 gets anyway...).  If I were running this on a box not dedicated to the sim, I'd definitely come up with a batch script that shut all that stuff down prior to firing up the sim. 

Anti-virus, backups and update services are notorious for causing performance issues when they run.  If they can't be turned off entirely, at least try to be careful of their scheduled run times and turn off live monitoring during flights, etc.

Share this post


Link to post
Share on other sites

(re-reading that post sounded a bit condescending - not what I intended at all, was more of a post for future lurkers that might have come across it due to the title and wanted some general tips...)

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
2 hours ago, RobJC said:

Hey guys, just wanted to share how I fixed the stutters I was seeing in this sim....

Thanks for this!  I am running very similar hardware, i5 6600k oc'd to 4.5Ghz, GTX 1070 native and SSDs.  Currently just setting the Process Lasso Priority class > Always > Windows dynamic thread priority boosts enabled [NOT SELECTED].  I still get micro stutters, but I will try your recommendation above and see where I'm at. ~Robert


i5-6600K 3.5Ghz OC to 4.5GHz|CorsairH60 Liq Cooler|GA-Z170X-Gaming 7|GTX 1070|G.Skill Trident DDR4-3200 32GB|950 PRO M.2 250GB|850 EVO 500GB|2TB Seagate FireCuda SSHD|FractalDesign R4|Corsair RMx 750W|Win10 64bit Home|X-Plane 11|MSFS2020

I love the smell of Jet-A in the morning!

Robert Pressley a.k.a. SmokeDiddy

Share this post


Link to post
Share on other sites
2 hours ago, jackdleach said:

"...and turn off live monitoring during flights, etc."

That partially, if not fully, defeats the purpose of having AV software. Mine has now become a relatively ancient system, and I keep my AV monitoring active at all times; and I experience very, very few micro-stutters. I have also read some threads that indicate that having [significant] AI traffic active is often times the [a] culprit with regard to micro-stutters.


i7-8700; 16GB DDR4 at 2666MHz; nVidia GTX 1070 Ti; 512GB NVMe SSD & 1TB 7200 RPM HDD; Win 10 Pro; FSX Gold, FS Genesis (orig. legacy) mesh, a gazillion addons; MFS 2020 inst. on ext. 1TB Samsung 840 EVO SSD; LG 32UD59-B 32" UHD 4K; Thrustmaster T.16000M FCS stick; wired conn. to rtr.

Share this post


Link to post
Share on other sites
1 hour ago, RustyFlyer said:

That partially, if not fully, defeats the purpose of having AV software.

Partially, maybe, but hardly fully.  I'd suggest it's a matter of risk... how much risk of a virus being downloaded to your machine while using a flight sim?  There's many ways aside from AV to be security-conscious, and I think turning off active monitoring during a sim session is relatively low risk, provided you're careful about what is running during that time.  Sketchy add-ins may be a risk, and email is usually the only other thing that "listens outside" that's also risky, but that can be mitigated fairly easily by closing your email client or having it download headers only by default.  Anyway, it's a bit far afield the original post now, and I'll respect anyone's opinion/practices on matters of security, but that's my 2cents worth.  Cheers

Share this post


Link to post
Share on other sites

Make sure you don’t run any unnecessary background programs like AV , App updates , Windows updates , Apps running in the background 


Gerard

7940x ( 14 cores ) : 8 cores @ 4.8 - 6 cores @ 4.0 Ghz - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Gigabyte GTX 2080 TI Windforce OC @1920 Mhz - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Gigabyte GTX 2080 Windforce OC @ 1900 Mhz - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
Share on other sites
2 hours ago, MrFuzzy said:

Why this?

There is always divided opinion whether Threaded Optimization should be on or off in Nvidia Inspector.  Does anyone really know which way it should be and why?

Also, last night With TAA on and Anisotropic set to x16, I was getting no visual difference whether Supersampling was set to x2 or x8.  I have heard that the higher you go the more VRAM it will consume, so looks like this can be set low.  I noticed even on x8 I still had shimmering wire fences anyway.

Makes you wonder if some of these setting are actually changing things properly, for instance the Vsync settings obviously aren't working as intended yet.

Edited by bobcat999

I like to fool airline passengers into thinking I have my own swimming pool by painting a large blue rectangle on my patio!

Share this post


Link to post
Share on other sites

My AV is set to silent mode in my sims no stutters.

  • Like 1

i9 10900K\ASUS APEX MB \ MSI RTX 2080Ti GAMINGX TRIO \ M.2  Samsung 970 EVO Plus 1TB C Drive \ 2+1TB Samsung 850 EVO \ 2TB BarraCuba \ 32GB G.SKILL Z DDR4 3600MHZ \ Windows 10 Home\ ASUS 28" 4K monitor\ 4TB Portable Drive\P3DV5

Raymond Fry.

PMDG_Banner_747_Enthusiast.jpg

Share this post


Link to post
Share on other sites

Update: I spent about 5 hours flying the Baron and C152 last night and this sim is really amazing when you aren't experiencing stutters left and right. I think the G-Sync monitor I have is doing a lot of the heavy lifting, because even at 20 FPS it is smooth. Panning around is silky smooth in the cockpit, but i do get the initial takeoff stutters as the CPU is flat out. But as soon as I take off it smooths right out. I have even flown out of Heathrow and it works very acceptably. 

I will post my in-sim settings when I get a chance. 

  • Like 1

i7 4770K@4.3GHz | 32GB RAM | GTX 1070 | ASUS Z97-Pro | 1TB SSD | LG 27GL850 G-Sync | Win10 Home

Share this post


Link to post
Share on other sites
9 hours ago, MrFuzzy said:

Why this?

I set this to off and it’s stutter city. My belief is it should be set to on. It does as it’s name suggests, optimises the threaded stuff. As far as I understand it tries to spread workload of main cpu thread to other threads, thus lowering CPU bottleneck.

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,075.00 of $25,000.00 Donate Now
×
×
  • Create New...