Jump to content
Sign in to follow this  
penta_a

Patch Version 1.8.3.0 Is Now Available!

Recommended Posts

25 minutes ago, marcg11 said:

First let me preface by saying that I do see improved performance for my PC which is appreciated. However I too am mystified at the process going on with this product. There is just no way some of the things that have cropped up in this release should have occurred and released in this condition. The A320 left engine issue and the mach/speed toggle being broken seem like items that cannot be released. I am in QA with a software company so I understand the dev software process pretty well - I also understand the pressure that software developers are under when issues are brought forward (performance I think in this case) and the thinking that corners can be cut. There are workarounds for the issues I am seeing and the game is still immensely enjoyable for me…but really this cant be way forward…Either the issues were missed in QA or the patch was rushed and not enough time went into making sure everything was covered. Hopefully some thought will go into the process moving forward…communicating to the community that more time is needed…and these patches can be better for everyone.

Agreed. Missing Control Sensitivities (as one example) means that the team who designed/patched/updated the UI menus simply did not test their own work. I find this extraordinary. If your task is to patch and check the menus, then at the very least you would spend a couple of hours going through every single menu (there aren't that many of them) and double checking they work, or even that they exist. It really does not take that long to check your work.

  • Like 8
  • Upvote 1

Robert Young - retired full time developer - see my Nexus Mod Page and my GitHub Mod page

Share this post


Link to post
Share on other sites

I gain about 5 fps with the patch, the sim runs stable and smooth at 60+ fps, I saw that my CPU Core# 5 tops at 100% now, not the first one as before the patch, I wonder if that is related to the patch note "Tweaked CPU thread priorities to reduce interruptions in frame critical threads." ?

Edited by Ixoye
  • Like 1

| Intel I9 10900K | Corsair 32Gb 3200MHz | Asus Rog Strix OC 2080Ti | Samsung 970 EVO Plus 1TB |

Share this post


Link to post
Share on other sites

All parameters weren't working at KFAT...not even close.

I agree did a Fedex Caravan flight from kmke-ksaw. Weather reports in KSAW all day were mostly clear skies. I went almost to minimums before breaking out of overcast so it wasn't even close weather wise. I did have winds aloft though. I nfact, the metar always reports these same values regardless of what is actually depicted (before and after patch). dew point 10, few clouds 1,200, few clouds 4,500, few clouds 12,500. Temp, winds and altimeter do change but are rarely accurate  

Share this post


Link to post
Share on other sites
8 minutes ago, Flyfaster said:

So annoying to have to go thru the MS store every time to update this thing! 😞

Literally took me 5 minutes.  Just download the xbox app and click two buttons, close, open sim lol 

Share this post


Link to post
Share on other sites

One observation. Winds aloft have no effect on the aircraft ground speed. 20knt tail wind and the GS matches the IAS. C208 FL6000.

Share this post


Link to post
Share on other sites
8 hours ago, sd_flyer said:

Update is 15.53 Gib for me

I'm getting 15.9 and have Premium.  I guess that explains the different download sizes.

 

Share this post


Link to post
Share on other sites

Downloading 19.24 GiB (and still going) of 15.69 Gib...  I must have one of those premium deluxe patches!  The trouble is I just don't know how much to expect.  It's 3 in the morning here and I need to go to bed! 

Whilst I am grateful to MS/Asobo for responding quickly and adding the performance improvements (along with other improvements), but the issues regarding the Airbus left engine starting, and various displays going blank in flight need a hot fix quickly.

And while it understandable that some aircraft systems might get inadvertently broken while trying to fix or improve the aircraft systems, how this could cause the control sensitivities panel to go missing I just do not understand. (work around is to text edit a controls config file apparently).

The most worrying thing for me, and the first thing that will lead to me losing support for them if true, is that apparently, according to a thread on Reddit by someone assisting the A320Neo improvement program, they have not only ignored requests for communication from them, but it seems damaged their ability to carry on.  Whether this was done on purpose or not I don't know, but if this is true, it is very sad.  

Edited by bobcat999
Extra info

I like to fool airline passengers into thinking I have my own swimming pool by painting a large blue rectangle on my patio!

Intel i9 12900k in a ROG Strix Z690 D4 motherboard with water cooling, EVGA RTX 3080Ti Ultra, 32 GB DDR4 RAM 3800 CL15, 4 x Samsung 1 TB NVME M.2, with MSFS on a Samsung 980 pro PCIE4 (7000 gb/s).

Share this post


Link to post
Share on other sites
1 hour ago, ckyliu said:

The launcher is still a bag of poo, got stuck on a particularly large file and kept restarting it, I had to connect up my powerline Ethernet adapters, for some reason the launcher does not get on with Wifi and it's the only app on my PC that doesn't.

I download over wifi and never had any problems with downloads or installations

  • Like 1

Share this post


Link to post
Share on other sites

Installed the patch here and haven't had time to do test flights, just loading the Caravan on the runway, but that's showing almost 10 FPS better than before. That's progress! Good job Asobo if this is also what other users are seeing.

Also the Dev mode FPS window is showing I'm now "main thread limited," where before the patch it was showing GPU limited. That's interesting. 

Sensitivity curves menu gone, but based on controller response it looks like it's still using my saved curves. Someone screwed up there, but it least it doesn't affect anyone who already saved the settings.

 

1 hour ago, B787Pilot3222 said:

Not working. It's foggy (smoke) here in Vancouver and the sim depicts broken clouds. Disappointing.

Same here with Live Weather close to 0S9 in the Washington Olympic Peninsula not far away from you.

Broken clouds in the sim, when the visibility should be way down according to local METARs. Even ignoring the smoke, there's more cloud cover up there right now than "broken." 


X-Plane and Microsoft Flight Simulator on Windows 10 
i7 6700 4.0 GHz, 32 GB RAM, GTX 1660 ti, 1920x1200 monitor

Share this post


Link to post
Share on other sites
40 minutes ago, robert young said:

Agreed. Missing Control Sensitivities (as one example) means that the team who designed/patched/updated the UI menus simply did not test their own work. I find this extraordinary. If your task is to patch and check the menus, then at the very least you would spend a couple of hours going through every single menu (there aren't that many of them) and double checking they work, or even that they exist. It really does not take that long to check your work.

You guys must have not been in Flight sim very long, this is exceptional compared to FSX and the bugs it had. It was never right.  I'm still amazed with the default scenery and Aircraft. I know this will take time to perfect and I can except that.  Give it time, and ofcourse it was released before schedule, if it bothers you that bad you feel the need to complain go back to FSX or P3D and fly those default aircraft, all your doing is complaining. Come back in a year or so and maybe it will meet your standards.  I guess you can't please everyone.  

  • Like 4
  • Upvote 1

I fly mostly GA and Business jets around ORBX PNW | Im live near Boston so I also will fly in MA and ME |  KLEW- 3B1- KBED 

Also avid RC Pilot, Planes and Heli | Ride a Harley's and Snowmobiles! 

PC Setup: Intel i7 8700k | MD Z370 | MSA GTX1080 | H100 liquid Cooling | 250G SSD | PS RM750 | NZXT S340 Case | Windows 10 | AOC 27" 4K | P3D V4.5 | Saitek Yoke | Saitek Rudder pedals | Saitek Throttle Quad| Lots of Addons| 

Share this post


Link to post
Share on other sites
10 minutes ago, Ryanmlt1 said:

You guys must have not been in Flight sim very long, this is exceptional compared to FSX and the bugs it had. It was never right.  I'm still amazed with the default scenery and Aircraft. I know this will take time to perfect and I can except that.  Give it time, and ofcourse it was released before schedule, if it bothers you that bad you feel the need to complain go back to FSX or P3D and fly those default aircraft, all your doing is complaining. Come back in a year or so and maybe it will meet your standards.  I guess you can't please everyone.  

I accept your points, and most of the update work is excellent - the sim is excellent, but the regression on the control sensitivities panel is not good and is hard to understand, as they weren't even working on it.  Hopefully, as it is a UI issue, they can put it back quickly with a hot fix.  It is really important to have this especially due to the current over sensitivities of the aircraft to control inputs.

Edit:  On second read of your post it comes across as a bit offensive actually.  I don't often agree with RY, but on this point he is right.  Telling someone to go back to their old sim and come back in a year, when they have paid good money, had something that worked and is now broken, is out of order.  They are right to complain about this and ask for it to be it put back quickly.

Edited by bobcat999
Extra text

I like to fool airline passengers into thinking I have my own swimming pool by painting a large blue rectangle on my patio!

Intel i9 12900k in a ROG Strix Z690 D4 motherboard with water cooling, EVGA RTX 3080Ti Ultra, 32 GB DDR4 RAM 3800 CL15, 4 x Samsung 1 TB NVME M.2, with MSFS on a Samsung 980 pro PCIE4 (7000 gb/s).

Share this post


Link to post
Share on other sites
7 minutes ago, adesai73 said:

is anyone else not able to see the in-flight settings bar after the update?

This isn't listed as a problem, and in fact, people are seeing a new 'active pause' icon in there.  Maybe reboot and restart to see if it persists.

Edited by bobcat999

I like to fool airline passengers into thinking I have my own swimming pool by painting a large blue rectangle on my patio!

Intel i9 12900k in a ROG Strix Z690 D4 motherboard with water cooling, EVGA RTX 3080Ti Ultra, 32 GB DDR4 RAM 3800 CL15, 4 x Samsung 1 TB NVME M.2, with MSFS on a Samsung 980 pro PCIE4 (7000 gb/s).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...