Jump to content

Sign in to follow this  
swk1959

208 Altitude autopilot

Recommended Posts

It seems no matter what I do, when I set the altitude the aircraft continues to climb, even when I set it to a lower altitude and engage -vs speed it continue's to climb the only way to stop it is to disengage the AP and hand fly it. As soon as the AP is engaged regardless the plane climbs.

any help would be appreciated,

 

Thanks

Share this post


Link to post
Share on other sites
Posted (edited)

Do you have a target altitude already set with the alt knob? I have been flying the C208 pretty exclusively lately and here is what I typically do

Set target altitude with alt knob when still on ground 

Engage the flight director before takeoff

When in the air and ready to engage AP I sync the heading with my current heading by pressing the hdg knob then I engage the heading mode

I then will engage f/c mode and finally the AP

f/c mode should provide pitch to maintain the current airspeed which you can then increase or decrease with the vspeed wheel until reaching target altitude

I haven't had any AP issues doing this other than there is a bit of a nose down pitch when within about 500ft of target altitude which it then slowly climbs back to reach target altitude but I think this is a bug with the latest update 

 

Dave

Edited by DaveS
additional info

Share this post


Link to post
Share on other sites

Thanks Dave for the speedy reply I will give it a shot and see what happens

 

Scot

Share this post


Link to post
Share on other sites

Thanks for the suggestion Dave but I followed your directions exacally tried it 4 times to make sure, the aircraft just continues to climb regardless

 

Scot

 

Share this post


Link to post
Share on other sites

It seems this is an issue with the 208, the 172 and the mooneybravo's autopilots are functioning as expected.

Share this post


Link to post
Share on other sites

What you are describing has not happened to me ever and I have around 88 hours in my logbook on the c208. I wonder if it something else causing it on your setup. Perhaps a control issue?

Share this post


Link to post
Share on other sites

I don't disagree, it just seems odd that it just the 208, I suspect it may be an issue between my machine and the latest update as I never had the trouble before. Oddly enough before the update I had issue's with the 172 autopilot but since the update it works fine.

Share this post


Link to post
Share on other sites

No mods at all Dave, strictly the same as I bought it with the exception of the patches

Share this post


Link to post
Share on other sites

Same problem for me with the C208, on FLC or VS modes it always shoots past the set altitude. No problems at all with the AP on either of the 172's. Once the C208 is at a set AP altitude, you can then change altitudes using VS with no problem, so I reach set altitude with a 172, then switch to the 208 using developers mode.

Share this post


Link to post
Share on other sites

I haven't had that problem. I set the desired alt. I set the vspeed and enable VS. I set the FD. I set the proper NAV mode. Then after take off, I trim to get close to my rate of climb and then engage the AP.  It just continues the climb and engages ALT hold at correct level


 

P3D#1 - 7700K 5.0g ROG X270F 3600 15-15-15 - EVGA RTX 2080ti 1000W PSU 1- 850G EVO SSD, 2-256G OCZ SSD, 1TB,HAF942-H100 Water W1064Pro
40" 4K Monitor 3840x2160 - AS16, ASCA, GEP3D, UTX, Toposim, ORBX Regions, TrackIR
P3D#2 - 3770K 4.7g Asus Z77 1600 7-8-7 GTX1080ti DH14 850W 2-1TB WD HDD,1tb VRap, Armor+ W10 Pro 2 - HannsG 28" Monitors
 

Share this post


Link to post
Share on other sites

It must differ from machine to machine I guess, it had worked for me when I first bought it but seems broken now, trying all the Ga's I have in the deluxe version to see which one's are affected for me, so far just the 208.

9 minutes ago, vgbaron said:

I haven't had that problem. I set the desired alt. I set the vspeed and enable VS. I set the FD. I set the proper NAV mode. Then after take off, I trim to get close to my rate of climb and then engage the AP.  It just continues the climb and engages ALT hold at correct level

 

Share this post


Link to post
Share on other sites
22 minutes ago, vgbaron said:

I haven't had that problem. I set the desired alt. I set the vspeed and enable VS. I set the FD. I set the proper NAV mode. Then after take off, I trim to get close to my rate of climb and then engage the AP.  It just continues the climb and engages ALT hold at correct level

I just tried it in the same order you describe, and still no Alt hold. Had VS set to 500fpm and it steadily climbed between 500 and 1200 fpm and went passed the set Alt. The Altimeter started blinking when it got close to the altitude, but kept going.

Share this post


Link to post
Share on other sites
41 minutes ago, desbean said:

I just tried it in the same order you describe, and still no Alt hold. Had VS set to 500fpm and it steadily climbed between 500 and 1200 fpm and went passed the set Alt. The Altimeter started blinking when it got close to the altitude, but kept going.

Now that IS strange.  I assume you are starting on the runway with engine running. I say that because if you did a manual start, perhaps "something" didn't get initialized properly. If you have any mods installed in community folder, try removing them all and see if the AP works then add back one by one.


 

P3D#1 - 7700K 5.0g ROG X270F 3600 15-15-15 - EVGA RTX 2080ti 1000W PSU 1- 850G EVO SSD, 2-256G OCZ SSD, 1TB,HAF942-H100 Water W1064Pro
40" 4K Monitor 3840x2160 - AS16, ASCA, GEP3D, UTX, Toposim, ORBX Regions, TrackIR
P3D#2 - 3770K 4.7g Asus Z77 1600 7-8-7 GTX1080ti DH14 850W 2-1TB WD HDD,1tb VRap, Armor+ W10 Pro 2 - HannsG 28" Monitors
 

Share this post


Link to post
Share on other sites
7 minutes ago, vgbaron said:

Now that IS strange.  I assume you are starting on the runway with engine running. I say that because if you did a manual start, perhaps "something" didn't get initialized properly. If you have any mods installed in community folder, try removing them all and see if the AP works then add back one by one.

Yes, started on the runway and running. AP holds heading, but not Alt. Once again I switched to the 172 G1000, established altitude with AP then switched back to 208. When back in the 208 the AP is still on, but have to re-select and re-adjust both Heading and Alt., but then no problems with AP. On a brighter note I have no crashes using VFR map...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    33%
    $8,485.00 of $25,000.00 Donate Now
×
×
  • Create New...