Jump to content

ah2511

P3Dv5.1 and VR

Recommended Posts

40 minutes ago, YoYo said:

According me they take wrong way for WMR in P3Dv5. 

Update Sync:

YDPw7hDl.jpg

Pre Render Sync:

wBw6X3hl.jpg

Pre Render here is the Holy Grail (and for example DCS use this). Why we have here Update option only for WMR in P3D I dont know. Pre render option doesnt work with WMR as it should with P3D, too many jittery but with very good FPS and frame time.

 

Second thing I started to investigate some of strange behavior in some of planes in v5 (it doesnt present in v4.5). It looks like a large momentary lag when you panning your head in Virtual Cockpit. Just for very short time but its very noticeable. Most of all, I noticed it in the older models that the developer ported to P3Dv5. Next I noticed that its connected with gauges (maybe old version or so) - but it wasnt present also in v4.5, after some time, when you see this big lag several times for no reason, you just don't want to fly. I found some articles about refresh rate of gauges (maybe it could be a problem if you HMD and sim works for example on 45 or 90 Hz but the gauge works with 18Hz - result lag, so maybe here is a problem also?) :

https://prepar3d.com/forum/viewtopic.php?f=6312&t=124001&start=30#p154707 (PANELS_UPDATE_EVERY_FRAME=1)

https://www.prepar3d.com/SDKv4/prepar3d/getting_help/advanced_configuration.html ( PANEL_UPDATE_MODE = 2 , 0-3, I have Academic)

I will check it. Did you notice in WMR sometime this strange behovior even you have max FPS for example?

Here is example. I did it from camera so sorry for bad quality but you can see few this lag here (notice that I have stable 45 fps in this situation):

 

Yes. Exactly this shot but noticeable stutter, like you display freeze milliseconds, and then goes on. Very annoying this behaviour. It drives me crazy that sometimes it is very smooth, sometimes out of nowhere it has this single stutter every x seconds.

We do have exactly the same issue YoYo!

And it does not matter if you have 150+ fps or 90 fps or 45fps. 

It is like P3D is "running to fast" and forgets his legs (VRSTEAM) sometimes

Share this post


Link to post
1 hour ago, mpo910 said:

Yes. Exactly this shot but noticeable stutter, like you display freeze milliseconds, and then goes on. Very annoying this behaviour. It drives me crazy that sometimes it is very smooth, sometimes out of nowhere it has this single stutter every x seconds.

We do have exactly the same issue YoYo!

And it does not matter if you have 150+ fps or 90 fps or 45fps. 

It is like P3D is "running to fast" and forgets his legs (VRSTEAM) sometimes

do you guys use UGCX by any chance? for me  that addon induces this kind of stutter at SMALL AIRPORTS because it is scanning the scenery cache at intervals.  you also notice at ORBX airports that the people stop moving for a second.

Share this post


Link to post

Means Ultimate Ground Crew X? No, I havent it.


Webmaster of yoyosims.pl.
Yoyosimsbanner.gif
Win 10 64, i9 9900k, RTX 3090 24Gb, RAM32Gb, SSD M.2 NVMe, Predator XB271HU res.2560x1440 27'' G-sync, Sound Blaster Z + 5.1, TiR5 [MSFS, P3Dv5, DCS, RoF, Condor, IL-2 CoD/BoX] VR fly only: HP Reverb v2

Share this post


Link to post
13 hours ago, YoYo said:

The latest and newest - 457.30 but dont campare Oculus to WMR, both are different systems. Perhaps do you use Sync in Pre render option in VR settings also?

We do have nvidia in common though. Check this out mate 

I don’t think 3000 series has any good drivers for VR right now, but 456.71 gave me a better experience, plus uninstalling fpsVR helped...

Cheers

 

 

  • Like 2

Share this post


Link to post
39 minutes ago, CaptainNick said:

I have noticed in single pass, my plane seems to sit a foot or two off the runway/taxi way/ramps now. Kind of odd.

That issues occurs on some airports since latest P3DV5.1 release (prior HF1). If it is single pass issue or caused by something else and only been seen in singlepass, I can´t tell you.

LM is aware of this as we opened tickets at their forum.

Examples are:

KSEA

FACT

and probably more, which I am not aware of at the moment.

Marcus

Edited by mpo910
  • Like 1

Share this post


Link to post
11 hours ago, ah2511 said:

I don’t think 3000 series has any good drivers for VR right now, but 456.71 gave me a better experience, plus uninstalling fpsVR helped...

But for example this "large lag" from my video from HMD was present also on 2080Ti, so according me its not a driver problem only but I agree drivers (or Steam VR) must be udated also for 30xx... the first my touch with P3D on 30xx was worse than on 2080Ti on the same version of P3Dv5.1 HF1 and the same drivers and SteamVR/WMR.

This is interesting topic for 3090 owners (the same magneta was in P3Dv5 - solution was not using water on Ultra quality, just High or less, but I played on Ultra water in 2080Ti without any problem https://www.prepar3d.com/forum/viewtopic.php?f=6312&t=140306): 

https://www.nvidia.com/en-us/geforce/forums/game-ready-drivers/13/402768/valve-index-missing-dropped-frames-since-nvidia-d/ .

Yep, it could be a case also with drivers ...

 

Edited by YoYo

Webmaster of yoyosims.pl.
Yoyosimsbanner.gif
Win 10 64, i9 9900k, RTX 3090 24Gb, RAM32Gb, SSD M.2 NVMe, Predator XB271HU res.2560x1440 27'' G-sync, Sound Blaster Z + 5.1, TiR5 [MSFS, P3Dv5, DCS, RoF, Condor, IL-2 CoD/BoX] VR fly only: HP Reverb v2

Share this post


Link to post

I just updated the following due test purposes to get rid of the lag magenta spikes within the farmetimes:

  • Uninstalled the standard Intel Chipset-, LAn and WLAN drivers
  • Installed new/fresh and up to date  M.Board related Chipsetdrivers
  • Installed new/fresh and up to date M.Board LAN and WLAN drivers 
  • Updated my BIOS (ASUS ROG MAXIMUS FORMULA VII Z490) to 0901 Version (got this month released )

I am testing right now and will report back if the spikes do further occur. 

Within the present flight they did not, but it is to early to be sure because I had this often that sometimes it was smooth and sometimes it was stuttery.

But for now, 30 min in flight with FSLabs from GCLP to LEMG not a single magenta spike.

Marcus

 

Edited by mpo910
  • Like 1

Share this post


Link to post

I did it few days ago, BIOS, drivers, new W10 even (fresh install before I changed GPU too), the same as it was. 

  • Like 1

Webmaster of yoyosims.pl.
Yoyosimsbanner.gif
Win 10 64, i9 9900k, RTX 3090 24Gb, RAM32Gb, SSD M.2 NVMe, Predator XB271HU res.2560x1440 27'' G-sync, Sound Blaster Z + 5.1, TiR5 [MSFS, P3Dv5, DCS, RoF, Condor, IL-2 CoD/BoX] VR fly only: HP Reverb v2

Share this post


Link to post
2 hours ago, YoYo said:

I did it few days ago, BIOS, drivers, new W10 even (fresh install before I changed GPU too), the same as it was. 

Do you have software for RGB stripes, like ArmouryCrate, or CorsairCube installed? These are also having nasty sideeffects on latency

Share this post


Link to post
2 hours ago, YoYo said:

I did it few days ago, BIOS, drivers, new W10 even (fresh install before I changed GPU too), the same as it was. 

also I did the following:

Virus Exlusion to runtimebroker.exe! This gained FPS with WMR running but VR turned off. Very interesting. More stable less jumpy FPS now. 

I saw, thet my FPS went down 20FPS (from 150 to 125) only turning on WMR without entering VR.

After I excluded runtimebroker.exe as a process, this gained.

But these 20 FPS do not count in every situation. In my case only when FPS is already very high above 100FPS+.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    34%
    $8,560.00 of $25,000.00 Donate Now
×
×
  • Create New...