Jump to content

Sign in to follow this  
fs1

New ATC and Airport Operations Application Testing

Recommended Posts

Posted (edited)

I did a test in KATL, where I dispalced R09L threshold by 152 meters and recompiled the default BGL.

Fast takes Offs are working fine there. I appreciate any hints. Thanks

Edited by fs1

Federico Sucari

Share this post


Link to post
Posted (edited)
54 minutes ago, fclaass said:

The behaviour you see is:

>  Aircraft is on short final

>  T/O Aircraft is holding short

>  Landing aircraft passes the T/O aircraft holding short.   T/O Aircraft is lining up before landing aircraft has touched down.

>  T/O Aircraft starts take-off roll regardless of landing aircraft has already vacated the runway. 

You can change the threshold value in ADE,  under Runway Settings, tab Primary/Secondary   'Offset Threshold;  

 

When you change this, the behaviour is:

>  Aircraft is on short final

>  T/O Aircraft is holding short

>  Landing aircraft touches down

>  T/O Aircraft lines up runway  approx 1 or 2 seconds after touchdown. 

>  T/O Aircraft waits on the runway until aircraft has vacated the runway, then starts the take-off roll.

I see what you mean. The further the AI is landing, the larger is the wait until the AI enters the runway, correct? If so, I will fix it

Edited by fs1

Federico Sucari

Share this post


Link to post

No, that's not what I mean.  I'm talking about the EnableRollThenTakeoff.   When the threshold is further down the runway, the AI enters the runway before touchdown of the landing AI, and it takes off regardless of when the landing AI vacates the runway. So it starts the take-off roll while the landing AI is still slowing down on the runway.

I have turned EnableFastTakeOff  off. 

Share this post


Link to post

You should test it on GVA airport for example,  Runway 05. which has a displaced threshold of 360 meters or something.

Share this post


Link to post
4 minutes ago, fclaass said:

You should test it on GVA airport for example,  Runway 05. which has a displaced threshold of 360 meters or something.

Ok I will test GVA, Rny 05 and let you know, Could not replicate it in KATL.


Federico Sucari

Share this post


Link to post
Posted (edited)

Here is a short video that is demonstrating the problem: One aircraft is still breaking after landing, while the departure is lining up. So far so good. But the departing aircraft then starts the take off with the landing aircraft still occupying the runway. 

Airport is KSAN San Diego with a displaced threshold.
 

 

Edited by Wolkenschreck

Best,
Christoph

Display resolution: 1920x1080 (8xSSAA)    GPU: 1080TI     CPU: i7-7700K (5.0 OC)    RAM: 16GB     SSD: Samsung 850Evo     Monitor: 27K

FSBetaTesters3.png

Share this post


Link to post

Thanks Christoph! Let me take a look. Regards, Federico


Federico Sucari

Share this post


Link to post

Does the runway assignment system works with the user’s aircraft. It seems that it does not because  it always gives me the closest runway. 
would that be a possible feature to add?

Share this post


Link to post
3 hours ago, Wolkenschreck said:

Here is a short video that is demonstrating the problem: One aircraft is still breaking after landing, while the departure is lining up. So far so good. But the departing aircraft then starts the take off with the landing aircraft still occupying the runway. 

Airport is KSAN San Diego with a displaced threshold.
 

 

I will work on a workaround with threshold. There seems to be a null zone not being detected.

36 minutes ago, cmdn said:

Does the runway assignment system works with the user’s aircraft. It seems that it does not because  it always gives me the closest runway. 
would that be a possible feature to add?

Still not. Is forthcoming! Thanks 

  • Like 1

Federico Sucari

Share this post


Link to post

What a fantastic tool which delivers an element of realism which flight simulator in all its forms has been missing since AI was first invented.

Had the odd problem with the planes lining up after an arrival has touched down but starting the roll before the previous plane has vacated - will need to check the off-set threshold point.

On a point of good order, when the plane taxis into position as the landing plane touches down, ATC gives the "cleared for takeoff" message when in real life it would be "Line up and hold" pending the vacation of the runway of the prior landing at which point takeoff clearance would then be given. Not sure how easy this is, but thanks to the author for something which does beyond the extra immersion which apps like AIFlow and AIGround have recently delivered.

  • Upvote 1

Share this post


Link to post

Not as technically proficient as others - can someone please point out where these files go? And what is used to edit the .xml files? Notepad++?

Share this post


Link to post
1 hour ago, verbal said:

Not as technically proficient as others - can someone please point out where these files go? And what is used to edit the .xml files? Notepad++?

You need to unzip all files into your P3D Documents\addons folders. 
For example, for P3D v4, open the Windows Explorer and type %userprofile%\Documents\Prepar3D v4 Add-ons

see this post in LM forums:

https://www.prepar3d.com/forum/viewtopic.php?t=126661

For the XML, the notepad is just fine.

Let me know if any issues.

 

 


Federico Sucari

Share this post


Link to post

Hi Frederico

Thanks for this nice little tool.

Did some testing tonight in Zurich. Unfortunately, I had takeoffs from RWY34 instead of RWY16, and landings on RWY16 at the same time...

Kind regards

Michael

<?xml version='1.0' encoding='utf-8' ?>
<Parameters>
    <Airport>
    <ICAO>EDDF</ICAO>
    <ActiveTakeOffRunway>
        <Runway>R07C</Runway>
    </ActiveTakeOffRunway>
    <ActiveTakeOffRunway>
        <Runway>R18</Runway>
    </ActiveTakeOffRunway>
    <ActiveLandingRunway>
        <Runway>R07L</Runway>
    </ActiveLandingRunway>
    <ActiveLandingRunway>
        <Runway>R07R</Runway>
    </ActiveLandingRunway>
    </Airport>
    <Airport>
    <ICAO>LSZH</ICAO>
    <ActiveTakeOffRunway>
        <Runway>R28</Runway>
    </ActiveTakeOffRunway>
    <ActiveTakeOffRunway>
        <Runway>R16</Runway>
    </ActiveTakeOffRunway>
    <ActiveLandingRunway>
        <Runway>R14</Runway>
    </ActiveLandingRunway>
    <ActiveLandingRunway>
        <Runway>R16</Runway>
    </ActiveLandingRunway>
    </Airport>
    <enableFastTakeOffs>1</EnableFastTakeOffs>
    <allowTakeOffDistance>6000</AllowTakeOffDistance>
    <taxiSpeedLimiter>30</TaxiSpeedLimiter>
    <enableRollthenTakeOff>1</enableRollthenTakeOff>
    <minCrossingRny>2000</minCrossingRny>
    <isGUIVisible>1</isGUIVisible>
    <voidTimer>1000</voidTimer>
</Parameters>

Share this post


Link to post
2 hours ago, fio said:

Hi Frederico

Thanks for this nice little tool.

Did some testing tonight in Zurich. Unfortunately, I had takeoffs from RWY34 instead of RWY16, and landings on RWY16 at the same time...

Kind regards

Michael

<?xml version='1.0' encoding='utf-8' ?>
<Parameters>
    <Airport>
    <ICAO>EDDF</ICAO>
    <ActiveTakeOffRunway>
        <Runway>R07C</Runway>
    </ActiveTakeOffRunway>
    <ActiveTakeOffRunway>
        <Runway>R18</Runway>
    </ActiveTakeOffRunway>
    <ActiveLandingRunway>
        <Runway>R07L</Runway>
    </ActiveLandingRunway>
    <ActiveLandingRunway>
        <Runway>R07R</Runway>
    </ActiveLandingRunway>
    </Airport>
    <Airport>
    <ICAO>LSZH</ICAO>
    <ActiveTakeOffRunway>
        <Runway>R28</Runway>
    </ActiveTakeOffRunway>
    <ActiveTakeOffRunway>
        <Runway>R16</Runway>
    </ActiveTakeOffRunway>
    <ActiveLandingRunway>
        <Runway>R14</Runway>
    </ActiveLandingRunway>
    <ActiveLandingRunway>
        <Runway>R16</Runway>
    </ActiveLandingRunway>
    </Airport>
    <enableFastTakeOffs>1</EnableFastTakeOffs>
    <allowTakeOffDistance>6000</AllowTakeOffDistance>
    <taxiSpeedLimiter>30</TaxiSpeedLimiter>
    <enableRollthenTakeOff>1</enableRollthenTakeOff>
    <minCrossingRny>2000</minCrossingRny>
    <isGUIVisible>1</isGUIVisible>
    <voidTimer>1000</voidTimer>
</Parameters>

Thanks.

1- What scenery are you using?

2- What version of the DLL are you using? (Right click on the DLL and look at the version tab)

3- This happens consistently with all AIs?

4- Is this the only airport you are having issues?

Thanks

Edited by fs1

Federico Sucari

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    48%
    $12,200.00 of $25,000.00 Donate Now
×
×
  • Create New...