Jump to content
Sign in to follow this  
captain420

Henrik Nielsen's Global AI Ship Traffic for MSFS

Recommended Posts

It's great what you guys are doing to improve the immersion in the sim. Well done all.

  • Like 2

AMD Ryzen 7 5800x3d, MSI X570 Pro, 32 gb DDR4 3600 ram, Gigabyte 6800 16gb GPU, 1x 2tb Samsung  NvMe , 2x 1tb Sabrent NvME, 1x Crucial SSD,

Share this post


Link to post
Share on other sites

Imagine if more of us (myself included) were driven, in more of what we do, by the same level of passion as Henrik and the team...

  • Like 4

Share this post


Link to post
Share on other sites
15 hours ago, KL791 said:

Thanks for the many positive reactions to this; we look forward to take the project to the next level 😄

A gem add-on for MSFS. Thank you!

Share this post


Link to post
Share on other sites

Can someone tell me what I might be doing wrong ?

I've seen this mod working beautifully in the straits of Gibraltar, and around the anchorages of Singapore, with plenty of ships to see. However, I've just flown the length of the Persian Gulf in three stages, including flying over Kharg Island, a major oil terminal, and over the straits of Hormuz, one of the world's busiest shipping lanes - yet I only saw one ship the entire time. It wasn't even an oil tanker, but rather a cruise ship near Oman. My altitude was between 5,000 and 6,500 ft during these flights. I've tried setting traffic at between 5% and 15%, but the sea remains empty.

Any advice would be gratefully received.

Share this post


Link to post
Share on other sites
4 hours ago, Paul K said:

Can someone tell me what I might be doing wrong ?

I've seen this mod working beautifully in the straits of Gibraltar, and around the anchorages of Singapore, with plenty of ships to see. However, I've just flown the length of the Persian Gulf in three stages, including flying over Kharg Island, a major oil terminal, and over the straits of Hormuz, one of the world's busiest shipping lanes - yet I only saw one ship the entire time. It wasn't even an oil tanker, but rather a cruise ship near Oman. My altitude was between 5,000 and 6,500 ft during these flights. I've tried setting traffic at between 5% and 15%, but the sea remains empty.

Any advice would be gratefully received.

Sometimes bgl files don't load... it can happen normally in crowded areas; we eg have several routes in the harbor of Rotterdam, but they show up at random. The same goes for the Suez Channel. This is another argument for moving to real time traffic... In the Persian Gulf you should definitely see more ships than one; do you have LittleNavMap installed? It would reveal ships out of your sight.  The route map below shows the location of routes, but concentration is to the West and in the Hormuz, so depending on where you fly you could avoid ships... Since last time you saw the ships did you do any changes to installation?

22050305430216112917883784.jpg

Share this post


Link to post
Share on other sites
2 minutes ago, KL791 said:

Sometimes bgl files don't load... it can happen normally in crowded areas; we eg have several routes in the harbor of Rotterdam, but they show up at random. The same goes for the Suez Channel. This is another argument for moving to real time traffic... In the Persian Gulf you should definitely see more ships than one; do you have LittleNavMap installed? It would reveal ships out of your sight.  The route map below shows the location of routes, but concentration is to the West and in the Hormuz, so depending on where you fly you could avoid ships... Since last time you saw the ships did you do any changes to installation?

Thank you for the reply 🙂

I do have Little Nav Map installed, but when flying down the Gulf, I didn't have it connected to the sim - it was on a second monitor, purely as reference for VOR and NDB frequencies.

Looking at your screenshot, the flights I did were south-eastwards down the Iranian coast, so your route map explains part of my problem. However, I kept on that south-east heading, and so crossed the straits of Hormuz twice, once towards Oman, then back across to Iran. Looking at that area on your map, I should have seen a lot more than just the one cruise ship.

The only thing that has changed in MSFS since initially installing GAIST is SU9. I've tried altering the ship traffic percentages, of course, but that's all.

Share this post


Link to post
Share on other sites
7 minutes ago, Paul K said:

Thank you for the reply 🙂

I do have Little Nav Map installed, but when flying down the Gulf, I didn't have it connected to the sim - it was on a second monitor, purely as reference for VOR and NDB frequencies.

Looking at your screenshot, the flights I did were south-eastwards down the Iranian coast, so your route map explains part of my problem. However, I kept on that south-east heading, and so crossed the straits of Hormuz twice, once towards Oman, then back across to Iran. Looking at that area on your map, I should have seen a lot more than just the one cruise ship.

The only thing that has changed in MSFS since initially installing GAIST is SU9. I've tried altering the ship traffic percentages, of course, but that's all.

If shipping shows up you might also just have been unlucky with timing over the Hormuz... traffic varies a lot over the day.

Share this post


Link to post
Share on other sites
4 minutes ago, KL791 said:

If shipping shows up you might also just have been unlucky with timing over the Hormuz... traffic varies a lot over the day.

Okay, well my flight sim journey is taking me to Australia, so I hope to see ships in the Malacca Strait - as an ex-seafarer, I know that area is busy all night and all day. Thanks for the mod, and the continued development - real-time traffic sounds very good indeed. 🙂

  • Like 1

Share this post


Link to post
Share on other sites
On 5/3/2022 at 6:00 PM, Paul K said:

Okay, well my flight sim journey is taking me to Australia, so I hope to see ships in the Malacca Strait - as an ex-seafarer, I know that area is busy all night and all day. Thanks for the mod, and the continued development - real-time traffic sounds very good indeed. 🙂

You are welcome 😄 We are working hard on it.

  • Like 3

Share this post


Link to post
Share on other sites

When this be back out of beta then?


James

Share this post


Link to post
Share on other sites
7 hours ago, Phantoms said:

When this be back out of beta then?

The beta basically works as intended - there are a few ships which need to get some texture work and some wakes could be better  but routes and everything works after SU9 so we will take it easy. Probably next version and the DFDS real time add on will be launched in a few weeks, but while some users  had issues under SU9 there are no cricital issues with the Beta right now after SU9 so instead of hurrying with a minor update correcting a ferry and a navy ship we will come with something really ground breaking.

  • Like 6
  • Upvote 1

Share this post


Link to post
Share on other sites
7 hours ago, Phantoms said:

When this be back out of beta then?

The beta basically works as intended - there are a few ships which need to get some texture work and some wakes could be better  but routes and everything works after SU9 so we will take it easy. Probably next version and the DFDS real time add on will be launched in a few weeks, but while some users  had issues under SU9 there are no cricital issues with the Beta right now after SU9 so instead of hurrying with a minor update correcting a ferry and a navy ship we will come with something really ground breaking.

Share this post


Link to post
Share on other sites

With the latest SU9, it seems that with this addon enabled, it causes MSFS to freeze upon launching. I have pinpointed it down to this specific mod, because with it disabled, the sim loads up fine.

  • Like 1

ASUS ROG Maximus Hero XII ▪︎ Intel i9-10900K ▪︎ NVIDIA RTX 3090 FE ▪︎ 64GB Corsair Vengeance RGB Pro ▪︎ Windows 10 Pro (21H1) ▪︎ Samsung 970 EVO Pro 1TB NVME SSD (OS Drive) ▪︎ Samsung 860 EVO 2TB SATA SSD ▪︎ Seagate 4TB SATA HDD ▪︎ Corsair RMx 850W PSU

Share this post


Link to post
Share on other sites

Did I read somewhere that some users had reported that the wakes were angled at 45° since the sim update 9 patch/fix?  I've been away from my PC for a few days, so have been unable to check, though I don't recall noticing anything untoward.


Ryzen 5600X, AM4, 6 Core 12 thread - Nvidia 3080 - 32 Gig DDR4 RAM - Windows 10 64 bit MSFS 2020 Premium Deluxe Edition Resolution 2560 x 1440 (32 inch curved monitor)

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, captain420 said:

With the latest SU9, it seems that with this addon enabled, it causes MSFS to freeze upon launching. I have pinpointed it down to this specific mod, because with it disabled, the sim loads up fine.

I have GAIST Beta installed, and--->I have discovered a work-around simply by accident.    Captain, if you find your load bar freezes at around 40 percent, do the key presses to get to the Task Master, and then close that window...don't end anything...and when you close that window, the Load Bar will continue its advance.   I found this out that as MSFS was frozen at 40 percent (I waiting five minutes to be sure...)  I then wanted to end MSFS using the Task Master.  But wanting to give MSFS one more chance to progress, I didn't end it...merely top right x'ed the Task Master Window closed, and saw the load bar become animated again.  Well..with the next freeze up...I didn't wait one minute...I opened up the Task Master Window...waited five seconds, closed the window...and again,  MSFS's load bar animated to put me at the welcome screen.  So try that...why that works, I have no idea, other than perhaps it is a Windows 'hang' and by calling up the Task Master,   and then merely closing the window...it 'jars' Widows 10/11 to respond...and load out the program.  Is this true...have no idea...but I have done this now four times, when the MSFS load bar stalls at 40 percent load in , and each time I close the Window without doing anything more but calling it up...and then closing it...the MSFS load bar continues to full load.

 

Edited by Sesquashtoo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...