Jump to content

simbol

P3D 5.1 HF1 issues with Clouds

Recommended Posts

Hello all,

Rob Aisncough has just found an issue with Volumetriccloud.cfg, he posted here: https://forums.hifisimtech.com/threads/build-7628-p3d-v5-1-hf1-issues-partial-workaround.13349/#post-59979

He asked me to post this information on AVSIM In case you are experiencing problems with EA clouds, this is what he recommends:

Quote

I think I found the problem and possible work around and it appears to be an LM problem and I've notified them.

None of the Client, Content, Scenery update installers will replace the VolumetricClouds.cfg file for the older P3D V5.1 version with the newer one that contains the [Global] section and possibly other changes.

Delete Generated Files will NOT delete the VolumetricClouds.cfg file.

As a result this entire section is missing from VolumetricClouds.cfg and/or other changes to [Cumulonimbus], [Cirrus], [Stratus], [Cumulus] are not there. The only way to work around this is to manually delete the VolumetricClouds.cfg and then start P3D which will then regenerate this file with the correct sections.

I'm almost certain this is the cause for users indicating "missing" clouds/weather, especially those using HiFi ASP3D. My other concern is there possibly anything else not updating correctly from the installers and/or not being deleted with "Delete Generated Files" (which is a prepar3d.exe command line option)?

[Global]
render_grid_x_km_low = 0.3
render_grid_x_km_med = 0.3
render_grid_x_km_high = 0.2
render_grid_x_km_ultra = 0.15
render_grid_z_km_low = 3.0
render_grid_z_km_med = 3.0
render_grid_z_km_high = 3.0
render_grid_z_km_ultra = 3.0
cloud_resolution_low = 256
cloud_resolution_med = 512
cloud_resolution_high = 512
cloud_resolution_ultra = 768
max_cloud_distance_km_low = 200
max_cloud_distance_km_med = 250
max_cloud_distance_km_high = 300
max_cloud_distance_km_ultra = 350
num_slices_low = 128
num_slices_med = 128
num_slices_high = 128
num_slices_ultra = 128
cloud_shadow_strength = 1.5
cloud_shadow_range_km_low = 100.0
cloud_shadow_range_km_med = 175.0
cloud_shadow_range_km_high = 250.0
cloud_shadow_range_km_ultra = 300.0
cloud_shadow_texture_size_low = 256
cloud_shadow_texture_size_med = 512
cloud_shadow_texture_size_high = 1024
cloud_shadow_texture_size_ultra = 2048
crepuscular_ray_strength = 1.0
edge_noise_wavelength_km = 2.5
worley_texture_size = 64
cell_noise_wavelength_km = 2.7
max_fractal_amplitude_km = 3
cloud_threshold_distance_km = 0.2

This entire section is missing, such that ONLY a full clean install of P3D will get the correct VolumetricClouds.cfg.

WORK AROUND is to manually delete VolumetricClouds.cfg location example: C:\Users\Rob\AppData\Roaming\Lockheed Martin\Prepar3D v5
 

Hope this helps someone.

Regards,

Simbol

  • Like 4

Share this post


Link to post
21 minutes ago, simbol said:

Hello all,

Rob Aisncough has just found an issue with Volumetriccloud.cfg, he posted here: https://forums.hifisimtech.com/threads/build-7628-p3d-v5-1-hf1-issues-partial-workaround.13349/#post-59979

He asked me to post this information on AVSIM In case you are experiencing problems with EA clouds, this is what he recommends:

Hope this helps someone.

Regards,

Simbol

It does not solve it entirely for everyone. I think we have different issues for those who have no clouds.. I did check this also and have the updated version also created after deleted the prior one. Clouds will not reload with ASP3D.....they disappear and come not back all though they should regarding metar. Damian is aware of certain issues as well. 

So for some users not having any clouds at all it may be the cause and solution. But there are further issues with reloading weather with ASP3D as well. 

Marcus

Edited by mpo910

Share this post


Link to post

I've done a full clean install. With EA on, cloud resolution at medium, x4MSAA on a 4k screen, when I look off to the side up at altitude, I am seeing a pixelated scene around all the clouds. Do others see this behavior? I am using latest HiFi with that program controlling the cloud cfg file and a flight plan loaded.

Edited by B777ER

Eric 

 

 

Share this post


Link to post
3 minutes ago, B777ER said:

I've done a full clean install. With EA on, cloud resolution at medium, x4MSAA on a 4k screen, when I look off to the side up at altitude, I am seeing a pixelated scene around all the clouds. Do others see this behavior? I am using latest HiFi with that program controlling the cloud cfg file and a flight plan loaded.

I do see more pixelated clouds with that combo as before this HF1 update. Yes. Have posted this at HiFi and LM support both.

HiFi has to make some changes within their own cloud config with ASP3D. Therefore you should check the box in ASP3D options "Disable aps3d cloud config" if I recall this checkbox name correctly so ASP3D will use the sim cloud config file instead. 

Share this post


Link to post
Just now, mpo910 said:

I do see more pixelated clouds with that combo as before this HF1 update. Yes. Have posted this at HiFi and LM support both.

HiFi has to make some changes within their own cloud config with ASP3D. Therefore you should check the box in ASP3D options "Disable aps3d cloud config" if I recall this checkbox name correctly so ASP3D will use the sim cloud config file instead. 

Good info.  So if I left it unchecked and now ASP3D has modified it, should I check that setting in the ASP3D UI, delete the cloud cfg and let P3D rebuild it?


Eric 

 

 

Share this post


Link to post

No. Uncheck it and ASP3D will use its own parameters to create clouds. Check it and ASP3D will use the sim ones to create clouds with those parameters. 

You do not have to delete anything. 

Marcus

Share this post


Link to post

Thanks @simbol 
The Global section was also missing on my end. Last complete reinstall of P3D was when 5.0 came out. The following updates I did with the component installers. After deleting the VolumetricClouds.cfg and starting P3D the global section is there

Edited by BestPlane

Manuel Miller

Share this post


Link to post
37 minutes ago, mpo910 said:

No. Uncheck it and ASP3D will use its own parameters to create clouds. Check it and ASP3D will use the sim ones to create clouds with those parameters. 

You do not have to delete anything. 

Marcus

Makes no difference, using LM's or ASP3D, both show a lot of cloud pixelation when viewing them. This was on a fresh install so I don't have the issue Rob mentions. Just looks like word not allowed with EA on.


Eric 

 

 

Share this post


Link to post

Good find. I had the file at 7kb and by deleting it it came back to 9k.

I didn<t have clouds missing before, but now it is definitely different for the better.

Not tested enough yet.

 


Pierre

Share this post


Link to post

I checked my VolumetricClouds.cfg and I don't have this global section. Should I just copy and paste this into my cfg? Or delete the cfg? Also what does this global section fix/add?

Share this post


Link to post
12 minutes ago, Joseph29 said:

I checked my VolumetricClouds.cfg and I don't have this global section. Should I just copy and paste this into my cfg? Or delete the cfg? Also what does this global section fix/add?

What I did was execute the file "Delete Generated files" and it seems that that deleted all the files that I had with the previous version and new ones were generated where it includes the data from the VolumetricClouds.cfg section.

Now I have clouds with EA on, but the clouds have patterns and pixels, when I zoom in on them.

Share this post


Link to post

Please report at LM about the quality of clouds. They need your feedback so they can make further adjustments. Otherwise they think it is all ok now. Which is obviously not the case.  

Marcus

Share this post


Link to post

Howdy. I’m a long time flight simmer and stalker of various forums, and first time poster here. After updating all my P3D components to 5.1 HF1, I was still quite underwhelmed by the EA experience. That was until I took Simbol’s advice and deleted the VolumetricClouds.cfg file and BAM - what a dramatic and completely changed EA experience. Large voluminous clouds with structure that towered above my flight level, storms, multiple cloud layers etc ... very immersive for my humble tube-liner needs. Clearly there is work remaining, eg. the Mars sunset that also makes distant mountains look weird (much lighter than the foreground) and clouds that disappear (but shouldn’t) over time, but P3D, EA and Active Sky are all moving in the right direction and I thank LM and HIFI for their ongoing hard work.

  • Like 3

Share this post


Link to post

Re pixelated clouds. - change the cloud resolution in the volumetric cloud config to:

[Global]
cloud_resolution_ultra=1024 

  • Upvote 1

Intel 10900k @ 5.1 HT on, Nvidia 3090, 32GB RAM @3800mhz, 1TB NVME Drive (P3Dv5.1), 1440p 48' Ultrawide Monitor.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    33%
    $8,485.00 of $25,000.00 Donate Now
×
×
  • Create New...