Jump to content

Sign in to follow this  
jmhelms

1.12.13 Hangs at "New Activities " Page

Recommended Posts

Running (or trying to) 1.12.13 on powerful gaming computer 

under W-10 (fully update) ....Store install initially...

downloaded  1.12.13 yesterday afternoon...

the D/L hung halfway through...I exited the program, restarted,

and the D/L resumed and installed (I think) successfully...started MSFS and it eventually 

loaded...there was a long lag somewhere that I did not pinpoint....

This morning tried to load 1.12.13....it now hangs on the "New Activities"

page...before the upgrade to 1.12.13 MSFS ran perfectly...

Any help appreciated...

Thanks, John H.

Share this post


Link to post
Share on other sites

I suppose you have disabled any mods in community folder already? You can do that by renaming the community folder for a test. If MSFS now works, name it back to Community, rebooting the computer and try again (unbelievable but this often works for me). If it doesn't then I rename the Community again and move one half of the files back to a new Community each time to find the culprit mod. 90%+ a modification is the gremlin preventing MSFS booting or MSFS CTD while playing the sim.

  • Like 1

AMD Ryzen5 3600 cpu, 2060 SUPER gpu, 600 Watt Gold Thermaltake psu, 2K 32" Sceptre curved monitor, 16 GB RAM. Entire system including monitor under $1400 iBuyPower (IBP brand had best user reviews at BestBuy).

Share this post


Link to post
Share on other sites

Thanks Fielder for the prompt and detailed reply...

will try your solution and report back...think I even 

saw something in the update install about that...humm

Happy Holidays!

John H.

 

 

Share this post


Link to post
Share on other sites

I’m getting this too and beginning the process of identifying the bad add on, a few mods at a time.

I’ve narrowed it down to one of a small handful of otherwise very nice Seattle-area freeware sceneries that previously worked fine.

Perhaps we can report back our culprits to save each other time in elimination (I’ve not even tried my Europe collection yet, but all payware seems fine for Me)

Steve

Share this post


Link to post
Share on other sites

If you are talking about the last screen you see before you load into the main menu, then I had a similar problem last night.  I also noticed that there was continuous network traffic through the fightsim.exe process.  Long story short, I spent the morning doing a lot of debugging and, at least in my case, pinned the issue down to a scenery with an apostrophe in its name causing an error in a remote API that the sim is calling when it starts up due to bad escaping.

Check to see if you have any mods active with a ' in the directory name and if so remove them, and see if that works.

This was the thread i posted earlier today on the official forum about my problem:

https://forums.flightsimulator.com/t/startup-hang-caused-by-apostrophe-in-scenery-name/339695

It seems as though there may be several related issues:

https://forums.flightsimulator.com/t/stuck-on-start-screen-loading-screen-stuck-between-flight-and-main-screen-after-update-1-12-13-0/339193

 


Rob Jones, Lead DeveloperWorking Title Simulations

 

Share this post


Link to post
Share on other sites

So the sim phones home to Microsoft with a complete list of every addon scenery we are using every time we run it?  Figures.


AMD 3950X | 64GB RAM | AMD 5700XT | CH Fighterstick / Pro Throttle / Pro Pedals

Share this post


Link to post
Share on other sites
6 minutes ago, Republic DC9 said:

I’ve narrowed it down to one of a small handful of otherwise very nice Seattle-area freeware sceneries that previously worked fine.

The San Juan Islands?  If so, rename the "wookie042-sinclair's-secret-airstrip-sji6" to "wookie042-sinclairs-secret-airstrip-sji6".


Rob Jones, Lead DeveloperWorking Title Simulations

 

Share this post


Link to post
Share on other sites
5 minutes ago, marsman2020 said:

So the sim phones home to Microsoft with a complete list of every addon scenery we are using every time we run it?  Figures.

It seems to, yes.   I didn't think to save the content of the non-error responses to those search requests, and I'm mid-flight now or I'd start it up and check again.   But either tonight or tomorrow if you're interested (and don't beat me to it) I can set up my mitm proxy again and see what the responses to good requests look like.  They didn't seem to be anything overly interesting, though, from what I recall.

FWIW, this seems to be the API they're interacting with:  https://docs.microsoft.com/en-us/gaming/playfab/api-references/

What I found entertaining was that this Azure API is running in AWS.  😁

Edited by kaosfere

Rob Jones, Lead DeveloperWorking Title Simulations

 

Share this post


Link to post
Share on other sites

I certainly get that there is information that needs to be transmitted for a modern online game (like if I'm flying an add-on aircraft, I ran into someone else flying a Savage Carbon the other day and it was pretty neat, so obviously they need to know what aircraft you're flying), but since the overlay of scenery addons on top of the streamed world occurs locally it seems on at a first glance to me for it to be unnecessary for this to be transmitted. 

Maybe there is some kind of matchmaking functionality to it, like if I install a Meigs field addon and go sit on the runway, and someone else doesn't have Meigs field installed, it prevents them from seeing my aircraft sitting in the middle of the park where the runway used to be?

Edited by marsman2020

AMD 3950X | 64GB RAM | AMD 5700XT | CH Fighterstick / Pro Throttle / Pro Pedals

Share this post


Link to post
Share on other sites
1 hour ago, kaosfere said:

The San Juan Islands?  If so, rename the "wookie042-sinclair's-secret-airstrip-sji6" to "wookie042-sinclairs-secret-airstrip-sji6".

Nope....didn't have that one installed - looks cool though thank you! 🙂

Steve

Share this post


Link to post
Share on other sites

"Thanks Fielder for the prompt and detailed reply...

will try your solution and report back...think I even 

saw something in the update install about that...humm

Happy Holidays!

John H."

 

Thanks a bunch Fielder (and all)... this trick fixed the loading problem...

now to figure out the gremlin that caused the problem...thanks to all the others

about the debugging ideas....I do not have the San Juan Is scenery...

Happy Holidays to all...

John H

Share this post


Link to post
Share on other sites

C152x mod is my issue . Removed it and everything is fine . The C152x mod is also the cause of content folder not showing or updating . Remove the c152x mod and everything is ok . I like the c152 mod but it causes issues . 

 

Dazza

Share this post


Link to post
Share on other sites

Wow, DBoy....great eye/find!...that mod was what was causing all

my problems...thanks for reporting it!....

Happy Holidays to all...

John H.

Share this post


Link to post
Share on other sites

In my troubleshooting, I also found the Hong Kong Int'l 

addon caused a problem...I believe it's called "VHHH-scenery"...

I'd like to highly  recommend the "MSFS AddOn Linker"...

found here: 

https://flightsim.to/file/1572/msfs-addons-linker

Once properly setup, it greatly simplifies troubleshooting the 

MSFS Community folder...you can selectively turn off and on

the contents of the Community folder without having to delete

items therein or use "dummy" Community folders......

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...