Jump to content
Sign in to follow this  
nosaj_armstrong

Autopilot Not working (Hard turns to right/left)

Recommended Posts

Hi All!

 

I wanted to bring this up in hopes of getting some ideas/solutions as my searches and ideas found in this and the MSFS forums have been futile. Ever since the last update the A320 Autopilot is essentially unusable. Out of nowhere it will start a hard right to turn leading to a dive. The only way to recover is turn the AP off. 

 

I haven't tested other aircraft, but this happens in default, FBW Stable, Dev and CFBW. I have Both TCA SideStick and Throttle and 'think' those could be causing the issue but I am unsure. I've left both controllers to default and just modified a few buttons but haven't touched the sensitivity settings. I've tried setting the deadzone to 10% and 15% as suggested by some with no change.  I've tried utilizing both Modern and Legacy Flight Models. 

At first I thought it was the FBW A320 and posted there for support but it's definitely not the mod as it happens with default.

Here is a video of essentially what happens to me: https://github.com/flybywiresim/a32nx/issues/2836#issuecomment-753857726

I was wondering if anyone had any ideas or solutions? 

  • Upvote 1

Share this post


Link to post
Share on other sites

I've had that issue in the Carenado Seminole. 

But I figured it's only happening if I've activated AP while on the ground. If I wait with AP until I'm airborne, it doesn't happen.

I thought it was the Seminole being quierky. It's the same behavior as you describe, instant turn to the right and diving. 


R9 5900X | RTX 3090 | 64 GB 3600 | 3440x1440 G-Sync | Logitech Pro Throttles Rudder Yoke Panels | Thrustmaster T.16000M FCS | TrackIR 5 | Oculus Rift S
Experience with Flight Simulator since early 1990s

Share this post


Link to post
Share on other sites
Posted (edited)

Thank you for your response. The AP isn't activated when on the ground but the FD is on the A320. Tested taking off without FD on, same problem. 

Edited by nosaj_armstrong

Share this post


Link to post
Share on other sites

Same problem with my first flight since today's update, but with the King Air. I set AP once I was airborne and all was well for the first handful of minutes until it failed to make a shallow turn between waypoints and alternated between near 90 degree turns to left and right until I switched the AP off.


OS:     Win10 Home
Mobo: MSI MAG X570 Tomahawk Wifi; CPU: AMD Ryzen 5 3600 (Matisse) 3.6 GHz
RAM: Corsair Vengeance DDR4 32Gb (2x 16GB) 3600 MHz.GPU:  MSI Radeon RX 5700XT [8GB]
SSD:  Corsair Force MP510 (for OS);  2x 1TB Sabrent Rocket Nvme PCIe 4.0 (one for sim, one for scenery)
HDD:  Seagate 3TB (for Data); Seagate 1TB (for other Programs), ASUS TUF Gaming VG32VQ1B Curved 31.5" monitor, 1440p, 38Mbs ethernet

Share this post


Link to post
Share on other sites
2 hours ago, Republic3D said:

But I figured it's only happening if I've activated AP while on the ground. If I wait with AP until I'm airborne, it doesn't happen.

Agrees with my experience from early on after initial release.  I encountered it on my very first flight and several times after that until I caught on.  In fairness I was studying and learning the MSFS G1000 and did not realize I was activating the autopilot on the ground as I played around with it.  Lesson learned.  Hope that is the issue he is reporting, as that is easy to avoid.


Frank Patton
MasterCase Pro H500M; Z490 WiFi MOB; i7 10700k 3.8 Ghz; H100i Pro; 32GB DDR4 3600; RTX 3070 TI 8GB; Gold RMX850X PSU; ASUS VG289 4K 27"
Honeycomb Alpha & Bravo, Crosswind 3's w/dampener.  
Former USAF meteorologist & ground weather school instructor. AOPA Member #07379126
                       
"I will never put my name on a product that does not have in it the best that is in me." - John Deere

Share this post


Link to post
Share on other sites
Posted (edited)
5 minutes ago, fppilot said:

Agrees with my experience from early on after initial release.  I encountered it on my very first flight and several times after that until I caught on.  In fairness I was studying and learning the MSFS G1000 and did not realize I was activating the autopilot on the ground as I played around with it.  Lesson learned.  Hope that is the issue he is reporting, as that is easy to avoid.

In my case the AP isn't activated until after take off. What I notice when it happens is the flight Director is trying to correct but the aircraft is not responding. 

Edited by nosaj_armstrong

Share this post


Link to post
Share on other sites

I think it’s related to my controllers (TCA throttle and side stick) I’m going to try a flight without then plugged in and see how it goes. 

Share this post


Link to post
Share on other sites
Posted (edited)

Might need to mess with your dead zone, the aircraft reacts to any movement direction even if it's a very very tiny amount which can cause your plane to start listing.

Edited by Tuskin38

Share this post


Link to post
Share on other sites
1 hour ago, Tuskin38 said:

Might need to mess with your dead zone, the aircraft reacts to any movement direction even if it's a very very tiny amount which can cause your plane to start listing.

I’ve gone up as high as 20 or 25. Any suggestions on settings?

Share this post


Link to post
Share on other sites
22 hours ago, nosaj_armstrong said:

I think it’s related to my controllers (TCA throttle and side stick) I’m going to try a flight without then plugged in and see how it goes. 

Did you notice any difference?

I don't have the TCA Sidestick, but I have the Thrustmaster 16000m FCS, which is the same stick. 

 


R9 5900X | RTX 3090 | 64 GB 3600 | 3440x1440 G-Sync | Logitech Pro Throttles Rudder Yoke Panels | Thrustmaster T.16000M FCS | TrackIR 5 | Oculus Rift S
Experience with Flight Simulator since early 1990s

Share this post


Link to post
Share on other sites

I haven’t tried it yet but I read somewhere to ensure to key bindings were associated to flight controls. I removed all keyboard associations to all flight controls and tested a flight and it happened again. It happened when I was adding/modifying a STAR though I’m not sure if that is relevant. I was able though to disconnect the AP correct the role stabilize and re enable the AP and the flight continued and was able for the first time in a while complete the flight. 
 

I’m testing another flight right now to see if it happens again and I will then test one without any flight controllers plugged in. If it happens again without my TCA side stick and throttle plugged in then there is defenitlyw something wrong with the AP. I’ve tried default, and all FBW versions and tested using and not using SimBrief integration and it happened every time. At this point it’s either a bug on the AP or my controllers. I’ll report once I test without controllers. 

Share this post


Link to post
Share on other sites

Im having the same problem with the autopilot. I have noticed that the rudder is indicating hard to the left. When you try to trim the rudder back the aircraft goes into a spiral dive.

I just setup a simple flight YSSY-YMML. The aircraft climb ok autothrottle worked ok but would not track on NAV mode. I used the heading bug and disengaged FD to regain course. At toc I re engaged NAV mode and it held course and all was good until i turned on the FD again the aircraft banked left and then stayed there.

 

 

Edited by Taurasjf

Share this post


Link to post
Share on other sites

What I've started to do is fly old fashioned (back to my 172 CX days) where I fly in HDG mode and just track each fix one at a time. LNAV tracking is busted, especially for STARs.


Rules of Wisdom:
Take-offs are optional, landings are mandatory.
The only time you have too much fuel is when you're on fire.
To make a small fortune in aviation you must start with a large fortune.

There's nothing less interesting than the runway behind you and the space above you.

Share this post


Link to post
Share on other sites

You want Modern flight model for sure.

You just need enough deadzone to ensure that your stick is outputting '0' for pitch and yaw when you have released it.  You can see what each axis is doing based on the circle which follows the curve as you deflect it in the Sensitivity settings.

Have you fully deflected your controls through their range prior to takeoff?  I've had some oddness when I haven't done this.


AMD 3950X | 64GB RAM | AMD 5700XT | CH Fighterstick / Pro Throttle / Pro Pedals

Share this post


Link to post
Share on other sites

I have been going to settings after I load into a flight, unplugging my saitek yoke system, listen for sound telling me its unplugged(windows sound), plug back in. Centers everything so I can fly straight. I have to do this every time I load into msfs. My calibration won't save after the dec. update. 


Anthony

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...