Jump to content
Sign in to follow this  
Phantoms

Use default logitech drivers while running spad?

Recommended Posts

I got my Class Echo up and running (it's great btw) for MSFS. It requires Spad.next to function.

I have a Logitech throttle quadrant along with Logitech Switch and Multi panels. I'm perfectly happy with Logitech's drivers and would like to keep using them instead of using spad to control them. However, spad interferes with the logitech drivers and using the panels. In addition to causing issues with the panels, it has constant popup warnings about using the logitech drivers.

Is it possible to turn off logitech support and warnings in spad and let the actual Logitech drivers prevail? If so, could someone point me to how?


James

Share this post


Link to post
Share on other sites

Could be interesting to consider keeping only spad. I’m new to spad but I had it up and running with default profiles quite rapidly yesterday. And you benefit from nice plus like button acceleration (usefull for large changes in headind, altitude, crs etc). The radio panels switch button also has a standard function in the nav position to turn on audio identification of the nav frequency on a long press (500 ms). So some interesting functionality readily available if you made the purchase.

 


Pierre

P3D when its freezing in Quebec....well, that's most of the time...
C-GDXL based at CYQB for real flying when its warming up...

Share this post


Link to post
Share on other sites

The purpose of SPAD is to replace the Logitech drivers (as well as provide a heck of a lot of features that Logitech doesn't provide).  My feeling: delete the Logitech drivers.  You have so many more options with SPAD.

Share this post


Link to post
Share on other sites

Yea, dump the Logitech drivers.  I’ve been running only spad for several years.


Kent

i7 4790k @4.7Ghz 32Gb DDR3 1333 RTX 2070 GPU Win10 Pro

Share this post


Link to post
Share on other sites

Yes, I never get my Backlightpanel running by Logitech or Saitek drivers.

Only by Spad and Spad next. Delete the driver and never installed again.

All is running perfect

Edited by sal9000

Stephan from Germany

 

My System

Share this post


Link to post
Share on other sites

I figured out how to do this.

 

In Spad you have to go to Settings, then Devices, then to each Saitek Device and set the support to Off.

Next, when in game with Spad running, when you get the Logitech warnings you have to click "do not show again".

 

Now with Spad running it will not interfere with the Logitech drivers in MSFS.

Edited by Phantoms

James

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...