Jump to content

Sign in to follow this  
BWBriscoe

Refresh rates / stutters etc.

Recommended Posts

12 hours ago, sho69607 said:

Setting my sim to 30fps results in rough camera panning and a non fluid experience altogether. So basically stutters with free sync or slow/laggy camera panning are what I have to choose from. Also setting my fps to 30 internally causes my fps to dip even lower.

Spencer, what you can also try (to achieve smooth fluid performance) is another way of syncing to refresh rate by using freeware MSI Afterburner w/ RivaTunerStatisticsServer.  With RTSS you can, if you have a monitor capable of 60hz refresh for example, use a divisor of 2 to result syncing at half the screen's rate of 60Hz, so 30fps.  As Ray mentioned it's critical to NOT limit frames w/in P3D but leave that at UNLIMITED.  I saw a photo of your screen's software and it appears it can be set to 60Hz.   I have found this practically matches performance w/ vsync to 30Hz screen w/ the only difference being your CPU/GPU are still being asked to render to more pixels even though post-processing it becomes limited w/ a software vsync.  I think you would leave freesync and gsync off to KISS.

An even simpler approach is to use nV Control Panel's Adaptive Vsync set to half refresh, but not sure how that approach compares to the other two.  I am 100% confident one can expect fluid performance provided your system can maintain at least 30fps w/ the frame rate slider at UNLIMITED.  Of course you can dial back settings to achieve that.

  • Like 1

Noel

System:  9900K@5.0Ghz@1.21v all cores, MSI MPG Z390M GAMING EDGE AC, Noctua NH-D15S, Corsair Vengeance 32Gb LPX 3200mHz DDR4, Sabrent NVme 2Tb x 2, RTX 2070 Super FE, Corsair RM 850W PSU, Win10 Pro, Dell curved 3440x1440, Saitek Yoke, TQ & Cessna Trim Wheel, UNLIMITED frames vSync to 30Hz in P3D 4.5 & MSFS.

 

Share this post


Link to post
10 hours ago, Noel said:

Spencer, what you can also try (to achieve smooth fluid performance) is another way of syncing to refresh rate by using freeware MSI Afterburner w/ RivaTunerStatisticsServer.  With RTSS you can, if you have a monitor capable of 60hz refresh for example, use a divisor of 2 to result syncing at half the screen's rate of 60Hz, so 30fps.  As Ray mentioned it's critical to NOT limit frames w/in P3D but leave that at UNLIMITED.  I saw a photo of your screen's software and it appears it can be set to 60Hz.   I have found this practically matches performance w/ vsync to 30Hz screen w/ the only difference being your CPU/GPU are still being asked to render to more pixels even though post-processing it becomes limited w/ a software vsync.  I think you would leave freesync and gsync off to KISS.

An even simpler approach is to use nV Control Panel's Adaptive Vsync set to half refresh, but not sure how that approach compares to the other two.  I am 100% confident one can expect fluid performance provided your system can maintain at least 30fps w/ the frame rate slider at UNLIMITED.  Of course you can dial back settings to achieve that.

Alright making progress, but with vsync off and using RTSS, I am getting massive screen tearing now. It is my understanding that RTSS will not work with vsync on, so something else must be causing this, right?


~Spencer Hoefer

MOBO: Gigabye Aorus z590 elite | CPU: Intel i9-10900k  | RAM: GSKILL RIPJAWS 32GB DDR4 3200 |GPU: Nvidia RTX 2080Ti 11GBOS: Windows 10 

Share this post


Link to post

Spencer, are you using only the 'global' settings in NCP, or a profile for P3D/MSFS?  And I assume you did check in NCP to see if 30Hz was in fact not an option?  Freesync/Gsync off?  You should not have any significant screen tearing w/ this approach.  I will send a couple of screen shots in a few minutes on how RTSS should be set up as there is a spot that is may not be intuitive.  Have you used RTSS before?


Noel

System:  9900K@5.0Ghz@1.21v all cores, MSI MPG Z390M GAMING EDGE AC, Noctua NH-D15S, Corsair Vengeance 32Gb LPX 3200mHz DDR4, Sabrent NVme 2Tb x 2, RTX 2070 Super FE, Corsair RM 850W PSU, Win10 Pro, Dell curved 3440x1440, Saitek Yoke, TQ & Cessna Trim Wheel, UNLIMITED frames vSync to 30Hz in P3D 4.5 & MSFS.

 

Share this post


Link to post

You should be set up like this.  I have no screen tearing at all w/ my monitor at 60Hz, and that is with vsync on or off in-sim, P3D.  I have a rock solid 30fps w/ excellent animation smoothness and freedom from preventable stutters.  (ie, not the longer pauses from P3D loading a giant scenery tile all at once)

RTSS-2.png


Noel

System:  9900K@5.0Ghz@1.21v all cores, MSI MPG Z390M GAMING EDGE AC, Noctua NH-D15S, Corsair Vengeance 32Gb LPX 3200mHz DDR4, Sabrent NVme 2Tb x 2, RTX 2070 Super FE, Corsair RM 850W PSU, Win10 Pro, Dell curved 3440x1440, Saitek Yoke, TQ & Cessna Trim Wheel, UNLIMITED frames vSync to 30Hz in P3D 4.5 & MSFS.

 

Share this post


Link to post
10 hours ago, Noel said:

Spencer, are you using only the 'global' settings in NCP, or a profile for P3D/MSFS?  And I assume you did check in NCP to see if 30Hz was in fact not an option?  Freesync/Gsync off?  You should not have any significant screen tearing w/ this approach.  I will send a couple of screen shots in a few minutes on how RTSS should be set up as there is a spot that is may not be intuitive.  Have you used RTSS before?

No I have it set specifically for P3D and not global. Freesync, which is a monitor feature, is turned off. This also removes the gsync options in NCP so I am assuming that gets turned off with free sync disabled. If I turn on Vsync in P3D the screen tearing stops, but I’m assuming that also prevents RTSS from working correctly. I will recheck my settings and report back if there are issues. Maybe I missed a step.


~Spencer Hoefer

MOBO: Gigabye Aorus z590 elite | CPU: Intel i9-10900k  | RAM: GSKILL RIPJAWS 32GB DDR4 3200 |GPU: Nvidia RTX 2080Ti 11GBOS: Windows 10 

Share this post


Link to post

Well for me, no tearing whatsoever using RTSS w/ or w/o vsync in-sim.  Perhaps you might duplicate my NCP settings, which I do on the global tab.  If you want I can send a screen shot.

If you're seeing a solid 30fps then RTSS x/2 -1 should be working if your screen is at 60Hz and you're set up to be able to generate at least 30fps.  One of the downsides of using RTSS over vsync to 30Hz screen is you can't really tell how close to being truly maxed out w/ re to GPU and/or CPU utilization, because it's always trying to render the maximum number of frames possible.  With vysnc to 30Hz you canor both that's the problem because w/ vsync to 30Hz you only create what's needed at any moment in time.

Does it fix the stuttering you mentioned at the beginning of this discussion?


Noel

System:  9900K@5.0Ghz@1.21v all cores, MSI MPG Z390M GAMING EDGE AC, Noctua NH-D15S, Corsair Vengeance 32Gb LPX 3200mHz DDR4, Sabrent NVme 2Tb x 2, RTX 2070 Super FE, Corsair RM 850W PSU, Win10 Pro, Dell curved 3440x1440, Saitek Yoke, TQ & Cessna Trim Wheel, UNLIMITED frames vSync to 30Hz in P3D 4.5 & MSFS.

 

Share this post


Link to post
Posted (edited)
3 hours ago, Noel said:

Well for me, no tearing whatsoever using RTSS w/ or w/o vsync in-sim.  Perhaps you might duplicate my NCP settings, which I do on the global tab.  If you want I can send a screen shot.

If you're seeing a solid 30fps then RTSS x/2 -1 should be working if your screen is at 60Hz and you're set up to be able to generate at least 30fps.  One of the downsides of using RTSS over vsync to 30Hz screen is you can't really tell how close to being truly maxed out w/ re to GPU and/or CPU utilization, because it's always trying to render the maximum number of frames possible.  With vysnc to 30Hz you canor both that's the problem because w/ vsync to 30Hz you only create what's needed at any moment in time.

Does it fix the stuttering you mentioned at the beginning of this discussion?

If you could that would be great. Still getting lots of screen tearing but only in the VC view (in this case the PMDG 777). If I switch to external there is no screen tearing. It is most noticeable during turns and when looking out at the sky. The good news is the stutters seem to have stopped.

Edited by sho69607

~Spencer Hoefer

MOBO: Gigabye Aorus z590 elite | CPU: Intel i9-10900k  | RAM: GSKILL RIPJAWS 32GB DDR4 3200 |GPU: Nvidia RTX 2080Ti 11GBOS: Windows 10 

Share this post


Link to post

Stutters are here when you change cockpit light intensity by turning knobs


Frédéric Giraud

Share this post


Link to post
8 hours ago, grandfred29 said:

Stutters are here when you change cockpit light intensity by turning knobs

This is a fundamental defect of the engine I'm afraid.


Noel

System:  9900K@5.0Ghz@1.21v all cores, MSI MPG Z390M GAMING EDGE AC, Noctua NH-D15S, Corsair Vengeance 32Gb LPX 3200mHz DDR4, Sabrent NVme 2Tb x 2, RTX 2070 Super FE, Corsair RM 850W PSU, Win10 Pro, Dell curved 3440x1440, Saitek Yoke, TQ & Cessna Trim Wheel, UNLIMITED frames vSync to 30Hz in P3D 4.5 & MSFS.

 

Share this post


Link to post

Did you guys finally resolved the stuttering issue? I had my P3D stutter-free (mostly) back in v4.x and 5.0 days, but with the current release I simply do not get to this point anymore and I wonder why. 

First off, it is exetremely important to line out what kind of stutter I observe: I am not (!) talking about irregular stutters occurring when things get loaded in the sim, when approaching big hubs, when the load of the sim is so big that FPS drop below 25 and so on, what I struggle with are extremely regular stutters every 2-3 seconds. They are also hardly visible on the FPS counter, as they are too short to have an effect. While I almost not notice them if the overhead above my 30FPS cutoff is big enough, for example on small airfields or rural areas, they are extremely annoying on big hubs like LEMD or EDDF. Although FPS stay above 25, mostly even at my locked 30, these stutters are just killing immersion. Most obvious they are when I move the camera fast around the 3rd person view of the plane, then it is really like a regular metronome, every 3 seconds a short stutter.

Now, back in v4.x and 5.0 days I was pretty sure that switching off G-sync exclusively for P3D did the trick. But in 5.1, this does not eliminate those stutters. I already tried a hell lot of a things, but I simply do not understand why I had no issues in v4.x and 5.0, but obviously cant get rid of those stutters in v5.1. 

I already tried vsync on/off, limiting the FPS internally to 30, 60 or unlimited, limiting the FPS externally to 30, 60 or any other number somehow matching my 144Hz monitor, I tried limiting the monitor to 60 or 120H and using above internal or external limiters, I tried with G-Sync globally off or only specifically off for P3D. Nothing helps. Those bloody regular stutters remain. 

I did also check that everything running with P3D and P3D itself is defined as exception in antivirus, I checked that FSUIPC autosave is off, I checked that there is no simclient of Navigraph running etc. Nothing obvious. Stutters remain. 

I am lost, what else could I try?


Greetings, Chris

Intel i7-8700K@5.0GHz, 2x16GB 3200MHz CL14 RAM, Gigabyte AORUS 1080Ti, Windows 10 Home 64bit, Prepar3D 4.5

Share this post


Link to post
1 hour ago, AnkH said:

Did you guys finally resolved the stuttering issue? I had my P3D stutter-free (mostly) back in v4.x and 5.0 days, but with the current release I simply do not get to this point anymore and I wonder why. 

First off, it is exetremely important to line out what kind of stutter I observe: I am not (!) talking about irregular stutters occurring when things get loaded in the sim, when approaching big hubs, when the load of the sim is so big that FPS drop below 25 and so on, what I struggle with are extremely regular stutters every 2-3 seconds. [...]then it is really like a regular metronome, every 3 seconds a short stutter.

Hmm... it would be interesting to see if anyone else suffers from this.
I too have noticed regular stutters every 2-3 seconds with P3D v5.1.

I had assumed that it was just my PC (maybe it is, if no-one else notices this problem).
My initial thoughts were to remove the factory OC of my GPU, not use the OC boost (PBO) on my Ryzen CPU and ensure that *all* P3D folder locations were excluded from AV checking. None of thess actions made any difference.

I may need to do a fresh install of Win 10, since my PC is 4 years old and I've definitely had a couple of issues with Win updates during this time.
 


Ryzen 3700X 4.4GHz(PBO); ASUS GTX 1070 O8G; Gigabyte AB350 Gaming-3; 32GB Corsair 3200 MHz; ASUS VG35VQ 35" (3440x1440)
Fulcrum Sim yoke; Thrustmaster TCA Sidestick and Throttle Airbus edition; MFG Crosswind rudder pedals; CP Flight MCP 737; Logitech FIP x2; TrackIR

P3Dv5.1 + FS Global Ultimate NG + ORBX + MSE + ActiveSky + ChasePlane + AILRP + FS-ATC Chatter + FFTF Dynamic + Self Loading Cargo + WIN 10 Pro
PMDG 737 777; QW 787; AS A320 A330; MJC Dash 8; A2A C172 PA-28; Carenado A42 A72 XL560; FT E-Jets v3; QW 757; JF C152

Share this post


Link to post

Well, the puzzling thing in my case is that I was able to remove those regular stutters in earlier versions but I fail to do so in v5.1...


Greetings, Chris

Intel i7-8700K@5.0GHz, 2x16GB 3200MHz CL14 RAM, Gigabyte AORUS 1080Ti, Windows 10 Home 64bit, Prepar3D 4.5

Share this post


Link to post
On 2/25/2021 at 9:21 AM, sonny147 said:

I tried the 30hrz thing once , i just could not live with a laggy/slow mouse lol 

Same for me.  However, just a question.  If I change my monitor to 30hz, should I also limit my frames in Nvidia Control Panel?  I did notice less than smooth flights when I limited to 30hz...but I ALSO limited my frames in NCP to 30.  Perhaps if I don't limit in NCP and leave it at UNLIMITED in the sim, I might be able to tolerate 30hz, as long as the flight doesn't appear slightly jerky.  I'll have to try that.

Share this post


Link to post

1/2 refresh rate under VSync checked in NCP worked quite well for me on a flight this afternoon.  Seems like a viable option for smoothing out P3dv5.  I'm using a 60hz LG 4K monitor (32"), and I set the sim to UNLIMITED.   I expect to keep trying this setting and hopefully it could prove to be the best solution.  Who knows?  It sure is worth trying since it does NOT affect the mouse movement .

Stan

Share this post


Link to post

Stan, set screen refresh to 30Hz, set frame limit in P3D to UNLIMITED, and turn VSYNC on in P3D--you can also turn on triple buffering if that's till an option in v5.x.  Use all default Global settings in NCP.   There is NO JERKY, no weird mouse lag, nothing but the smoothest flight possible at 30fps, w/ the LEAST amount of work for your CPU & GPU.  The key is setting up P3D and MSFS so you always have some headroom in both CPU & GPU:  ideally, tune settings such that you never see worse than 95% utilization for both, in the most demanding settings.  This method asks your CPU and GPU to only deliver 30fps--because of this you can easily see how much headroom you actually have to work with, which is not the case w/ some other methods.


Noel

System:  9900K@5.0Ghz@1.21v all cores, MSI MPG Z390M GAMING EDGE AC, Noctua NH-D15S, Corsair Vengeance 32Gb LPX 3200mHz DDR4, Sabrent NVme 2Tb x 2, RTX 2070 Super FE, Corsair RM 850W PSU, Win10 Pro, Dell curved 3440x1440, Saitek Yoke, TQ & Cessna Trim Wheel, UNLIMITED frames vSync to 30Hz in P3D 4.5 & MSFS.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    45%
    $11,475.00 of $25,000.00 Donate Now
×
×
  • Create New...