Jump to content
Sign in to follow this  
Noel

3/9/21 Update: major, variable persisting fps drops?

March 9 Update: significant performance issues post update?  

212 members have voted

  1. 1. Have you experienced variable and persistent big drops in frame rate not typically occuring prior to the update?

    • Yes, and it's still happening as of March 14th or later
    • Yes, but it's completely resolved as of March 14th or later
    • No, I've not had any performance anomalies as described post-update


Recommended Posts

This is probably a good time to take a couple of weeks off from MSFS and focus on building my upgrade. Maybe by the time everything is up and running, some of these kinks will be worked out, along with whatever initial CRJ issues pop up, and the sim will be more stable when I get back in the cockpit. Between the problems stemming from the UK update and now this, it's been a rough month. I have a feeling this won't be fixed in the next day or two...

Edited by captaingoldfish

Share this post


Link to post
Share on other sites

What does the rotating white wheel at the bottom right of the screen indicate? Disk activity? Data streaming?  I am seeing it a lot. Maybe it was there before the update but I don't recall.

Is there a way to turn it off in game?

Edited by jarmstro
  • Like 1

Share this post


Link to post
Share on other sites
48 minutes ago, jarmstro said:

What does the rotating white wheel at the bottom right of the screen indicate? Disk activity? Data streaming?  I am seeing it a lot. Maybe it was there before the update but I don't recall.

Is there a way to turn it off in game?

I think that wheel is data streaming and it has been present more since SU3 and seems to coincide with my stutters and dropped framerates.  Also, my PC seems to be running very hot too yet I rarely monitor temps as I'm running a GTX3070 and 560X at stock and never got anywhere temp limits before.

For me too, the problems seemed to start a bit with WU3 and then magnify 10x with SU3.  I've never needed vsync before WU3, but that introduced tearing when panning, so I've been at 60fps limit with vsync on since and general flying in the 50s with drops into the 40s over detailed scenery areas or big airports.

I'm now getting drops into the low 20s at times where stutters even feel like FPS in single figures then suddenly I'm back up in the 50s again.

I've removed all my addon scenery since SU 3 just to be sure there are no conflicts with components at stock and a vanilla MSFS.

We really need a way to revert to pre SU3 until MS/ASOBO can sort it or a very quick hotfix if they really do know the cause.

Edited by cianpars
  • Like 1

Ryzen 5600X, AM4, 6 Core 12 thread - Nvidia 3080 - 32 Gig DDR4 RAM - Windows 11 64 bit MSFS 2020 Premium Deluxe Edition Resolution 2560 x 1440 (32 inch curved monitor)

Share this post


Link to post
Share on other sites
1 hour ago, jarmstro said:

What does the rotating white wheel at the bottom right of the screen indicate? Disk activity? Data streaming?  I am seeing it a lot. Maybe it was there before the update but I don't recall.

Is there a way to turn it off in game?

The best guess is that the streaming process takes its sweet time to load imagery. It has always been here for me but I have a mediocre 4G connection. 


Dominique

Simming since 1981 -  4770k@3.7 GHz with 16 GB of RAM and a 1080 with 8 GB VRAM running a 27" @ 2560*1440 - Warthog HOTAS - MFG pedals - MSFS Standard version with Steam

 

Share this post


Link to post
Share on other sites

Me to, I have never used the frame rate counter, don't need to see the occasional one minute or so stutters and slow down. Happens over terrain, bad weather or good. one airport in the community folder, that's all. Same recommended settings since the sim came out. 

Share this post


Link to post
Share on other sites
6 hours ago, Maxis said:

Your wording in the survey  is off but ill vote that the bug is present and has been present since the UK update. The problem just seems to have expanded more since the Sim update

Ive always flown with either rivatuner or "since February" Radeon performance monitor giving me system performance info during my flights and i noticed the gpu fallout from 100% to 0/5/30/60/80 or whatever random number it pulls it down to accompanied with stutters since that update.

I had also moved to vsync locked at 30 after that update to handle the tearing which was fine as the sim would still go above the 30.

Post the sim update 3 i had an even worse performance hit. But someone mentioned about moving the Vsync lock from 30 to 60 and i tried it and it worked. It however has not fixed the gpu fallout problem from the UK update. Which is what everyone is noticing now so in essence yes im affected.

Your statement above is 100% my issue.  FPS drops and since UK update, Vsync locked at 30 in NCP helps, but it can still happen.  The drops seem to be less in length since the latest sim update.  I hope they don't happen on landing!

  • Like 1

Simon

Share this post


Link to post
Share on other sites
7 hours ago, gore54 said:

I would like to know where the people are flying that have not experienced these sudden drops in fps and gpu tanking. For me it doesnt matter whether your at 300 ft or 39000 ft the results are the same. The problem is location specific because I can go back repeatedly and get the same result with or without anything in my community folder. I fly mostly in the USA and since the last update its a complete mess.

I have seen variable results, say comparing Australia and Canada. There is a definitely a drop since before the update. But Australia in the JF  Piper Arrow was much better than Canada in either the CJ4 with mod or the TBM with mod.

interestingly when I removed all mods from community folder the frame rates doubled. They went from 12 - 14 up to 25-30. Still lower and more stutters than I had before, but better. 

go figure...

Share this post


Link to post
Share on other sites

For me the fps drop caused by limited  mainthread started from World Update 3 (UK) and it got worse with the last SIM Update. 

  • Like 2
  • Upvote 4

Share this post


Link to post
Share on other sites

I never had any performance issues with MSFS, but after the latest patch it is a mess, not only in the sim itself, menus are also very laggy.

  • Upvote 1

| Intel I9 10900K | Corsair 32Gb 3200MHz | Asus Rog Strix OC 2080Ti | Samsung 970 EVO Plus 1TB |

Share this post


Link to post
Share on other sites

I turned off dev mode and the FPS counter to assess it by feel and the MSFS stutters feel to me like when P3D drops to single figure framerates over somewhere like London or New York. This is while flying over Kent, so undulating countryside terrain with a handful of small towns and villages for autogen. Same problem in south Essex, especially around Stansted. Goodness knows why, it's pretty flat around there.


i7-10700K; RTX 2070 Super; 16GB; P3Dv4.5HF3 & MSFS2020.

Share this post


Link to post
Share on other sites

I’ve had a general decrease in performance since release - coupled with micro stutters at any frame rate.

The big FPS drops and freezing only started in the last 2 or 3 weeks.

I’ve suspended all third party purchases now, as frankly anymore investment in MSFS would be folly.

maybe some strategic comments on third party forums would result in some pressure from them to Asobo.

  • Like 1

Ryzen 5900x - 32gb 3600Mhz RAM - Asus Strix X570-F Motherboard - ASUS TUF OC RTX 3090 - AOC AGON 32" 144Hz - LG OLED55CX5LB 55" Smart 4K Ultra HD HDR OLED - 1TB Sabrent Rocket M.2 + 2TB PCIe4.0 NVMe drive's - Samsung EVO 670 SSD 250gb - 2TB 3.5" HDD - Honeycomb Alpha Flight controls Yoke - Thrustmaster HOTAS Warthog. T Flight Rudder Pedals - Trackir

Share this post


Link to post
Share on other sites
26 minutes ago, hanhamreds said:

I’ve suspended all third party purchases now, as frankly anymore investment in MSFS would be folly

Me too. I was looking forward to the CRJ release tomorrow but forget it. Instead I've spent money on add-ons for games that actually work and dont randomly slow down to 15 FPS. What a great concept, right??

  • Upvote 2

Share this post


Link to post
Share on other sites

Just a reminder Mr Kock told me that no one at AS has seen this probelm. So there you go no probelm at all..............😀😡


David Murden  MSFS   Fenix A320  PMDG 737 • MG Honda Jet • 414 / TDS 750Xi •  FS-ATC Chatter • 

 Fenix A320 Walkthrough PDF   Flightsim.to •

DCS  A10c II  F-16c  F/A-18c • (Others in hanger) • Supercarrier  Terrains = • Nevada NTTR  Persian Gulf  Syria • Marianas • 

• 10900K@4.9 All Cores HT ON   32GB DDR4  3200MHz RTX 3080  • TM Warthog HOTAS • TM TPR • Corsair Virtuoso XT with Dolby Atmos®  Samsung G7 32" 1440p 240Hz • TrackIR 5 & ProClip

Share this post


Link to post
Share on other sites
5 hours ago, bugbee said:

Me to, I have never used the frame rate counter, don't need to see the occasional one minute or so stutters and slow down. Happens over terrain, bad weather or good. one airport in the community folder, that's all. Same recommended settings since the sim came out. 

60 seconds stutters are with me from the beginning. I can fly with stopwatch and they are always there, right on time. Has anyone find a reason of these?


Regards, Bartek Staniszewski

Share this post


Link to post
Share on other sites
11 hours ago, gore54 said:

I would like to know where the people are flying that have not experienced these sudden drops in fps and gpu tanking. For me it doesnt matter whether your at 300 ft or 39000 ft the results are the same. The problem is location specific because I can go back repeatedly and get the same result with or without anything in my community folder. I fly mostly in the USA and since the last update its a complete mess.

I am not seeing massive frame rate drops nor CPU spikes with GPU going to sleep. I run frames locked at 30. I am seeing consistently lower frame rates on the ground at complex airports, or when approaching a graphically busy area at low altitude. (But a steady decrease - no stutter to speak of).

In cruise, frames stay right at 30 consistently. This current problem may be worse on newer CPU/GPU combos. My own system is a 2016 vintage 4790K, OC at 4.5 GHz, with an 11GB 1080Ti GPU. I have 32 GB system RAM.

I am using the well-regarded 457.30 Nvidia driver, and have been since it came out in November.

I monitor performance with the perf app in the Windows Game Bar. GPU load remains consistently high at about 85 percent - no fluctuations there at all. CPU varies between 30 and 64 percent. I have seen VRAM use as high as 85 percent on the ground, and about 50 percent in high altitude cruise. RAM use stays right around 45 percent consistently. Some have reported signs of a possible memory leak, with ever-increasing RAM use, but that has not happened here.

Interestingly, I had the exact same symptoms on my system way back around the second patch in early September. At that time, it was manifested by CPU going to 100 percent regularly, with an accompanying GPU drop to 10 percent, and massive stutters. Originally I had hyper threading turned off, giving only 4 cores. When I turned HT on, it was much much better. I doubt that is the problem now though for those who are experiencing it.

I wonder if this is related to the cache in some way? The fact that some users see the problem come and go at very specific geographic locations, and can duplicate the issue at those same locations every time, might point to a cache issue. 

FWIW, I do not use rolling or manual cache at all - nor AI, multiplayer or ATC. I do use Live Weather on every flight. Render scaling is at 80, (with a 4K monitor). Terrain and object detail is at 140. Most graphics settings HIGH, with clouds and textures at ULTRA.


Jim Barrett

Licensed Airframe & Powerplant Mechanic, Avionics, Electrical & Air Data Systems Specialist. Qualified on: Falcon 900, CRJ-200, Dornier 328-100, Hawker 850XP and 1000, Lear 35, 45, 55 and 60, Gulfstream IV and 550, Embraer 135, Beech Premiere and 400A, MD-80.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...