Jump to content
Sign in to follow this  
joe cooper

SPITFIRE out NOW!!

Recommended Posts

Posted (edited)
10 hours ago, lambourne said:

The flight dynamics have really changed, it's a much more docile aeroplane now. Certainly takeoffs are easier than ever, even though I wound on rudder trim while playing about earlier I'm sure there was almost no swing on takeoff.

Does the belly tank disappear if you don't fill it?

O she still can swing alright 😜

I use as postered 2 pagers back, 1 up trim and I use full right rudder trim. If you start your roll (boost 0)with stick full back then increase boost and relax stick with speed, then boost 4 then when all is fine boost 6-7. 

She can still pull left and right as I have seen. 😉

Another way to take off that also works really well is to simply old the stick full back all the time, she sticks to the ground and then floats off at around 90 mph but you noise never drops. But for short takeoffs it works realy well she is also more planted on the ground.  

Edited by Nyxx

David Murden  MSFS  • Ryan ST-A • JF PA-28R IV   M20R • AH Spitfire MKI • FI Spitfire MKIX • Milviz FG-1D • TBM CRJ • PMDG DC 6 •  DCS if you want the ultimate challenge

10900K@4.9 All Cores HT ON   32GB DDR4  3200MHz RTX 3080  • Thrustmaster, Warthog HOTAS & TPR • TrackIR 5 & ProClip • Arctis PRO Headset with GameDAC Samsung G7 32" 1440p 240Hz • 

Share this post


Link to post
Share on other sites

I am still having the problem - all switches are in the correct position - centre 1 & external 1 tanks are full - yet I have an empty indication on my fuel gauge(excep t when I preess the bottom tank button) - now the engine is dying on the runway before I can even set the trims - try a startup & the engine dies - perplexing to say the least

as stated before the upgrades it all worked well

help please


Rattso

Cooler Master Cosmos 700M - Asus Rampage IV - intel i9-7920x 12 core - 128gb Corsair Dominater - EVGA Kingpin 3090 - Silverstone 1500W P/S - Creative AE-7 - intel Optane 500gb -3x 2tb M2 SSDs - 2x 2tb Samsung EVO SSDs - 1x Hybrid 2tb HDD - Thrustmaster Warthog - MFG Crosswind - Samsung G9 49" monitor

Share this post


Link to post
Share on other sites

Did you delete the orignal from you comunnity folder before installing the new version?


David Murden  MSFS  • Ryan ST-A • JF PA-28R IV   M20R • AH Spitfire MKI • FI Spitfire MKIX • Milviz FG-1D • TBM CRJ • PMDG DC 6 •  DCS if you want the ultimate challenge

10900K@4.9 All Cores HT ON   32GB DDR4  3200MHz RTX 3080  • Thrustmaster, Warthog HOTAS & TPR • TrackIR 5 & ProClip • Arctis PRO Headset with GameDAC Samsung G7 32" 1440p 240Hz • 

Share this post


Link to post
Share on other sites
10 hours ago, Rattso said:

I am still having the problem - all switches are in the correct position - centre 1 & external 1 tanks are full - yet I have an empty indication on my fuel gauge(excep t when I preess the bottom tank button) - now the engine is dying on the runway before I can even set the trims - try a startup & the engine dies - perplexing to say the least

as stated before the upgrades it all worked well

help please

The Spitfire has an always-on electrical system. The fuel gauge is on a pushbutton switch so it only activates when the button is held in, else it drains the battery.

You've definitely got the fuel pump turned on? Buried right beneath the trim wheel, I move the camera down to see it and turn it on. Rad flap system on too? Switch just aft of the fuel pump one, it's on the lower LHS side of the cockpit. If that is off on the ground you're likely to overheat the engine.

Last thing I can think of, mixture? Do you have a throttle lever mapped to mixture and have you set it fully forward? If it's fully rear that's the idle cutoff position in MSFS.


i7-10700K; RTX 2070 Super; 16GB; P3Dv4.5HF3 & MSFS2020.

Share this post


Link to post
Share on other sites

all sorted now - found the little radiator cowl switch (required some interesting head positions on head tracking to a. see it & b. decide which way to acitivate it) - no probs with temps now - even managed a dead stick when the engine failed - wasn't game to go out of the circuit area until I had it sorted - thx again for the helpul replies

  • Like 1

Rattso

Cooler Master Cosmos 700M - Asus Rampage IV - intel i9-7920x 12 core - 128gb Corsair Dominater - EVGA Kingpin 3090 - Silverstone 1500W P/S - Creative AE-7 - intel Optane 500gb -3x 2tb M2 SSDs - 2x 2tb Samsung EVO SSDs - 1x Hybrid 2tb HDD - Thrustmaster Warthog - MFG Crosswind - Samsung G9 49" monitor

Share this post


Link to post
Share on other sites

Did a flight last night and both the oil and radiator temp gauges stayed on 0.  Couldn't for the life of me work out why.   Can anyone suggest something i might have forgotten to do in my sleepy state before i go and report it as a bug?


Ryzen5 3600 | RTX 2060 Super | 32GB HyperX Fury 3200mhz | B550 Aorus Elite v2 |2x 1TB WD Blue NVMe | 4x500Gb Kingston SSD | Corsair RM650w PSU |

Share this post


Link to post
Share on other sites
Posted (edited)

My favorite Aircraft at one of my favorite airports back from Dunkirk. 🙂

Screenshot-1247.png

 

Edited by Nyxx
  • Like 1

David Murden  MSFS  • Ryan ST-A • JF PA-28R IV   M20R • AH Spitfire MKI • FI Spitfire MKIX • Milviz FG-1D • TBM CRJ • PMDG DC 6 •  DCS if you want the ultimate challenge

10900K@4.9 All Cores HT ON   32GB DDR4  3200MHz RTX 3080  • Thrustmaster, Warthog HOTAS & TPR • TrackIR 5 & ProClip • Arctis PRO Headset with GameDAC Samsung G7 32" 1440p 240Hz • 

Share this post


Link to post
Share on other sites
On 5/27/2021 at 10:37 PM, lambourne said:

The Spitfire has an always-on electrical system. The fuel gauge is on a pushbutton switch so it only activates when the button is held in, else it drains the battery.

You've definitely got the fuel pump turned on? Buried right beneath the trim wheel, I move the camera down to see it and turn it on. Rad flap system on too? Switch just aft of the fuel pump one, it's on the lower LHS side of the cockpit. If that is off on the ground you're likely to overheat the engine.

Last thing I can think of, mixture? Do you have a throttle lever mapped to mixture and have you set it fully forward? If it's fully rear that's the idle cutoff position in MSFS.

Not quite accurate.

The FlyingIron has a Battery On switch activated by advancing the throttle lever forward to a 1/3. Cold and Dark the Battery is in the Off position. Although this is not how the real world marks are wired it can cause confusion for pilots new to the FlyingIron mark. Advancing the throttle forward switches the battery on. If you want to switch it off again you can lean forward and locate the toggle switch just forward of the throttle to do so.

 

Share this post


Link to post
Share on other sites
On 5/31/2021 at 1:24 PM, The Moose said:

Did a flight last night and both the oil and radiator temp gauges stayed on 0.  Couldn't for the life of me work out why.   Can anyone suggest something i might have forgotten to do in my sleepy state before i go and report it as a bug?

Same problem here.  I think it must be a bug.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

@The Moose @briwith

I do not see it on my rig so I don't think it is a bug.

When you installed the 1.02rc2 update did you delete the older version from the Community folder and replace it by the new version or did you  just paste the new over the older version ?  

 

 

Edited by Dominique_K
  • Like 1

Dominique

Simming since 1981 -  4770k@3.7 GHz with 16 GB of RAM and a 1080 with 8 GB VRAM running a 27" @ 2560*1440 - Warthog HOTAS - MFG pedals - MFS Standard version with Steam

 

Share this post


Link to post
Share on other sites
11 minutes ago, Dominique_K said:

@The Moose @briwith

I do not see it on my rig so I don't think it is a bug.

When you installed the 1.02rc2 update did you delete the older version from the Community folder and replace it by the new version or did you  just paste the new over the older version ?  

 

 

I always delete old versions, even when developers say its unnecessary.

Anyway, I've only had the non functioning temperature gauges happen once so far, so not an issue really.


Ryzen5 3600 | RTX 2060 Super | 32GB HyperX Fury 3200mhz | B550 Aorus Elite v2 |2x 1TB WD Blue NVMe | 4x500Gb Kingston SSD | Corsair RM650w PSU |

Share this post


Link to post
Share on other sites

Is it me or the last update has not really corrected the nose raising up issue  when the flaps are down ? 

Now my recommendation of the day : Do a pattern flight around LGTH Thiva in Greece.  Great landscape with a lake and hills.  Your chance to do a take off at a boost of 12 and to break your neck at landing. The kind of strip where you have to do everything perfectly right (speed, pitch, situational awareness) or die.  

 

  • Like 3

Dominique

Simming since 1981 -  4770k@3.7 GHz with 16 GB of RAM and a 1080 with 8 GB VRAM running a 27" @ 2560*1440 - Warthog HOTAS - MFG pedals - MFS Standard version with Steam

 

Share this post


Link to post
Share on other sites
Posted (edited)
57 minutes ago, Dominique_K said:

Is it me or the last update has not really corrected the nose raising up issue  when the flaps are down ? 

Now my recommendation of the day : Do a pattern flight around LGTH Thiva in Greece.  Great landscape with a lake and hills.  Your chance to do a take off at a boost of 12 and to break your neck at landing. The kind of strip where you have to do everything perfectly right (speed, pitch, situational awareness) or die.  

 

It was one of the first things I looked at. When you first drop them not a lot happens but then I find it nose dives, so it is a bit of a delay. I always have throttle off when doing this.

Throttle off to get down below 160mph, Flaps down then boost back to 0 then gear down.

Edited by Nyxx
  • Like 1

David Murden  MSFS  • Ryan ST-A • JF PA-28R IV   M20R • AH Spitfire MKI • FI Spitfire MKIX • Milviz FG-1D • TBM CRJ • PMDG DC 6 •  DCS if you want the ultimate challenge

10900K@4.9 All Cores HT ON   32GB DDR4  3200MHz RTX 3080  • Thrustmaster, Warthog HOTAS & TPR • TrackIR 5 & ProClip • Arctis PRO Headset with GameDAC Samsung G7 32" 1440p 240Hz • 

Share this post


Link to post
Share on other sites
On 5/29/2021 at 10:33 AM, quantumpion said:

Any news on when the update is coming to the store?

?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...