Jump to content

Sign in to follow this  
pinepix62

GTN750 in a Carenado D18 - No VOR or ILS signal

Recommended Posts

Posted (edited)

I installed the RXP GTN 750 into the Carenado Beech D18 using the F1 GTN replacement function.

Although I can tune the NAV1 radio signal and the HSI seems to pick it up as the pointer will point towards the VOR when I adjust the course but the NAV flag in the HSI does not disappear and the autopilot will not follow the course and the HSI will not display or capture the glideslope if tuned to an ILS. I made sure the GTN 750 is set to VLOC and the autopilot is set to NAV but I can not get it to work. Is there a hidden GPS/VNAV switch or setting on the GTN 750 settings I am missing. All the other planes work fine after I got rid of the F1 GTN's on my system.

PS - I am using P3D V5.1

Edited by RXP
New info

Johan Pienaar

 

Share this post


Link to post
Share on other sites

What settings have you established in the configuration panel?  See the RXP GTN Users Manual. 

Windows Start Menu, Reality XP, User's Manual.

 

image.png.155a9ec02badc32c2a52edfe4c7bbc5c.pngimage.png.e19dc73c80c354ccf1c80ef763cf8998.png

  • Like 1

Frank Patton
MSI Z490 WiFi MOB;  i7 10700k Comet Lake 3.8 Ghz CPU; Ripjaws 32 gb DDR4 3600; ASUS GTX 1070 TI Turbo 8GB; MasterCase H500M; Corsair H100i Pro cooler; Corsair RMX850X PSU; ASUS VG289 4K 27"; Honeycomb Alpha Yoke A+.  Former USAF meteorologist & ground weather school instructor; AOPA Member #07379126 
                        There is no limit to what a man can do or where he can go if he doesn’t mind who gets the credit! - Benjamin Jowett

 

Share this post


Link to post
Share on other sites

I had a look at the manual and played wit the settings but nothing worked.

You can see that the NAV1 radio is tuned to the selected frequency as the DME gives the correct reading and the HSI needle is and the to/from pointer is correct but the NAV error flag in the HSI stays on. My settings are attached.

20210407171652-a94edf2a.jpg

 

20210407171654-f525e28b.jpg

 

20210407171653-de571f7b.jpg


Johan Pienaar

 

Share this post


Link to post
Share on other sites
Posted (edited)

Try Connect GPS to VOR..

Carenado has a record of buggy avionics, so who knows what might be going on behind the scenes..

Do the HSI and autopilot work correctly, when selecting the Carenado GNS in the panel?

What does the HSI look like, when you stop the GTN at the test page when powering up?

Send me a PM if you want to debug this further.. 😉

 

 

Edited by Bert Pieke

Bert

Share this post


Link to post
Share on other sites

Bert, connecting GPS to VOR does nothing. If I use GPS as the source then the AP follows the GPS track and the flag is missing, working as it should.

Tried the RXP GTN in the Cessna C337 and getting the same problem. So it seems to be deeper than the D18 😲


Johan Pienaar

 

Share this post


Link to post
Share on other sites
10 minutes ago, pinepix62 said:

Tried the RXP GTN in the Cessna C337 and getting the same problem. So it seems to be deeper than the D18 😲

Well, the C337 I have installed... give me a scenario I can try.

  • Like 1

Bert

Share this post


Link to post
Share on other sites
38 minutes ago, Bert Pieke said:

Well, the C337 I have installed... give me a scenario I can try.

Just flew the C337 at KTPA and it followed the ILS R01L just fine... NAV1 on 108.90

  • Like 1

Bert

Share this post


Link to post
Share on other sites

When the GTN is in VLOC mode, it won't override anything.

The only reason I can see for this kind of problem, is when the aircraft NAV/GPS switch is not matching the GTN GPS/VLOC mode. In this case, the GTN might be indicating VLOC but the NAV/GPS switch is in GPS mode and therefore you'll get wrong information.

The NAV/GPS switch mode is in the simulator and has nothing to do with the RXP GTN though. Either the aircraft panel is offering a distinct switch you can change, or, it is internally managing the simulator switch state and usually displays NAV or GPS light somewhere. In any case, you might want to change the RXP GTN CDI Sync Mode to GPS <==> SIM so that any change on one is reflecting on the other, and compare whether this is making any difference.

Otherwise, are you sure at this location with this frequency tuned in, you do receive valid signal with a default aircraft like the Mooney?


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Let your voice be heard and help us make a difference for you: Vote !
Open up communications with Reality-XP (Microsoft Flight Simulator Forums)

Share this post


Link to post
Share on other sites
1 hour ago, RXP said:

Otherwise, are you sure at this location with this frequency tuned in, you do receive valid signal with a default aircraft like the Mooney?

Flew it an a A2A V35B with the same panel setup and it work in that case. Will look for a hidden NAV/GPS Switch


Johan Pienaar

 

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, pinepix62 said:

Flew it an a A2A V35B with the same panel setup and it work in that case. Will look for a hidden NAV/GPS Switch

The configuration settings are aircraft specific.  i.e. the settings are saved in a file named "RealityXP.GTN.ini" in each aircraft model's primary folder.

Edited by fppilot

Frank Patton
MSI Z490 WiFi MOB;  i7 10700k Comet Lake 3.8 Ghz CPU; Ripjaws 32 gb DDR4 3600; ASUS GTX 1070 TI Turbo 8GB; MasterCase H500M; Corsair H100i Pro cooler; Corsair RMX850X PSU; ASUS VG289 4K 27"; Honeycomb Alpha Yoke A+.  Former USAF meteorologist & ground weather school instructor; AOPA Member #07379126 
                        There is no limit to what a man can do or where he can go if he doesn’t mind who gets the credit! - Benjamin Jowett

 

Share this post


Link to post
Share on other sites

KTPA ILS R01L - Everything looks fine DME active LOC active GS active but HSI shows red and white error chevrons 

I can not find any other NAV/GPS switch

3 hours ago, RXP said:

Sync Mode to GPS <==> SIM

Tried this setting, did not work 

13 minutes ago, fppilot said:

The configuration settings are aircraft specific

Aware of this.

Thanks for the help

20210407222755-61d2c35f.jpg


Johan Pienaar

 

Share this post


Link to post
Share on other sites
1 hour ago, pinepix62 said:

KTPA ILS R01L - Everything looks fine DME active LOC active GS active but HSI shows red and white error chevrons 

And if you take the same aircraft in the same conditions but without the GTN, the HSI is no longer showing the red/white error chevrons?

Then if you take the same but with the GTN again, and this time you deselect the GTN "Link to HSI", is it still failing?

I'm sorry for the time it might take but the only way is cross-checking with different settings in order to isolate a potential culprit.


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Let your voice be heard and help us make a difference for you: Vote !
Open up communications with Reality-XP (Microsoft Flight Simulator Forums)

Share this post


Link to post
Share on other sites

I have sent a copy of my panel and ini file to the OP to try..

  • Like 3

Bert

Share this post


Link to post
Share on other sites
3 hours ago, pinepix62 said:

By a process of elimination I found the window that contains gauge00=F1GTN!GTNStack,  0,0,255,870 seems to be causing the problem. Seems to be conflicting with the RXP GTN750. Maybe the utility can be updated to remove this window when you do the replacement.

I'm glad you've sorted this out! Thank you @Bert Pieke for your help with this!

As for the conflicting gauge, I'm quite surprised this would be a factor in itself, unless the aircraft gauges are using this gauge to detect a "GTN" presence in the cockpit and whether they'd process the simvars data differently.

A good test for this would be to add this gauge reference in a default aircraft panel, or another aircraft panel eventually, and see whether the same problem is happening as well. If it does, then I'll definitely consider adding an option to warn users and remove this entry from the panel.cfg upon detection.

  • Like 1

Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Let your voice be heard and help us make a difference for you: Vote !
Open up communications with Reality-XP (Microsoft Flight Simulator Forums)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    49%
    $12,400.00 of $25,000.00 Donate Now
×
×
  • Create New...