Jump to content
Sign in to follow this  
Kuax

Another possible cure for sound causing stutters

Recommended Posts

Great tip, worked a treat for me as well.

I used the MSI tool which made it very easy, just click and apply.

I have and old system with a PCI soundcard (a good one though) and my Nvidia gfx card shared the same linebased IRQ as my soundcard.

The soundcard was linebased only, but the gfxcard could be set to msi, so I changed that and voila, no more rumble and pops despite fps going over 100.

Then I noticed the soundcard still shared IRQ with some chipset thing, so I put the soundcard in another PCI slot and now there are now more shared IRQs what so ever.

This part of the system should now be running optimally.

Cheers mate!

Edited by neumanix

Share this post


Link to post
Share on other sites

Well, it didn't fix the sound distortion >100 fps after all, as I stated in the post above.

But it was still nice to get the IRQ channels optimized a little.

Share this post


Link to post
Share on other sites

FS9 does not support unlimited framerate.
If the framerate exceeds 60fps the sound stutters and distorts.
To fix the problem, use the limiter at maximum 60 fps.


Creatore di * FS9 Supersky * ( plugin Atmo Ambient Environment ).
* XP11 atmoXphere * (
Atmo Ambient Environment plugin ) creatore.

-------------------------------------------------- ---------------------
Pc intel i3-4160 3.6ghz, 8gb ram, (new) GeForce RTX-3060 12gb, Win10 Home 64bit
--------------- --------------------------------------------------------

Share this post


Link to post
Share on other sites
On 4/15/2021 at 1:05 PM, efis007 said:

FS9 does not support unlimited framerate.
If the framerate exceeds 60fps the sound stutters and distorts.
To fix the problem, use the limiter at maximum 60 fps.

Not true. The fps limit for sound distortion is at 100, for whatever reason. It seems to be the wind sounds that distort. You can test this by unlocking the frames in a situation where you get >100fps and enable/disable environment sound in the sound settings.

As a TrackIR user I prefer >100fps, so a way around this distorted sound is to edit your aircrafts sound.cfg and exchange the wind sound files for silent ones. There is already one in FS9/sound called silence.wav.

Also the general default wind sounds in FS9/sound need to be replaced with silent .wav files.

This way you get rid of the distortions but keep other environment sounds, such as AI traffic etc.

Edited by neumanix

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...