Archived

This topic is now archived and is closed to further replies.

Gypsy Baron

Default window size in FSX....

Recommended Posts

I fly FSX in windowed mode, 1280 x 1024, and after I first installedFSX each time I hit "Fly" I would have to re-position drag the windowto fill my screen. It seemed to default to 800x600. At some point I did something ( scratches head... ) and FSX began to "remember" that I use 1280x1024 and when I hit "Fly" the window wouldfill my screen.Now, after having hadto do several "repair" cycles due to myriad FSX crashes and glitches, I'm back to having to drag that #^&*&%#@window and re-size it every time. Granted, I haven't much else todo while FSX plods along and loads for 2-3 minutes after "Fly" but it IS annoying that it doesn't size that window correctly.I've created new "default" flights and saved them sitting at thegate with the window properly sized but this has no effect.I've scanned my fsx.CFG file for a clue and the only thing I see thereis a statement:Location=-2,-4,1284,993,.DISPLAY1which is/was the last size I dragged that window to but it doesn'tseem to effect diddley-squat ( <- a technical term ).Changing : Maximized=0 to Maximized=1will start it OK in full screen mode but ALT-RET puts it right back to an 800x600 window.After the initial re-sizing, subsequent flights will start withthe window properly sized, but as soon as I exit FSX and startit up again, it's back to point-click-drag again.Does ANYBODY have a clue as to what one must do to get FSX toremember what the USER wants?TIA, Paul

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

HelloJust out of curiosity why do you fly in windowed mode as opposed to full screen

Share this post


Link to post
Share on other sites

Hello Paul,I believe that the minimum resolution for FS is 1024 x 768, not 800 x 600.You could try changing that line in the cfg file to:Location=0,0,1278,1016,.DISPLAY1or something along those lines. What you had there before seems to be larger than your monitor resolution.I think that the first 2 coordinates are the location of the upper left-hand corner of the window, so they should probably be 0,0, if that is correct.You should also make sure that both your monitor properties and the FS screen resolution are both set to 1280 x 1024.I always use windowed mode and get better performance, plus it may be that there are some issues with full-screen mode.Anyway, I am not an expert on this, but had the same problem as you and fixed it this way.Best regards.Luis

Share this post


Link to post
Share on other sites

>Did you select 1280 X 1024 under your FSX display settings?>>JimMy understanding is that the display resolution selected in FSX only applies to full screen, that in windowed mode it runs in the resolution your screen is set for.

Share this post


Link to post
Share on other sites

>>Did you select 1280 X 1024 under your FSX display settings?>>>>Jim>>My understanding is that the display resolution selected in>FSX only applies to full screen, that in windowed mode it runs>in the resolution your screen is set for. OK...I've found the "culprit"....I had edited my fsx.CFG file to add the specification "DisablePreload = 1" to the Main section, in an effort to speed up the slow loading time from tray-icon-click to main menu. That seems to cause FSX to jsut plain ignore the prior screen size data "Location=1,1,1279,987,.DISPLAY1" when starting a flight, rather than loading at that resolution/position. Just another little FSX glitch that slipped through what I'm SURE was rigorous testing off>. In any case, setting that parameter to "0" now gets me into the cockpit in a properly sized window. To answer the questions of those of you kind enough to reply, my screen resolution is 1280x1024x32. Also, I had 1280x1024 selected in the FSX display setup and that, of course, appears in the fsx.CFG file under the "DISPLAY.Device...." entry. I prefer flying in windowed mode as I often keep track of memory usage with a utility that shows that in the tray, along with my ZoneAlarm activity indications. Also, before changing video cards and flying FS9, I had an ATI AIW Pro card and often had a TV window in the upper right corner of my cockpit for those long, boring flights at 30K+ so got used to being in windowed mode :) As to the FSx default resolution, the window it opened looked to me to be 800x600, as it was about the same size as the picture of a B-25 and F4U that adorns the center of my desktop and that is 800x600. Paul ( will be more aware of "tweaks" and unwanted side effects.... )

Share this post


Link to post
Share on other sites

I have a similar issue, having just acquired (and successfully installed) FSX on my Dell, I found that during the initial set up of a flight (Flight Planner, Weather etc) the screen res stayed as it was but when I finally hit Fly Now, it decided to change the resolution and gave me the 2D cockpit with black bars either side of it. However when cycling through the other views, the screen res stayed as it normally is (1366 x 768 and yes it's a laptop until I can upgrade my desktop again).

 

Any way of getting the 2D cockpit back to full screen? Never had this problem with FS9 on the XP desktop, which has considerably less power than the laptop in all areas.

Share this post


Link to post
Share on other sites