Jump to content
Sign in to follow this  
RobSys

MSFS won't start

Recommended Posts

Hi all...

 

Today my MSFS (Purchased via Microsoft Store) wont start at all. Running the program start opens the Microsoft store window to Gaming Services.

Within the MS Store the sim is listed as installed.

On my C:drive, under WindowsApps FlightSimulator.exe has zero bytes... My Packages folder appears to be intact...

I recently transfered my C: drive to a new SSD however I have run MSFS several times since then...

I'm a bit at a loss...

Anyone have any suggestions...?

Thanks,

 

Rob

 


---------------------------------------------

System: Gigabyte Z490 Aorus Master, i9-10900K, EK Supreme water cooling, 32GB G Skill Ripjaws V F4-4000C 16D-32GVK DDR4, Asus GTX 3070, Acer Predator XB271HU + Asus MX27AQ monitors, WD SN850 1 TB M2 drive, Intel 750 Nvme 480 GB, Samsung 1 TB SSD, 3 TB + 4 TB HDD's, Honeycomb Alha + Bravo, Thrustmaster TPR Pendulum Rudder, Saitek Radio panel..

Share this post


Link to post
Share on other sites
2 hours ago, RobSys said:

Anyone have any suggestions...?

I got exactly the same problem yesterday. 21:00GMT.

I think it had something to do with the MS servers. I could not start MSFS, the Store opened and offered to update Gaming services. But it hung up when trying to do it.

I will try to re-launch MSFS tomorrow.

If the problem doesn't resolve itself, I'll try a solution from @Chock.

Edited by Nickbe

Nick Bebyakin   / Handmade cameraset for Ezca 2/3 - Ezdok v2  and Ezdok v3
EZdok Software    http://www.ezdok-camera.com/

i5-9500F@4.4GHz / 20Gb / RTX 2060-OC-6Gb / Win10x64 / MSFS2020

Share this post


Link to post
Share on other sites
10 minutes ago, Nickbe said:

But it hung up when trying to do it.

For me terminating the update manually when it said "installing" endlessly and then restarting the pc did the trick. One hour or so later the store offered the update again and it installed within seconds. Maybe worth a try...

Share this post


Link to post
Share on other sites
1 minute ago, Tom_L said:

For me terminating the update manually when it said "installing" endlessly and then restarting the pc did the trick. One hour or so later the store offered the update again and it installed within seconds. Maybe worth a try...

Yes, I will. I'll just be at the MSFS computer tomorrow.

In any case, we have a great solution from @Chock 😉.


Nick Bebyakin   / Handmade cameraset for Ezca 2/3 - Ezdok v2  and Ezdok v3
EZdok Software    http://www.ezdok-camera.com/

i5-9500F@4.4GHz / 20Gb / RTX 2060-OC-6Gb / Win10x64 / MSFS2020

Share this post


Link to post
Share on other sites

The solution is to reinstall GamingServices and GamingServices.net. Go to regedit and delete two items there regarding the gamingservices and then rebot your computer. Be careful when editing anything in the registry.

Go to HKEY_LOCAL_MACHINE_, system , currentControllSet, Services

Remove the Gamningservices and the GamningServices.Net

Restart the computer and go to the windows store and check for updates and voliá!

 


Come here you big, beautiful cup of coffee and lie to me about how much we’re going to get done today.

Share this post


Link to post
Share on other sites
2 hours ago, Tom_L said:

For me terminating the update manually when it said "installing" endlessly and then restarting the pc did the trick. One hour or so later the store offered the update again and it installed within seconds. Maybe worth a try...

Don't need to reboot your PC, simply quit the MS Store app and login back again


Cheers, Ed

MSFS Steam - Win10 Home x64 // Rig: Corsair Graphite 760T Full Tower - ASUS MBoard Maximus XII Hero Z490 - CPU Intel i9-10900K - 64GB RAM - MSI RTX2080 Super 8GB - [1xNVMe M.2 1TB + 1xNVMe M.2 2TB (Samsung)] + [1xSSD 1TB + 1xSSD 2TB (Crucial)] + [1xSSD 1TB (Samsung)] + 1 HDD Seagate 2TB + 1 HDD Seagate External 4TB - Monitor LG 29UC97C UWHD Curved - PSU Corsair RM1000x - VR Oculus Rift // MSFS Steam - Win 10 Home x64 - Gaming Laptop CUK ASUS Strix - CPU Intel i7-8750H - 32GB RAM - RTX2070 8GB - SSD 2TB + HDD 2TB // Thrustmaster FCS & MS XBOX Controllers

Share this post


Link to post
Share on other sites

Hi all...

Well..., I solved the problem! A rather drastic solution!

After MANY issues, including uninstalling MSFS, then Microsoft Store refusing to re-install MSFS to the store failing to open altogether, I finally re-installed Windows 10 from scratch! (Windows needed replacing anyway as I've upgraded my MB, CPU, power supply and Graphics card. Besides this was about the longest time ever between new Win 10 installs!)

Then..., MSFS installed...! I did keep a copy of my packages folder which I copied to the default location, That reduced the download to "only" 77 GB... 8 hours later and I could finally play with my new Honeycomb Alpha and Bravo gear...


---------------------------------------------

System: Gigabyte Z490 Aorus Master, i9-10900K, EK Supreme water cooling, 32GB G Skill Ripjaws V F4-4000C 16D-32GVK DDR4, Asus GTX 3070, Acer Predator XB271HU + Asus MX27AQ monitors, WD SN850 1 TB M2 drive, Intel 750 Nvme 480 GB, Samsung 1 TB SSD, 3 TB + 4 TB HDD's, Honeycomb Alha + Bravo, Thrustmaster TPR Pendulum Rudder, Saitek Radio panel..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...